Announcement

Collapse
No announcement yet.

Fatal error - but only for a few users

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • [Bug / Issue] Fatal error - but only for a few users

    Hello, I'm running vB 5.2.5 with PHP 5.6.28 and MySQL 5.5.54. For the most part and most users, I'm not seeing any issues. However, on a select few accounts, they've been getting a lot of errors similar to the following on some threads:

    Fatal error: Maximum execution time of 30 seconds exceeded in /home/warbar/public_html/rok/includes/vb5/template/cache.php on line 168

    The exact file and line can change, but that's the most common one. It occurs both in the default template and in my (very slightly) modified one. Searching for this error turns up a lot of references to changing the execution default time in php.ini, but they're mostly several years old. Since it was only for a few users I initially dismissed their complaints as being due to cache, cookies, etc. - but here's the rub. The error is tied specifically to those user accounts, and not to a machine or browser.

    I had a few of the users give me permission to log in using their credentials, and I did so on many machines and with a variety of browsers. In every case, if I used their login I could recreate the issue, but if I used someone else's it typically loaded right up. Would anyone have any thoughts/direction on how to correct the issue with these particular user accounts?

  • #2
    Just curious, are they from a specific user group? In other words, do all those accounts have that in common? Just thinking that narrowing or finding more information may help support.

    Also, are you seeing the error or is it causing an error or non function? You may want to disable display errors through your php.ini. I know support recommends this if it isn't causing any actual problems.

    William

    Comment


    • #3
      So far the users reporting the error have come from more than one user group William, so I wouldn't think that was the issue. Good thought, though. What you see is that after the page times out, you're left with nothing but the page background and that error message (or similar) quoted above.

      Comment


      • #4
        This may be due to user's subscriptions. You should definitely try to increase the max execution time in PHP.

        GIPHY for vB5 AutoLinker Auto-Create Flag Report Topic Social Icons in Postbit Clear Cache Cron DragDrop Upload Topic AJAX AutoUpdate Custom Avatars Selector Stop Links in Posts...and more!

        Comment


        • #5
          Increasing the PHP Timeout will hide the problem but it won't really go away. The issue is probably caused by too many private messages being stored on the accounts. Increase the time out and have them delete private messages from their account. You can also try deleting their private messages in the AdminCP by using the Quick Links dropdown on their user profile. There is a fix to a query in 5.2.6 to help alleviate some of the issues related to this.

          Upgrading MySQL to 5.7 will also help with running queries on the site.

          http://tracker.vbulletin.com/browse/VBV-16730
          Translations provided by Google.

          Wayne Luke
          The Rabid Badger - a vBulletin Cloud demonstration site.
          vBulletin 5 API

          Comment


          • #6
            Thank you for the information, folks. I'll check on the PM situation and inquire with my host about upgrading MySQL.

            Comment

            widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
            Working...
            X