Announcement

Collapse
No announcement yet.

Email parsing / syntax issue.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Email parsing / syntax issue.

    When my forum sends emails that contain content from the forum in the body (e.g. a PM or thread subscription) the syntax or parsing is messed up. For example, I sent myself a PM from a test account.

    This is what I sent:
    Code:
    Third test. Line break after this.
    
    Now I put in a & to test that.
    This is what came in the email.
    Code:
    Dear John,
    
    TestID has sent you a prviate message.  You can view it at: url is correct here.
    
    Here is a preview of the message:
    Third test.&nbsp; Line break after this.<br />
    <br />
    Now I put in
    
    All the best,
    My forum name

  • #2
    We don't support HTML in email at this time. This is how it looks with HTML in the content.
    Translations provided by Google.

    Wayne Luke
    The Rabid Badger - a vBulletin Cloud demonstration site.
    vBulletin 5 API - Full / Mobile
    Vote for your favorite feature requests and the bugs you want to see fixed.

    Comment


    • #3
      Can I turn HTML off so it just comes through as plain text?

      Comment


      • #4
        There is a bug around the lack of plaintext parsing in emails:

        http://tracker.vbulletin.com/browse/VBV-13781

        Vote for:

        - *Admin Settable Paid Subscription Reminder Timeframe*
        -
        *PM - Add ability to reply to originator only*
        - Add Admin ability to auto-subscribe users to specific channel(s)
        - "Quick Route" Interface...

        Comment


        • #5
          That appears to be from 2015. Are you kidding me? Sending reply or PM notifications is a core functionality of the forum. I'm not trying to send HTML, I just want the message to sent not looking like garbage. Is there an ETA on a fix?

          Comment


          • #6
            Originally posted by imahawki View Post
            That appears to be from 2015. Are you kidding me? Sending reply or PM notifications is a core functionality of the forum. I'm not trying to send HTML, I just want the message to sent not looking like garbage. Is there an ETA on a fix?
            Not at this time. Harsh reality is there are other priorities for the developers right now.

            Voting and commenting on the bug is the best way to try and push it forwards.
            MARK.B | vBULLETIN SUPPORT

            TalkNewsUK - My vBulletin 5.6.3 Demo
            AdminAmmo - My Cloud Demo

            Comment


            • #7
              No, there isn't an ETA on a fix yet. Nor has the majority of our customer base expressed that this is a priority for them. It has three votes. Nor, is this considered a critical issue by the criteria set forth in JIRA.

              Here is the list of priority issues that customers have voted for: http://tracker.vbulletin.com/browse/...arissues-panel
              Translations provided by Google.

              Wayne Luke
              The Rabid Badger - a vBulletin Cloud demonstration site.
              vBulletin 5 API - Full / Mobile
              Vote for your favorite feature requests and the bugs you want to see fixed.

              Comment


              • #8
                Hold on, I want to clarify. I'm not asking for HTML mail. I'm just asking that the forum not screw up plain text. The email notifications I get from THIS forum are fine so is this a setting in the forum software?

                Comment

                Related Topics

                Collapse

                Working...
                X