Announcement

Collapse
No announcement yet.

Mysql error after upgrade

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Mysql error after upgrade

    Upgraded from 5.2.3 to 5.2.4 latest. I started to get this errormessages. They come a few hundered within an our or so.

    The table exist, I have repaired it and it workes fine.

    Can't find any errors when using forum.


    PHP Code:
    Database error in vBulletin 5.2.2:




    Invalid SQL:

    SELECT `varname`,`languageid`,`textFROM vb5_phrase

    WHERE 
    `varnameIN ('message') AND `languageidIN (5,0,-1);




    MySQL Error   Table 'zoopet.vb5_phrase' doesn't exist

    Error Number  : 1146

    Request Date  : Sunday, October 30th 2016 @ 05:46:20 PM

    Error Date    : Sunday, October 30th 2016 @ 05:46:20 PM

    Script        : http:///index.php?option=com_content&view=article&id=419

    Referrer      : 

    Username      : Gäst

    Classname     : vB_Database_MySQLi

    MySQL Version : 

  • #2
    You didn't run the upgrade script. According to that error, the database is a 5.2.2 database, not a 5.2.4 database.

    Please don't PM or VM me for support - I only help out in the threads.
    vBulletin Manual & vBulletin 4.0 Code Documentation (API)
    Want help modifying your vbulletin forum? Head on over to vbulletin.org
    If I post CSS and you don't know where it goes, throw it into the additional.css template.

    W3Schools <- awesome site for html/css help

    Comment


    • #3
      I did run the upgrade in installationfolder after uploading files

      Is there another upgrader-script I can run?

      I have also tried and upload all files again and run the upgrade script.The admincp says the new version.

      Comment


      • #4
        I would suggest rerunning the upgrade.php script and verifying it completes. The database error above definitely specifies that this error is occurring on a 5.2.2 database, not a 5.2.4 database.

        Please don't PM or VM me for support - I only help out in the threads.
        vBulletin Manual & vBulletin 4.0 Code Documentation (API)
        Want help modifying your vbulletin forum? Head on over to vbulletin.org
        If I post CSS and you don't know where it goes, throw it into the additional.css template.

        W3Schools <- awesome site for html/css help

        Comment


        • #5
          I have now run upgrade.php again. Also deleted some files not recognized as right version

          The error is still there?

          Any more suggestions? How can I see that the database is the correct version.

          Comment


          • #6
            And does the error still say 5.2.2 or does it now say 5.2.4? And does the error always have the same script link or are they different?

            Please don't PM or VM me for support - I only help out in the threads.
            vBulletin Manual & vBulletin 4.0 Code Documentation (API)
            Want help modifying your vbulletin forum? Head on over to vbulletin.org
            If I post CSS and you don't know where it goes, throw it into the additional.css template.

            W3Schools <- awesome site for html/css help

            Comment


            • #7
              Still says 5.2.2 (have run update.php 3 times). There are different link to script.

              Comment


              • #8
                If the upgrade has completed, that isn't possible.

                What do you mean by 'there are different links to script'? vB5 can only have one URL.

                Also, have you downloaded the FULL 5.2.4 package, and uploaded ALL the files?
                You cannot upgrade using a patch, nor can you upgrade by just uploading the /install folder.

                Please try the following:
                1. Go to the members area
                2. Download the FULL 5.2.4 package
                3. Unzip and upload ALL the files.
                4. Run yourdomain.com/core/install/upgrade.php
                MARK.B | vBULLETIN SUPPORT

                TalkNewsUK - My vBulletin 5.5.2 Demo
                AdminAmmo - My Cloud Demo

                Comment

                widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                Working...
                X