Announcement

Collapse
No announcement yet.

Error - Could not open frontend config file.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Error - Could not open frontend config file.

    Yea well... trying to run the script and can't open file...



    To:

    /config.php

    Then, you need to rename this file:

    /core/includes/config.php.new

    To:

    /core/includes/config.php DONE !

    Then, in that file, you need to complete the following fields:

    $config['Database']['dbname'] = 'VBulletinDataBase';
    Change forum to whatever your database name is.
    I created a new DataBase from MySQL® Database Wizard

    and I named it: "VBulletinDataBase" (OF COURSE NOT THE REAL NAME, JUST AN EXAMPLE OF GIVEN NAMES)



    $config['Database']['technicalemail'] = '[email protected]'; (NOT MY REAL EMAIL)
    Change the email address to your own.

    $config['MasterServer']['username'] = 'MeV'; (NOT THE REAL USERNAME)
    Change root to the database username
    From VBulletinDataBase the username is "MeV"




    $config['MasterServer']['password'] = 'MSpassword'; (NOT THE REAL PASSWORD)
    Enter the database password inside the '' marks.
    This is the password to enter the server itself, NOT the VBulletinDataBase (WHICH SHOULD BE THE SAME PASSWORD ANYWAY)



    All other fields should be left as default, unless your database is on a separate server, in which case this will need changing:

    $config['MasterServer']['servername'] = '107.xxx.xx.xxxx'; (NOT THE REAL IP ADDRESS)
    ^^^ That number is the IP address.


    4. You need to rename this file:

    /htaccess.txt

    To:
    /.htaccess DONE!

    5. Upload all files to your server/webspace/whatever and browse to yourforumpath.com/core/install/install.php. DONE!

    6. Enter your customer number and the installation will proceed. DONE!

    6.1 vBulletin 5 Configuration Builder fill in the blank with above information..


    vBulletin 5 Configuration Builder


    Let ALONE:
    Cookie Prefix:
    Default: bb
    Database Type:
    Default: mysqli
    Table Prefix:
    Optional Table Prefix (OK to leave blank.)

    Mod CP Directory:
    Default: modcp

    Error - Could not open frontend config file.


    7. Delete the /core/install directory after the installation has finished. NOT DONE..




    Could somebody tell me why I am not getting connected?

    Last edited by elindo; Tue 20 Sep '16, 7:38pm.

  • #2
    The only thing I can think of is that the database is not mysqli type.


    I created the database under MySQL® Database Wizard


    My Cpanel under Databases has the options of:


    PhPMyAdmin
    MySQLDatabases
    MySQL Database Wizard
    Remote MySQL

    The only places in which you seem to be able to create databases are under:

    MySQLDatabases
    MySQL Database Wizard

    I see nothing that says MySQI


    I have:



    cPanel has php5.6 and MySQL is 5.5.

    cPanel supports cURL 7.19.7



    Comment


    • #3
      Haven't looked into the issue but you should remove asap the db credentials that you posted in the first post for security reasons.

      GIPHY for vB5 AutoLinker Auto-Create Flag Report Topic Social Icons in Postbit Clear Cache Cron DragDrop Upload Topic AJAX AutoUpdate Custom Avatars Selector Stop Links in Posts...and more!

      Comment


      • #4
        Ok... I got this error now:


        Startup Errors
        Due to the following errors, the install/upgrade can not continue:
        • Error description: 2: mysqli_real_connect(): (28000/1045): Access denied for user 'xxxxxxx'@'ip-107-xxxxxx.ip.secureserver.net' (using password: YES)
        • The database has failed to connect because you do not have permission to connect to the server. Please confirm the values entered in thecore/includes/config.php file
        (xxxx's are not the real username or password)



        I re-uploaded the config file and changed the name to "config" in my computer, now it reads on the public_html from my server as "config.php"... before it was reading as "config.php.php"



        Why you think I am getting this error????





        Comment


        • #5
          Access denied for user 'xxxxxxx'@'ip-107-xxxxxx.ip.secureserver.net

          This means that the database credentials in the config file are incorrect. You will need to speak to your host to obtain the correct details.

          Also - $config['MasterServer']['servername'], this is usually best left as 'localhost'. Only change this if your hosts say you need to.
          MARK.B | vBULLETIN SUPPORT

          TalkNewsUK - My vBulletin 5.6.3 Demo
          AdminAmmo - My Cloud Demo

          Comment


          • #6
            I see..

            It worked with:


            $config['MasterServer']['servername'], this is usually best left as 'localhost'.



            BTW... my computer saves the file automatically with config.php.... I only have to name it config in my computer to read it as config.php on my public_html


            It is currently installing.
            Last edited by elindo; Wed 21 Sep '16, 8:22am.

            Comment


            • #7
              Excellent, sounds like you got there. Let us know if you experience any further issues.
              MARK.B | vBULLETIN SUPPORT

              TalkNewsUK - My vBulletin 5.6.3 Demo
              AdminAmmo - My Cloud Demo

              Comment


              • #8
                Would you know how long is the install?

                It is currently stuck on 73% Status: Processing XML, Step 14 of 20

                Comment


                • #9
                  It may have got stuck.

                  If it has still not moved on....Change the url in the address bar from install.php to upgrade.php and then press enter.
                  MARK.B | vBULLETIN SUPPORT

                  TalkNewsUK - My vBulletin 5.6.3 Demo
                  AdminAmmo - My Cloud Demo

                  Comment


                  • #10
                    Changed it to:

                    /core/install/upgrade.php


                    It moved to:

                    Upgrading to 5.2.3
                    Status: Processing XML, Step 16 of 20
                    28%

                    and it seems like it is staying there...


                    What do I have to do to keep it moving?


                    I have my computer directly hook up to my router for faster speed.

                    Comment


                    • #11
                      Moving forwards...

                      - Refresh computer and it finish installing
                      - Deleted files under /core/install
                      - Hit next to go to cp...



                      (The folder in which I have VBulletin is called "groups") Forbidden

                      You don't have permission to access /groups/admincp/ on this server.


                      Additionally, a 403 Forbidden error was encountered while trying to use an ErrorDocument to handle the request.

                      Comment


                      • #12
                        If it sticks at any of those later stages for more than about five minutes, refresh the page (F5).

                        It sounds like the server is timing out on some the heavier stuff done at install. It's not your computer or internet connection.
                        MARK.B | vBULLETIN SUPPORT

                        TalkNewsUK - My vBulletin 5.6.3 Demo
                        AdminAmmo - My Cloud Demo

                        Comment


                        • #13
                          Originally posted by elindo View Post
                          Moving forwards...

                          - Refresh computer and it finish installing
                          - Deleted files under /core/install
                          - Hit next to go to cp...



                          (The folder in which I have VBulletin is called "groups") Forbidden

                          You don't have permission to access /groups/admincp/ on this server.


                          Additionally, a 403 Forbidden error was encountered while trying to use an ErrorDocument to handle the request.
                          You need to rename the file htaccess.txt, and call it .htaccess
                          Note the period / dot at the start of the name.
                          MARK.B | vBULLETIN SUPPORT

                          TalkNewsUK - My vBulletin 5.6.3 Demo
                          AdminAmmo - My Cloud Demo

                          Comment


                          • #14
                            Ok..

                            1.
                            I went directly to my server and remaned the file ".htaccess"
                            The files in my computer /upload/ reads as .htaccess, but some how is was uploaded as htaccess.txt


                            Seems like it is moving forward......

                            2.
                            Security Alert!

                            The /core/install directory still exists.

                            This poses a security risk, so please delete that directory immediately. You cannot access the control panel until you do so.



                            I deleted all the files within the install folder... + Empty the trash from that file...



                            Do I need to delete the entire folder instead of leaving it empty? I don't see a way of how to do that yet...





                            .... I went back to do the upgrade again after empty the trash from the folder.... it doesn't re-load any more upgrades...




                            So right now I am at /groups/admincp/ with the same security alert..

                            Last edited by elindo; Wed 21 Sep '16, 9:38am.

                            Comment


                            • #15
                              You need to delete the actual /install/ folder as well as the contents.
                              MARK.B | vBULLETIN SUPPORT

                              TalkNewsUK - My vBulletin 5.6.3 Demo
                              AdminAmmo - My Cloud Demo

                              Comment

                              widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                              Working...
                              X