Announcement

Collapse
No announcement yet.

searchindex.php on Windows

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Wayne Luke
    replied
    Running MySQL commands and having the MySQLi library installed for PHP's usage are two completely different things. Plus depending on how your server is set up, your web based PHP can be configured differently than the command line PHP. You need to read the php info for your command line version of PHP to see if you have it installed.

    I should note that searchindex.php isn't necessarily quicker than reindexing from within the AdminCP. It just runs in the background until the user session is closed. The numbers in the output at the NODEIDs. Not necessarily posts. It will go from NODEID 0 to Max NODEID and always picks up where it left off.

    Leave a comment:


  • Ordovicium
    replied
    Now, I don't get this error, by switching off. But it exit immediately after the directory question. No further questions pop up.

    Yes, searchindex is in the root directory

    I guess MySQLi is installed. I am able to run MySQL commands.

    PHP 5.6.14 Zend Engine v2.6.0

    The problem is, I have approx. 700.000 Postings and after 2 days running day and night via AdminCp I stand at "Building Search Index 66000 :: 66500". If this is the post count, then it will be finished maybe 2020.
    Last edited by Ordovicium; Mon 15th Aug '16, 9:57am.

    Leave a comment:


  • Wayne Luke
    replied
    Hmmm. It shouldn't be trying to output templates at all. Please turn the option to show template names in the AdminCP under Settings -> Options -> General Settings.

    Does the error change with it off?
    searchindex.php is in your forum root directory? That is the best place to run it from.
    What version of PHP is being used at the command line? Using the command php -v will tell you this.
    Is MySQLi installed for the command line version of PHP?

    Leave a comment:


  • Ordovicium
    started a topic searchindex.php on Windows

    searchindex.php on Windows

    Hi,
    how to run searchindex.php and Windows (XAMPP). When I start the command line, I get following error after the path request:
    Code:
    <!-- BEGINN TEMPLATE: STANDARD_ERROR -->
    <!-- END TEMPLATE: STANDARD_ERROR -->
    No additional information here?!
widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
Working...
X