Announcement

Collapse
No announcement yet.

Image BB Code Problem?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • jkotlowski
    replied
    Originally posted by Wayne Luke View Post
    Browsers don't normally do that or the issue would be more prevalent. If she runs extensions, something might be adding it. It could be her browser language settings. I don't know why that would do it though.

    You can try adding the character to the Blank Character Stripper in the AdminCP under Settings -> Options -> Censorship Options. The value would be u8203
    Thanks! I added it in there. Hopefully it works. I've still been unable to replicate the issue myself. So I suppose I'll just have to wait until said member shows up and begins posting more pictures.

    Leave a comment:


  • Wayne Luke
    replied
    Browsers don't normally do that or the issue would be more prevalent. If she runs extensions, something might be adding it. It could be her browser language settings. I don't know why that would do it though.

    You can try adding the character to the Blank Character Stripper in the AdminCP under Settings -> Options -> Censorship Options. The value would be u8203

    Leave a comment:


  • jkotlowski
    replied
    Wayne Luke

    I had forgotten about this. The poster still has the problem. She apparently just searches these images on Google then copy the address. So they come from many different websites. I suggested to her to, instead of copying the URL from the address bar, to right click the image and copy image address. But it still seems to be happening. I've recently noticed it happening with other members, albeit considerably less frequently.

    Is there anything with a browser that could insert the zero width space into the advanced editor when pasting? I've tried replicating the issue myself to no avail so I'm not sure what could be happening.

    Leave a comment:


  • jkotlowski
    replied
    Originally posted by Wayne Luke View Post
    Seems like a bug. URLs shouldn't be automatically parsed in the IMG BBCode.

    Actually, if I look at your URL, in the code source, it has a bunch of characters at the beginning. & #8203; repeated several times, without the space.

    Without those, it renders properly. Make sure there are no hidden UTF-8 characters at the beginning of the URL.



    Where are you getting the original link URL?
    Hey thanks for the reply. To be honest, I have no idea where the original link is coming from. One of my members constantly posts these anime pictures in their posts, I guess trying to be cute. She's the one that keeps having the issue often. I honestly haven't noticed often otherwise. Though I've personally experienced it a few times, but it was only after I edited the post. It'd suddenly be a hyperlink between the IMG tags instead of the picture itself.

    I'll talk to the member in question and see if they're doing something odd when copying the URL.

    Leave a comment:


  • Wayne Luke
    replied
    Seems like a bug. URLs shouldn't be automatically parsed in the IMG BBCode.

    Actually, if I look at your URL, in the code source, it has a bunch of characters at the beginning. & #8203; repeated several times, without the space.

    Without those, it renders properly. Make sure there are no hidden UTF-8 characters at the beginning of the URL.



    Where are you getting the original link URL?

    Leave a comment:


  • jkotlowski
    started a topic Image BB Code Problem?

    Image BB Code Problem?

    I've noticed a problem with IMG BB Codes on my site. Every so often when someone types in the BB Code manually instead of using the button, it results in the image URL being hyperlinked and mixed into the BB Code brackets.

    [img]​​​​​​http://animeonline.su/uploads/posts/...2154951_10.jpg[/img]

    Exactly like this. (edit - this site kind of fixed it. On my site, the [/img] part of the tag would also be included in the hyperlink) The user then has to either delete the text and redo their code. Or they have to go into the advanced editor, highlight the text, and remove the hyperlink. This gets annoying for my users. Is there something I can do to stop this from happening?

Related Topics

Collapse

Working...
X