Announcement

Collapse
No announcement yet.

Complete loss of everything during upgrade

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Complete loss of everything during upgrade

    Have an old forum running vbulletin 3-8-7 patch level 3 that I was upgrading to vB 5 connect.
    Have done this before with no problem, first upgrading to 4.2.3 and then up to vb 5

    This time, upgrading to 4.2.3, everything is lost. No format, no forums, no database, etc.
    There was no problem in the upgrade, things went smoothly, just nothing there.
    The database is still intact (although changes were apparenty made)

    After installation it goes to xxx.com/forum.php and thows a bunch of errors (even in the admin panel trying to do the "Administrative Attention Required" functions:

    Checking if a package is enabled for an invalid package '3' on line 392 in /home/bqanda/public_html/vb/types.php
    #0 /home/bqanda/public_html/vb/router.php(514): vB_Types->packageEnabled('3')
    #1 /home/bqanda/public_html/vb/router.php(577): vB_Router::assertRoutes()
    #2 /home/bqanda/public_html/vb/route.php(236): vB_Router::getRouteSegmentFromClass('vBCms_Route_Lis...')
    #3 /home/bqanda/public_html/vb/route.php(260): vB_Route->__construct(false, false)
    #4 /home/bqanda/public_html/packages/vbcms/route/list.php(92): vB_Route::create('vBCms_Route_Lis...')
    #5 /home/bqanda/public_html/includes/functions.php(3668): vBCms_Route_List::getURL(Array)
    #6 /home/bqanda/public_html/includes/functions_forumlist.php(314): construct_memberaction_dropdown(Array)
    #7 /home/bqanda/public_html/includes/functions_forumlist.php(230): construct_forum_bit('1', 1, 0)
    #8 /home/bqanda/public_html/forum.php(611): construct_forum_bit(-1)
    #9 {main}


    Fatal User Error: Checking if a package is enabled for an invalid package '3' on line 392 in ..../vb/types.php in ..../vb/vb.php on line 286
    #1 : vbstop() called in ..../includes/class_core.php on line 5816 #2 : vb_error_handler() called in on line #3 : trigger_error() called in ..../vb/vb.php on line 286 #4 : vB::handleException() called in on line Other than removing all, reinstalling 3.8.7 and starting all over again, ANY ADVICE ???

  • #2
    What version of php is running on the server?
    MARK.B | vBULLETIN SUPPORT

    TalkNewsUK - My vBulletin 5.5.6 Demo
    AdminAmmo - My Cloud Demo

    Comment


    • #3
      Php version not an issue since this is a leassed server and I have vb 5.0 running on another site.
      Version 5.4 anyway

      Comment


      • #4
        What are the contents of your contenttype table?

        Select * from contenttype

        contenttypeid 3 should be Forum with a packageid of 1.
        Translations provided by Google.

        Wayne Luke
        The Rabid Badger - a vBulletin Cloud demonstration site.
        vBulletin 5 API - Full / Mobile
        Vote for your favorite feature requests and the bugs you want to see fixed.

        Comment


        • #5
          That it has. There are 28 entires in the contenttype table with contenttypeid 3 as Forum, packageid as 1 and all the rest are 0's.

          Am going to upgrade the 4.2 to 5.0 and see what happens, Things cannot get worse can they? Worth a shot before deleting everything and reloading from backup back to 3.8.

          Comment


          • #6
            Do not try to upgrade if the site is currently broken. Upgrading isn't a magic wand to fix things.
            Upgrading a broken site generally results in an upgraded, but still broken, site, except now you can't easily track back to what went wrong.
            MARK.B | vBULLETIN SUPPORT

            TalkNewsUK - My vBulletin 5.5.6 Demo
            AdminAmmo - My Cloud Demo

            Comment


            • #7
              See no option than to go back to 3.8.7 atm and maybe try again

              Comment


              • #8
                is there a way to do a clean install of vb 5.2.2 and then import the database of 3.8.7 ?
                Thanx

                Comment


                • #9
                  Originally posted by frank47 View Post
                  is there a way to do a clean install of vb 5.2.2 and then import the database of 3.8.7 ?
                  Thanx
                  No. The structures are entirely different.

                  If you have a backup, restoring back and trying again is probably the best option. You could spend the rest of your days trying to fix a broken upgrade manually, often you are chasing your tail as each 'fix' breaks something else.
                  MARK.B | vBULLETIN SUPPORT

                  TalkNewsUK - My vBulletin 5.5.6 Demo
                  AdminAmmo - My Cloud Demo

                  Comment


                  • #10
                    Doing a fresh install of 3.8.7 (as backup has a bunch of mods that might be causing the problem), reloading the database, and then trying a direct upgrade to 5.2.2 rather than going through a 4.0 upgrade.

                    Comment


                    • #11
                      hmm, might be a problem with a clean install of 3.8.7....

                      http://www.xxxx.com/install/install.php :

                      Strict Standards: Non-static method vB_Shutdown::init() should not be called statically, assuming $this from incompatible context in /home/bqanda/public_html/includes/class_core.php on line 2555

                      Strict Standards: Non-static method vBulletinHook::init() should not be called statically in /home/bqanda/public_html/install/init.php on line 212

                      Please Enter Your Customer Number (login panel)

                      Strict Standards
                      : Non-static method vBulletinHook::fetch_hook() should not be called statically in /home/bqanda/public_html/includes/adminfunctions.php on line 399

                      Strict Standards: Non-static method vBulletinHook::init() should not be called statically in /home/bqanda/public_html/includes/class_hook.php on line 118

                      Login with customer Id just cycles back to same screen

                      Any thoughts/advise?

                      Comment


                      • #12
                        vBulletin 3.8.7 is probably not compatible with your version of PHP. You cannot use anything higher than PHP 5.3.
                        Translations provided by Google.

                        Wayne Luke
                        The Rabid Badger - a vBulletin Cloud demonstration site.
                        vBulletin 5 API - Full / Mobile
                        Vote for your favorite feature requests and the bugs you want to see fixed.

                        Comment


                        • #13
                          Yeah, I am kind of screwed here as the backup is now also giving errors.

                          Will probably have to recompile apache with php 5.3 to reinstall ... grrrr

                          Comment


                          • #14
                            hmmm, recompiled with php 5.3 and same errors
                            Not sure I can go any lower
                            Are you sure 3.8.7 will work with 5.3?

                            Comment


                            • #15
                              3.8.7 is definitely compatible with php 5.3.

                              Does the admin cp report php 5.3?
                              MARK.B | vBULLETIN SUPPORT

                              TalkNewsUK - My vBulletin 5.5.6 Demo
                              AdminAmmo - My Cloud Demo

                              Comment

                              Related Topics

                              Collapse

                              Working...
                              X