Announcement

Collapse
No announcement yet.

CloudFlare SSL + vBulletin 5 Login Issue

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • CloudFlare SSL + vBulletin 5 Login Issue

    Hi all,

    I have recently deployed a new copy of vBulletin 5 and I am now attempting to get it set up using SSL. Everything works fine on the site, but when attempting to login, I receive the following message:

    (Larger resolution available here.)

    I believe that this is caused by the fact that I have the SSL configured through CloudFlare rather than on-site through the webserver. Does anyone have a working workaround for this? I am currently using Nginx, CloudFlare, and vBulletin 5.2.0. All of the settings are configured correctly to the best of my knowledge in the AdminCP. Like I said before, everything else works via SSL except for the login module.

    Any ideas?

    Regards,
    BboyEatsbacon

  • #2
    Originally posted by BboyEatsbacon View Post
    Hi all,

    I have recently deployed a new copy of vBulletin 5 and I am now attempting to get it set up using SSL. Everything works fine on the site, but when attempting to login, I receive the following message:

    (Larger resolution available here.)

    I believe that this is caused by the fact that I have the SSL configured through CloudFlare rather than on-site through the webserver. Does anyone have a working workaround for this? I am currently using Nginx, CloudFlare, and vBulletin 5.2.0. All of the settings are configured correctly to the best of my knowledge in the AdminCP. Like I said before, everything else works via SSL except for the login module.

    Any ideas?

    Regards,
    BboyEatsbacon

    You need to set your login URL to include https://

    Go to Settings > Site Name/URL/Contact Details > Login URL > and set it to https instead of http

    Comment


    • #3
      Originally posted by TheXboxCloud View Post


      You need to set your login URL to include https://

      Go to Settings > Site Name/URL/Contact Details > Login URL > and set it to https instead of http
      Thanks for your reply!

      Yes, I have already done this and that is what is causing this error. Loading it via plain HTTP results in a blank spot where the module should appear due to a secure page loading insecure elements, and loading via HTTPS results in the error described above. I suspect that this is due to the server referencing itself in the PHP module loading the login page, and since the server is not running a local HTTPS server, it cannot find the resource specified. Now, I am curious as to if there is a known workaround or a potential code patch which I could apply on my end to work more like vB4/prior for requesting the login applet.

      Any other suggestions?

      Comment


      • #4
        Originally posted by BboyEatsbacon View Post

        Thanks for your reply!

        Yes, I have already done this and that is what is causing this error. Loading it via plain HTTP results in a blank spot where the module should appear due to a secure page loading insecure elements, and loading via HTTPS results in the error described above. I suspect that this is due to the server referencing itself in the PHP module loading the login page, and since the server is not running a local HTTPS server, it cannot find the resource specified. Now, I am curious as to if there is a known workaround or a potential code patch which I could apply on my end to work more like vB4/prior for requesting the login applet.

        Any other suggestions?
        Not sure since you did do what I suggested already.

        There is another option for free SSL called "Let's Encrypt". You may want to do a search on it. This could potentially be a work-around for the moment.

        Although maybe some other people have some suggestions so you may want to hear those first.

        You can try enabling "always use https" via cloudflare page rules and see if that helps.

        But if you can't find a fix I hear good things about "Lets Encrypt" though I have never used them.

        Comment


        • #5
          Originally posted by TheXboxCloud View Post

          Not sure since you did do what I suggested already.

          There is another option for free SSL called "Let's Encrypt". You may want to do a search on it. This could potentially be a work-around for the moment.

          Although maybe some other people have some suggestions so you may want to hear those first.

          You can try enabling "always use https" via cloudflare page rules and see if that helps.

          But if you can't find a fix I hear good things about "Lets Encrypt" though I have never used them.

          Thanks for the reference! Let's Encrypt has worked wonderfully. There is now a full SSL configuration between my server and the enduser, and this problem is resolved! I don't know that I would directly take that as a solution, but it's certainly a great workaround. Thanks for your suggestion.

          Comment


          • #6
            Originally posted by BboyEatsbacon View Post


            Thanks for the reference! Let's Encrypt has worked wonderfully. There is now a full SSL configuration between my server and the enduser, and this problem is resolved! I don't know that I would directly take that as a solution, but it's certainly a great workaround. Thanks for your suggestion.

            No problem. Glad you got it working.

            Comment

            Related Topics

            Collapse

            Working...
            X