Announcement

Collapse
No announcement yet.

Question about characters in attached files

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • pmquist
    replied
    Thanks Wayne,

    I will be happy to convert to UTF8 since there seems to be other advantages as well by doing that. I was adviced earlier by someone in the vB-staff not to. Dont remember who.
    Is there a guide for how to do that somewhere or should I start a ticket?

    Regards / PerOla

    Leave a comment:


  • Wayne Luke
    replied
    The character å and some others like it appear twice in a font file. Once in the ASCII portion before the 256 byte and once in the second much larger UTF8 portion. Since you're using latin1 as your database character set, it would be looking for something in the lower level value in the ASCII portion. Unfortunately, I don't know of a way to enforce that. You may be able to resolve the issue converting to UTF8. However, I'll see if the developers can fix it in code.

    Leave a comment:


  • pmquist
    replied
    And finally mbstring
    Multibyte Support enabled
    Multibyte string engine libmbfl
    HTTP input encoding translation disabled
    libmbfl version 1.3.2
    Multibyte (japanese) regex support enabled
    Multibyte regex (oniguruma) backtrack check On
    Multibyte regex (oniguruma) version 5.9.2
    mbstring.detect_order no value no value
    mbstring.encoding_translation Off Off
    mbstring.func_overload 0 0
    mbstring.http_input pass pass
    mbstring.http_output pass pass
    mbstring.http_output_conv_mimetypes ^(text/|application/xhtml\+xml) ^(text/|application/xhtml\+xml)
    mbstring.internal_encoding no value no value
    mbstring.language neutral neutral
    mbstring.strict_detection Off Off
    mbstring.substitute_character no value no value

    Leave a comment:


  • pmquist
    replied
    iconv support enabled
    iconv implementation glibc
    iconv library version 2.19
    iconv.input_encoding ISO-8859-1 ISO-8859-1
    iconv.internal_encoding ISO-8859-1 ISO-8859-1
    iconv.output_encoding ISO-8859-1 ISO-8859-1

    Leave a comment:


  • pmquist
    replied
    The answer to that query is
    default_character_set_name
    latin1

    Leave a comment:


  • Wayne Luke
    replied
    Do you have iconv and mbstring installed in your PHP installation?

    What character set does your database use?

    YOu can use this query to check your character set:
    Code:
     
     SELECT default_character_set_name FROM information_schema.SCHEMATA  WHERE schema_name ="schemaname"; 
    Replace schemaname with the name of your database.

    Leave a comment:


  • pmquist
    started a topic Question about characters in attached files

    Question about characters in attached files

    I wonder if there is a solution to an issue with special characters in filenames in attached files.

    What happens is that a file with the swedish name

    Buars Ryttargård.doc

    is replaced with

    Buars Ryttargård.doc

    It might not look like a big problem, but when you attach 20 different files with names that mean something it is very hard to read out their names. Look at this one as an example: http://www.utkiken.net/forum/dokumen...1066#post41066

    I assume it has something to do with the language settings ISO versus UTF since there are several other language issues. However I have not found any other Jiras or questions about this specific issue so maybe it is easy to fix?

    Regards / PerOla

Related Topics

Collapse

Working...
X