Announcement

Collapse
No announcement yet.

custom link color breaks hover function

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • custom link color breaks hover function

    hmm, i just noticed an issue about link colors im hoping someone could help me to resolve...

    if i make a link a custom color<<< in the editor the hover color/decoration fails to activate....unlike this link

    i got disappointed because i noticed with the slider it is possible to have both links and a header image in the preview....however without the link effects it looks like regular text so it would be great to fix if possible....

  • #2
    How are you "Making a custom color link?" Not sure what you mean by that.
    Translations provided by Google.

    Wayne Luke
    The Rabid Badger - a vBulletin Cloud customization and demonstration site.
    vBulletin 5 Documentation - Updated every Friday. Report issues here.
    vBulletin 5 API - Full / Mobile
    I am not currently available for vB Messenger Chats.

    Comment


    • #3
      like changing text color basically....on a link

      its kinda hard to see the vb default because the colors are close but it does change with a hover effect

      Comment


      • #4
        How are you accomplishing this? Style Variables? Each Style Variable should have Color and a Hover class that can be set independently.

        If you're overriding the CSS, you will most likely have to provide your own CSS to handle the hover event as well.
        Translations provided by Google.

        Wayne Luke
        The Rabid Badger - a vBulletin Cloud customization and demonstration site.
        vBulletin 5 Documentation - Updated every Friday. Report issues here.
        vBulletin 5 API - Full / Mobile
        I am not currently available for vB Messenger Chats.

        Comment


        • #5
          what? in the editor.....like as a regular member....choosing text color is a basic editor function u know?

          look at my initial post and notice the link that is dark blue

          Comment


          • #6
            Do you mean when people make a post using the editor and manually make the link a different colour within the post?
            If so, there's nopthing you can do about that.
            MARK.B | vBULLETIN SUPPORT

            TalkNewsUK - My vBulletin 5.5.2 Demo
            AdminAmmo - My Cloud Demo

            Comment


            • #7
              yeah, couldnt that be a custom BB code or something? ....something? seems like there would be a way idk dam

              Comment


              • #8
                To fix that, you have to add this custom CSS to override the set color on hover.

                Code:
                .js-post__content-text a:hover { color: #1C6191 !important; }

                GIPHY for vB5 AutoLinker Auto-Create Flag Report Topic Social Icons in Postbit Clear Cache Cron DragDrop Upload Topic AJAX AutoUpdate Custom Avatars Selector Stop Links in Posts...and more!

                Comment


                • IggyP
                  IggyP commented
                  Editing a comment
                  hmm something still seems blocking it? trying on default style...gonna try a few other ways, thanks glenn

                  btw, i noticed some of this effect is also browser relevant...firefox at least retains the correct color on the hover decoration(underline), but the link color(text) is still the 'custom' on upon hover
                  Last edited by IggyP; Tue 29th Mar '16, 10:08pm.

              • #9
                hmm, well i never got the text color to hover properly, but if you put "background" instead of "color", that one doesnt get blocked and is at least a similar effect where members can easily tell its a link...

                it still doesnt work in the slider tho hmm
                (default text color hover links work in slider only)
                Last edited by IggyP; Tue 29th Mar '16, 10:43pm.

                Comment


                • #10
                  That css is for the links inside the posts only.

                  It's hard to figure out to fix the hover issue without seeing the actual page in action.

                  GIPHY for vB5 AutoLinker Auto-Create Flag Report Topic Social Icons in Postbit Clear Cache Cron DragDrop Upload Topic AJAX AutoUpdate Custom Avatars Selector Stop Links in Posts...and more!

                  Comment


                  • #11
                    i believe the conflict is an issue in default installation? i verified it on a default style...so thought that should have worked...
                    the background hover effect is something at least, better than nothing, but it also applies to the links which are NOT custom colored which i dont like...

                    the slider integration, well if thats more complicated i wont worry, ill just add it to the to-do list for now...

                    Comment

                    widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                    Working...
                    X