No announcement yet.

Help! Endless errors on upgrade to 5.1!

  • Filter
  • Time
  • Show
Clear All
new posts

  • Help! Endless errors on upgrade to 5.1!

    We are currently upgrading from 4.1 to 5.1.10 and are caught in a loop of error when we get to the private message part of the upgrade. I heard of a solution by modifying code, but am wary to do so. There must be a better way. This happens everytime we try to upgrade, whether I refresh it or not, and nothing I do can bypass it.

    We get this error:

    Action Required
    Unexpected Text:

    <?xml version="1.0" encoding="windows-1252"?>
    <br />
    <b>Fatal error</b>: Call to a member function fetch_userinfo() on a non-object in <b>/home/*****/public_html/forums/core/vb/string.php</b> on line <b>368</b><br />

    Script: 500a28
    Step: 6

    At this point in the upgrade:

    Upgrade Progress

    Upgrading to 5.0.0 Alpha 28
    Importing Private Messages- step 3 of 4
    Processing 5000 records

    Could anyone suggest how we might fix this? It is impeding our upgrade!

  • #3
    I've done a few upgrades where this has come up....I have eventually got past it by refreshing it each time...sometimes dozens of times.

    You'll get the 'processing 5000 records' thing each time, and my suspicion is that it is is actually moving along a bit each time, but then throwing the error.

    Eventually it gets past it.
    Last edited by Mark.B; Wed 10 Feb '16, 12:00am.

    TalkNewsUK - My vBulletin 5.6.4 Demo
    AdminAmmo - My Cloud Demo


    • #4
      I've tried refreshing 50 times and still nothing, will keep trying.


      • Glenn Vergara
        Glenn Vergara commented
        Editing a comment
        Have you tried my suggestion to use command line?

    • #5
      Tried the command line install but kept terminating due to database error. Not sure what happened there. Been waiting awhile for tech support to get back to me on this one, but I guess it takes forever


      Related Topics