Announcement

Collapse
No announcement yet.

Video BB Code Not Working In Signatures?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Video BB Code Not Working In Signatures?

    I might be wrong, but I was fairly sure this was working not too long ago. But now all video bbcodes in signatures get turned into hyperlinks unless a more complex version of the video code is used.

    [video=youtube;kcPOH_Q7WNI]https://www.youtube.com/watch?v=kcPOH_Q7WNI[/video]

    This seems to work, kind of. But using the code like this forces the video to autoplay. Which is extremely inconvenient. I don't have any third party products installed currently. I did have a dragonbyte tech "advanced thanks/like" product installed, but has since been removed. I thought there may be something in the original BB code's HTML that might be triggering this, but I don't even know where I can look for that.

    Any help would be greatly appreciated. Also, the video code says it can do Hulu, but I can't get it to work. =/

    -edit-

    I found the original video bb code in the style manager.

    Code:
    <vb:if condition="$provider == 'hulu'">
    <object class="restrain" type="application/x-shockwave-flash" width="<vb:if condition="isset($width) AND $width > 0">{vb:raw width}<vb:else />512</vb:if>" height="<vb:if condition="$height">{vb:raw height}<vb:else />296</vb:if>" data="http://www.hulu.com/embed/{vb:raw code}">
        <param name="movie" value="http://www.hulu.com/embed/{vb:raw code}" />
        <param name="wmode" value="{vb:raw vboptions.player_wmode}" />
        <!--[if IE 6]>
        <embed width="512" height="296" type="application/x-shockwave-flash" src="http://www.hulu.com/embed/{vb:raw code}" />
        <![endif]--></object>
    <vb:elseif condition="$provider == 'youtube'" />
    <iframe class="restrain" title="YouTube video player" width="<vb:if condition="isset($width) AND $width > 0">{vb:raw width}<vb:else />640</vb:if>" height="<vb:if condition="$height">{vb:raw height}<vb:else />390</vb:if>" src="//www.youtube.com/embed/{vb:raw code}?wmode={vb:raw vboptions.player_wmode}&autoplay=1"></iframe>
    <vb:elseif condition="$provider == 'youtube_share'" />
    <iframe class="restrain" title="YouTube video player" width="<vb:if condition="isset($width) AND $width > 0">{vb:raw width}<vb:else />640</vb:if>" height="<vb:if condition="$height">{vb:raw height}<vb:else />390</vb:if>" src="//www.youtube.com/embed/{vb:raw code}?wmode={vb:raw vboptions.player_wmode}&autoplay=1"></iframe>
    <vb:elseif condition="$provider == 'vimeo'" />
    <object class="restrain" type="application/x-shockwave-flash" width="<vb:if condition="isset($width) AND $width > 0">{vb:raw width}<vb:else />640</vb:if>" height="<vb:if condition="$height">{vb:raw height}<vb:else />360</vb:if>" data="http://vimeo.com/moogaloop.swf?clip_id={vb:raw code}&autoplay=1">
        <param name="movie" value="http://vimeo.com/moogaloop.swf?clip_id={vb:raw code}" />
        <param name="wmode" value="{vb:raw vboptions.player_wmode}" />
        <!--[if IE 6]>
        <embed width="640" height="360" type="application/x-shockwave-flash" src="http://vimeo.com/moogaloop.swf?clip_id={vb:raw code}&autoplay=1" />
        <![endif]--></object>
    <vb:elseif condition="$provider == 'dailymotion'" />
    <object class="restrain" type="application/x-shockwave-flash" width="<vb:if condition="isset($width) AND $width > 0">{vb:raw width}<vb:else />420</vb:if>" height="<vb:if condition="$height">{vb:raw height}<vb:else />339</vb:if>" data="http://www.dailymotion.com/swf/{vb:raw code}?autoPlay=1">
        <param name="movie" value="http://www.dailymotion.com/swf/{vb:raw code}" />
        <param name="wmode" value="{vb:raw vboptions.player_wmode}" />
        <!--[if IE 6]>
        <embed width="420" height="339" type="application/x-shockwave-flash" src="http://www.dailymotion.com/swf/{vb:raw code}?autoPlay=1" />
        <![endif]--></object>
    <vb:elseif condition="$provider == 'metacafe'" />
    <object class="restrain" type="application/x-shockwave-flash" width="<vb:if condition="isset($width) AND $width > 0">{vb:raw width}<vb:else />400</vb:if>" height="<vb:if condition="$height">{vb:raw height}<vb:else />345</vb:if>" data="http://www.metacafe.com/fplayer/{vb:raw code}.swf">
        <param name="movie" value="http://www.metacafe.com/fplayer/{vb:raw code}.swf" />
        <param name="wmode" value="{vb:raw vboptions.player_wmode}" />
        <param name="flashVars" value="playerVars=autoPlay=yes" />
        <!--[if IE 6]>
        <embed width="400" height="345" type="application/x-shockwave-flash" src="http://www.metacafe.com/fplayer/{vb:raw code}.swf" flashVars="playerVars=autoPlay=yes"/>
        <![endif]--></object>
    <vb:elseif condition="$provider == 'google'" />
    <object class="restrain" type="application/x-shockwave-flash" width="<vb:if condition="isset($width) AND $width > 0">{vb:raw width}<vb:else />400</vb:if>" height="<vb:if condition="$height">{vb:raw height}<vb:else />326</vb:if>" data="http://video.google.com/googleplayer.swf?docid={vb:raw code}&autoplay=1">
        <param name="movie" value="http://video.google.com/googleplayer.swf?docid={vb:raw code}" />
        <param name="wmode" value="{vb:raw vboptions.player_wmode}" />
        <!--[if IE 6]>
        <embed width="400" height="326" type="application/x-shockwave-flash" src="http://video.google.com/googleplayer.swf?docid={vb:raw code}&autoplay=1" />
        <![endif]--></object>
    <vb:elseif condition="$provider == 'facebook'" />
    <iframe src="https://www.facebook.com/video/embed?video_id={vb:raw code}" width="<vb:if condition="isset($width) AND $width > 0">{vb:raw width}<vb:else />576</vb:if>" height="<vb:if condition="$height">{vb:raw height}<vb:else />432</vb:if>" frameborder="0"></iframe>
    </vb:if>
    Last edited by jkotlowski; Thu 7 Jan '16, 10:49pm.
    Want bigger avatars for your forum? There's a mod here. But be sure to vote for the JIRA requesting the fix here!

  • #2
    So... I'm still having this issue. Has anyone figure out a solution to disabling youtube autoplay in signatures?
    Want bigger avatars for your forum? There's a mod here. But be sure to vote for the JIRA requesting the fix here!

    Comment


    • #3
      Welp, this is sort of crazy but I was just reminded that this is still an issue... Over a year after I asked about it.

      Anyone have any idea on how to fix this? It's a bit obnoxious.
      Want bigger avatars for your forum? There's a mod here. But be sure to vote for the JIRA requesting the fix here!

      Comment

      Related Topics

      Collapse

      Working...
      X