Announcement

Collapse
No announcement yet.

html ad overlaps

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • html ad overlaps

    hello, i was just working on trying to brighten up my forum a bit with some artwork installed as ads but now there are issues...im curious, thinking this must have been reported.....or perhaps i can do it a different way...but whats going on about this?

    so the issue is that if you make an html ad it displays a bar on pages it shouldnt that are on the same forum lvl...it doesnt display the ad, but i cant get rid of the blank bar...im trying to do one unique "ad" per forum but i cant because there are so many of the blank bars its a complete mess once im halfway thru...

    anyone know if there is a jira for this or how to avoid?? thanks, Iggy

  • #3
    sure no problem glenn, its just like how you will notice you put an ad on one page, then go to another forum and in the edit page area it still displays the module from the other locations, so even in the edit page module it gets so messy its hard to organize, but then it also leaves those blank bars on public display is bad.....someone posted about this some time ago but i dont recall the info about it...um ya ill grab a pic tho case it helps.
    thanks

    Comment


    • #4
      Click image for larger version

Name:	ad_issue.jpg
Views:	9
Size:	45.6 KB
ID:	4334952

      k, heres the shot...see all those bars? they are adds located in other channels....whats worse is i cant even make the latest topics module display the same, it goes a diff spot for each channel depending which ad is displaying....

      Comment


      • #5
        I'm on the phone but my first instinct to fix the issue is to hide the empty modules per forum page via CSS. Each page have page id in the body class to distinguish each page and each module has widget id. You can use those as the CSS selector.

        Code:
        .pageXXX #widget_XXX { display: none; }
        Last edited by Glenn Vergara; Sat 19 Dec '15, 9:57pm.

        GIPHY for vB5 AutoLinker Auto-Create Flag Report Topic Social Icons in Postbit Clear Cache Cron DragDrop Upload Topic AJAX AutoUpdate Custom Avatars Selector Stop Links in Posts...and more!

        Comment


        • #6
          hmm..im missing something...i got the page id and widget id...i tried a sample attempt like

          Code:
           
           .page109 #widget_175 { display: none; }
          into additional.css with no effect but im sure i must done something wrong, as it still shows

          Comment


          • IggyP
            IggyP commented
            Editing a comment
            btw i tried both widget id# and widget instance id#

          • IggyP
            IggyP commented
            Editing a comment
            got it gone in browser dev tools im close...

          • IggyP
            IggyP commented
            Editing a comment
            oh yes its my mistake, i have a custom additional.css for that style which of course it needed to go there instead of the regular one

        • #7
          A link to your forum would be helpful.

          GIPHY for vB5 AutoLinker Auto-Create Flag Report Topic Social Icons in Postbit Clear Cache Cron DragDrop Upload Topic AJAX AutoUpdate Custom Avatars Selector Stop Links in Posts...and more!

          Comment


          • IggyP
            IggyP commented
            Editing a comment
            sorry its for a private forum so you cant see anyway

        • #8
          ok im on my way, but one thing i wonder what is the correct way to disallow several widget per page...for example

          Code:
             
           .page109 #widget_175; #widget_176 { display: none; } 
           
          is incorrect

          Comment


          • #9
            hmm...calling it a night for now....didnt work...

            if it was just a couple ads seems like it would work, but this is over 20 channels so its messy at best, but i was gonna just go thru and suck it up and put it all in like
            Code:
                       .page109 #widget_195 { display: none; } #widget_196 { display: none; }
                       .page109 #widget_197 { display: none; } #widget_185 { display: none; }  
                       .page109 #widget_187 { display: none; } #widget_189 { display: none; }
                       .page109 #widget_190 { display: none; } #widget_191 { display: none; }
                       .page109 #widget_192 { display: none; } #widget_193 { display: none; }
                       .page109 #widget_198 { display: none; } #widget_188 { display: none; }
                       .page109 #widget_194 { display: none; }
            like that, even tho its a huge pain, but that doesnt even work because it starts hiding things on other pages that shouldnt be hidden, including the widgets i wish to display in some cases...(im positive the desired widget# was not included in the do not display list)

            i tried doing it more simply in a line, but that was giving odd results also that dont make sense...as in this example
            Code:
            .page109 #widget_195 { display: none; } #widget_196 { display: none; } #widget_197 { display: none; } #widget_185 { display: none; } #widget_187 { display: none; } #widget_189 { display: none; } #widget_190 { display: none; } #widget_191 { display: none; } #widget_192 { display: none; } #widget_193 { display: none; }
            and even if i can get this to patch in there, it still is a separate issue for the site builders "edit page" module because the modules run clean off the bottom of the screen, so i can even edit the lowest ones...grr..
            Last edited by IggyP; Sun 20 Dec '15, 2:07am.

            Comment


            • IggyP
              IggyP commented
              Editing a comment
              btw, i verified this to not work on a default style and in the original additional.css...

          • #10
            Originally posted by IggyP View Post
            ok im on my way, but one thing i wonder what is the correct way to disallow several widget per page...for example

            Code:
            .page109 #widget_175; #widget_176 { display: none; }
            is incorrect
            Should be:
            Code:
            .page109 #widget_175,
            .page109 #widget_176 { display: none; }
            Can be in one or multiple lines.
            Last edited by Glenn Vergara; Sun 20 Dec '15, 2:56am.

            GIPHY for vB5 AutoLinker Auto-Create Flag Report Topic Social Icons in Postbit Clear Cache Cron DragDrop Upload Topic AJAX AutoUpdate Custom Avatars Selector Stop Links in Posts...and more!

            Comment


            • #11
              Originally posted by IggyP View Post
              and even if i can get this to patch in there, it still is a separate issue for the site builders "edit page" module because the modules run clean off the bottom of the screen, so i can even edit the lowest ones...grr..
              Are you referring to this?

              http://www.vbulletin.com/forum/forum...-editing-forum

              GIPHY for vB5 AutoLinker Auto-Create Flag Report Topic Social Icons in Postbit Clear Cache Cron DragDrop Upload Topic AJAX AutoUpdate Custom Avatars Selector Stop Links in Posts...and more!

              Comment


              • #12
                thats exactly the one i was thinking of....still finishing up this public display issue first its working beauty tho...

                a million thank yous glenn! many of us will be so much more miserable without your helps

                Comment


                • josueinaki
                  josueinaki commented
                  Editing a comment
                  that is correct. Glenn is the god of vb for me :3

              Related Topics

              Collapse

              Working...
              X