Announcement

Collapse
No announcement yet.

Pages content changes are not shown after save, if page isn't reloaded

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • alessio
    replied
    Finally. i have not post the solution for me, that was to set YES the Add No-Cache HTTP Headers option on adminCP. My server is linux based.
    Now all contents are correctly showed after inserted, without reload the page.
    I had to check also something about ajax settings maybe, before to go ahead with this... i will do when it will be possible. All has been fixed at moment.

    Leave a comment:


  • alessio
    replied
    Clear your system cache and let it rebuild. Maintenance -> Clear System Cache.
    ALready done. The problem is that when i insert a new post, on forum list, it do not appear, as in others contests, until i do not reload the page.
    An user i think, can misunderstand that his post has not been processed, as me first time. The same happen on profile for example, where modified info aren't loaded until a page refresh. It can't be ok. The caching code, i think, isn't working properly maybe. Or something else is wrong somewhere.

    Leave a comment:


  • Wayne Luke
    replied
    Information is cached to improve performance. You can be running up against this.

    Clear your system cache and let it rebuild. Maintenance -> Clear System Cache.

    Leave a comment:


  • alessio
    replied

    Leave a comment:


  • IggyP
    replied
    also with albums...this happens

    Leave a comment:


  • alessio
    replied
    UP: the same if i approve an unapproved message: it appear to be not approved (after it has been approved) until the page isn't refreshed.
    Should i solve with http headers?

    Leave a comment:


  • alessio
    replied
    So, sorry for my eng. If i post on a forum, than i return on main forum page, last forum post i've just do, is not shown on latest post block, until i do not click Refresh on browser. I can navigate overall any page, but if i do not refresh manually the browser, last post are not on list. Yes the same behavior via sitebuilder. Is that normal?

    Leave a comment:


  • Wayne Luke
    replied
    Originally posted by alessio View Post
    also any new post, if i do not reload the page, display on Last Posts block on main page, for example.

    It doesn't automatically load new content and does rely on page loads to update that data.

    Leave a comment:


  • Glenn Vergara
    replied
    Originally posted by alessio View Post
    Hello, thank, yes, of course.
    But the last button does not reload the page and you have to manually reload yourself? What exactly are you changing? I assume you are referring to module changes via Sitebuilder.
    Last edited by Glenn Vergara; Fri 18th Dec '15, 11:00am.

    Leave a comment:


  • alessio
    replied
    also any new post, if i do not reload the page, display on Last Posts block on main page, for example.

    Leave a comment:


  • alessio
    replied
    Hello, thank, yes, of course.

    Leave a comment:


  • Glenn Vergara
    replied
    Did you click the Save Page button and the subsequent buttons? The last button actually reloads the page to display the updated page.

    Leave a comment:


  • Pages content changes are not shown after save, if page isn't reloaded

    How i should solve the problem that when certain modules (or some other content) are inserted, nothing appear modified on page after applied the addition (or deletion) if i do not do a page reload?
    The same happen in some other circumstance.

Related Topics

Collapse

Working...
X