Announcement

Collapse
No announcement yet.

Upgrade 4.0.8 to 5.1.6 Unexpected Text: <?xml version="1.0" encoding="windows-1252"?>

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Upgrade 4.0.8 to 5.1.6 Unexpected Text: <?xml version="1.0" encoding="windows-1252"?>

    I attempted to upgrade from 4.0.8 to 5.1.6 but receive the message "Unexpected Text: <?xml version="1.0" encoding="windows-1252"?>" and only that; there is no other text. After initially getting lost from the manual, I began following the instructions here and was able to start the process. I completely removed every 4.0.8 file and uploaded the vb5 files afterwards. I did not change any of the files after they were extracted until they were moved to the server(I edited with vim). The upgrade appears to run smoothly up until it's 99% done, then at step 20 I get the message.

    Searching around I attempted to follow the solution #1 here but was unable to figure out where to try solution #2. Based on the manual I did not attempt upgrading to the latest 4.x version first. Suggestions on what to do to fix this?

    Relevant information:
    PHP - 5.3.15
    MySQL - 5.5.33
    VB Version - 4.0.8(Attempted upgrade to 5.1.6)
    Browser Used - Google Chrome

  • #2
    Upgrade PHP to at least 5.3.7. That's the minimum requirement for vBulletin 5.1.6. For vBulletin 5.1.7 and up, the minimum PHP version required is PHP 5.4.0

    GIPHY for vB5 AutoLinker Auto-Create Flag Report Topic Social Icons in Postbit Clear Cache Cron DragDrop Upload Topic AJAX AutoUpdate Custom Avatars Selector Stop Links in Posts...and more!

    Comment


    • #3
      My stated php version is 5.3.15...which is newer than 5.3.7. Is that the only solution available?

      Comment


      • #4
        Oops sorry I misread your PHP version. But still you would need at least PHP 5.4 if you plan to upgrade (which you should) to 5.1.7 or later

        GIPHY for vB5 AutoLinker Auto-Create Flag Report Topic Social Icons in Postbit Clear Cache Cron DragDrop Upload Topic AJAX AutoUpdate Custom Avatars Selector Stop Links in Posts...and more!

        Comment


        • #5
          I get that, and I plan to, however, that does not address my current problem. My plan was to upgrade to 5.1.6, then start testing every site on my server for the latest php upgrade, once any issues were worked out, then upgrade php and vbulletin.

          Edit:
          I went ahead and upgraded my local php to 5.4.43 and the upgrade completed successfully. I guess I will need to upgrade sooner or choose a version of vBulletin that will work with PHP 5.3.15 temporarily.
          Last edited by itdept; Tue 8th Sep '15, 7:33am.

          Comment

          Related Topics

          Collapse

          Working...
          X