Announcement

Collapse
No announcement yet.

Problem with https site not loading stylesheets

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Wayne Luke
    replied
    This is something we're working on fixing so the the redirect isn't necessary. That is a good workaround at this time. You can see the JIRA here: http://tracker.vbulletin.com/browse/VBV-14906

    Leave a comment:


  • William Thomas Jr
    replied
    Originally posted by hienntp View Post
    Hello Mattewan. I also meet the same mistake, would you please show me your htaccess file? Thanks very much.
    If you would like to see my redirect: Redirect to https with .htaccess with a specific domain

    I am specifying a domain because I have multiple domains and sites that are not all ssl.

    William

    Leave a comment:


  • hienntp
    replied
    Hello Mattewan. I also meet the same mistake, would you please show me your htaccess file? Thanks very much.

    Leave a comment:


  • Wayne Luke
    replied
    It doesn't matter if it is cloud or not. If the SSL Certificate isn't explicitly passed to the web server (i.e. a Proxy or Load Balancer) the wrong URLs will be served. Changing to protocol relevant URLs will resolve the issue in all situations. Since your certificate is on a different server, the problem is the same for you.

    Leave a comment:


  • mattewan
    replied
    Hi William,

    Thanks for the .htaccess suggestion - I wouldn't have thought of it as I didn't know the bug in the forum software is caused by the previously hit page, as you suggest.

    I have updated my .htaccess file for now and it seems to have done the trick.

    Thanks for your help, really appreciate it.

    Leave a comment:


  • Mark.B
    replied
    We found the issue on Cloud, but it is relevant to all sites using https.

    Leave a comment:


  • William Thomas Jr
    replied
    I am not using the cloud option although I am using an ssl certificate on another host. I haven't ran into issues, probably because I have performed the below .htaccess rewrites. In the tracker's description: "The css and js links depend on whether the previous guest hit a page as http or https.

    As a suggestion, webmasters should use a 301 redirect from http to https in .htaccess. Likewise, www. or non www. should go to https://www or https://non www. Each is actually treated as a separate domain by Google and wrecks havoc with SEO when more than one entry into a domain are published. Only one should be utilized and all others should redirect to one and only one. We want all http://example.com and http://www.example.com and https://example.com to redirect to https://www.example.com. Note: the https://www is the only way into the site. For example:

    A standard redirect resulted in issues or intermittent redirects from an http:// to https:// address. Here's the correct htaccess redirect rule:

    RewriteCond %{HTTPS} off
    RewriteRule (.*) https://%{HTTP_HOST}%{REQUEST_URI}
    To force https://example.com or non www. to www. or https://www.example.com:

    Code:
    RewriteEngine On
    RewriteCond %{HTTP_HOST} !^www\. [OR,NC]
    RewriteCond %{HTTPS} off
    RewriteRule ^ https://www.example.com%{REQUEST_URI} [NE,R=301,L]
    Both of the above can be placed into .htaccess.

    Also note, I suspect we'll see more using ssl since Google announced months ago that ssl will benefit sites in the SERPs.

    Just some friendly suggestions,
    William
    Last edited by William Thomas Jr; Wed 5th Aug '15, 2:24pm.

    Leave a comment:


  • Wayne Luke
    replied
    This is a known issue at this time and we're working to fix it using protocol relevant URLs in an upcoming version.

    http://tracker.vbulletin.com/browse/VBV-14906

    Leave a comment:


  • William Thomas Jr
    replied
    What about both config.php files?

    In root/: $config['baseurl_login'] = 'https://www.example.com';

    and in root/core/includes config.php: $config['Misc']['baseurl'] = 'https://www.example.com';

    Leave a comment:


  • mattewan
    replied
    Under Site Name / URL Settings I have the following settings:

    VBulletin URL: https://www.wulfware.co.uk/vb
    Login URL: https://www.wulfware.co.uk/vb
    Core URL: https://www.wulfware.co.uk/vb/core

    Is there anywhere else I need to define these settings?

    Leave a comment:


  • Mark.B
    replied
    Do you have https reflected in all three URL settings?

    Leave a comment:


  • mattewan
    started a topic Problem with https site not loading stylesheets

    Problem with https site not loading stylesheets

    Hello,

    I have an issue with my vbulletin 5 site. For the past year I haven't used it because of all the bugs in vbulletin 5 rendering it unusable and bugs that i reported taking over 6 months to be fixed.

    Anyway, I month or so ago I upgraded to the latest version and I am now trying to add articles but I have hit a problem.

    Random pages will server the stylesheets from http instead of https causing the browser to not trust the content. I have logged into the admin panel, clicked "clear system cache" and then all the pages work again, for a while (maybe because I'm logged in?) then they start not rendering properly again.

    The url is: https://www.wulfware.co.uk/vb

    For me, at the moment, that page above doesn't load correctly. If i click the blogs link, that page works, go back to forums and I have an incomplete page again.

    I have attached a screenshot of the site name / url settings in the admin panel. It also shows my version number (im one version behind, but I'm not upgrading unless it's a confirmed bug in the version I'm using).

    Also, if I'm logged in, all the pages render correctly.

    How can I fix this? I really hope it's a setting and not a bug - I can't take any more disappointment.

    Thanks in advance.

Related Topics

Collapse

Working...
X