Announcement

Collapse
No announcement yet.

Upgrade to 5.1.8 failed during last step

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Upgrade to 5.1.8 failed during last step

    I'm upgrading my 4.2.3. system to 5.1.8. It's a medium sized system with 2M posts. The upgrade ran for 10 hours and went through each version until it came to 5.1.8.

    After going through all of the 518, this happened:


    Processing XML
    ----------------------------------
    Step 14 - Importing vbulletin-style.xml
    Template Group: Admin
    Template Group: BB Code
    Template Group: Blog
    Template Group: Blog Admin
    Template Group: Color
    Template Group: Content Entry
    Template Group: Conversation
    Template Group: CSS
    Template Group: Display
    Template Group: Editor
    Template Group: Error
    Template Group: Group
    Template Group: Human Verification
    Template Group: Inline Moderation
    Template Group: Link
    Template Group: Login
    Template Group: Media
    Template Group: Modify
    Template Group: Pagenav
    Template Group: Photo
    Template Group: Picture
    Template Group: Private Message
    Template Group: Profile
    Template Group: Screen Layout
    Template Group: Search
    Template Group: Group Admin
    Template Group: Subscription
    Template Group: Tag
    Template Group: User Profile Field
    Template Group: User Setting
    Template Group: Module
    Template Group: Ungrouped Templates 1
    Template Group: Ungrouped Templates 2
    Template Group: Ungrouped Templates 3
    Template Group: Ungrouped Templates 4
    Template Group: Ungrouped Templates 5
    Template Group: Ungrouped Templates 6
    <b>API Error</b><br><b>Error:</b> invalidid<br><b>Args:</b><br><pre style="font-family:Lucida Console,Monaco5,monospace;font-size:small;overflow:auto;border:1px solid #CCC;">array (
    0 =&gt; 'styleid',
    )</pre>
    FORUMS-QRZ-120:/c/forums/htdocs/core/install$

    I'm baffled. Can anyone help?


  • #2
    For completeness, I should mention that my mysql and php are both up to date with vB requirements.

    Comment


    • #3
      Have you tried refreshing the page? It may simply carry on.
      MARK.B | vBULLETIN SUPPORT

      TalkNewsUK - My vBulletin 5.5.6 Demo
      AdminAmmo - My Cloud Demo

      Comment


      • #4
        This was a command line upgrade, and yes, I restarted it several times. Each time it printed the same thing (as shown above).

        Comment


        • #5
          What is the URL to your site please? The URL in your license doesn't work.
          MARK.B | vBULLETIN SUPPORT

          TalkNewsUK - My vBulletin 5.5.6 Demo
          AdminAmmo - My Cloud Demo

          Comment


          • #6
            Did you try removing all non-default styles from your site prior to upgrading? (No vB4 styles/templates will work with vB5.)

            Please don't PM or VM me for support - I only help out in the threads.
            vBulletin Manual & vBulletin 4.0 Code Documentation (API)
            Want help modifying your vbulletin forum? Head on over to vbulletin.org
            If I post CSS and you don't know where it goes, throw it into the additional.css template.

            W3Schools &lt;- awesome site for html/css help

            Comment


            • #7
              Well, no I didn't remove them. That wasn't in the upgrade instructions, as I recall. So how do I recover? I don't need my old styles.
              Last edited by aa7bq; Sat 18th Jul '15, 1:45pm.

              Comment


              • #8
                Okay, thanks to Lynne for giving us the clue that allowed us to pull an all-nighter and finally get it going. It was my old templates/styles from vb 4.2.3.
                The fix was somewhat nail biting. We dumped the Templates and Style, Stylevar, etc., tables and got fresh ones from a new install on another database. By some miracle, it worked.

                I've just spent all day figuring out the API access so that I can perform logins remotely. If your developers had any sense of pride in their work, they'd throw together a quick how-to guide for this. I suppose they're afraid to commit to a published interface and if that's the case, I can look forward to a future debacle when they decide to alter the API without warning.

                Sure, those are harsh words, but seriously, all you have to do is show some professionalism and do your documentation.

                Comment


                • #9
                  I've faced with the same problem. And I stuck now. After this error I found this thread and I tried to restore forum vB 4.2.3 from my backup and removed all styles except the standard. But every time I've got the same error.

                  Actually my forum works under vB 3.8.9, but I need to upgrade it up to vB 5.1.9. I couldn't update vB 3.8.9 to vB 5.1.9 in the one moment. But I was able to make the first step and upgraded it to vB 4.2.3. But I cannot update it to vB 5.1.9 now. Please help!

                  Comment

                  Related Topics

                  Collapse

                  Working...
                  X