Announcement

Collapse
No announcement yet.

Glitches in Latest Topics Module?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Glitches in Latest Topics Module?

    So... I've noticed a couple REALLY annoying problems in the latest topics module. For some reason, some threads aren't pulled to the top when they're replied to. Appearing out of order on the page. And other time, topics that get replied to don't even get pulled into the module at all, which makes it more difficult for someone looking at the main page of my site to know someone has replied to the thread recently. I've also noticed that sometimes the topic doesn't update when people reply to the thread and the avatar that shows on the right doesn't update... Is there any way to fix this? I'll post the JSON code it's using.

    Code:
    {"date":{"from":"10"},"channel":["3","15","16","17","80","81","82","34","38","12241","18","19","20","21","22","83","194","1934","23","24","25","26","31","33","43","345","346","12394"],"sort":{"lastcontent":"desc"},"view":"topic","exclude_type":["vBForum_PrivateMessage"]}
    I've also tried clearing the system cache. This fixes the last two issues. But it doesn't fix the issue with threads not being included. I know it's not a channel issue, because other topics from the same channel are getting pulled into the search results. So any idea...?

    http://www.t5forums.com/

    This is the site.
    Want bigger avatars for your forum? There's a mod here. But be sure to vote for the JIRA requesting the fix here!

  • #2
    Ok, so I actually figured part of this out. Where topics weren't showing up in the module.

    The problem was the "date" option. I initially had it set to 30 days, and then dropped it to 10. Apparently, regardless of your other options, this date option targets ONLY the date that the topics were CREATED on. So any topics older than 10 days or 30 days weren't appearing. I bumped it up to 100,000 days. Should prevent it from happening again. =3

    Perhaps that should be explained in the module settings by default? Perhaps one of those clickable question mark buttons that litter the admin CP.
    Want bigger avatars for your forum? There's a mod here. But be sure to vote for the JIRA requesting the fix here!

    Comment

    Related Topics

    Collapse

    Working...
    X