Announcement

Collapse
No announcement yet.

TO keep users logged in

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • TO keep users logged in

    How can I keep users logged in without logging out automatically until they logout manual in the forum and in Mobile apps
    http://www.vbulletin.com/forum/filed...ledataid=63608

  • #2
    Could you please help
    http://www.vbulletin.com/forum/filed...ledataid=63608

    Comment


    • #3
      They should check the Remember Me box when they log in. They will stay logged in for 30 days.
      Translations provided by Google.

      Wayne Luke
      The Rabid Badger - a vBulletin Cloud demonstration site.
      vBulletin 5 API - Full / Mobile
      Vote for your favorite feature requests and the bugs you want to see fixed.

      Comment


      • #4
        Ok, Thanks
        http://www.vbulletin.com/forum/filed...ledataid=63608

        Comment


        • #5
          Hi there Wayne. There seems to be an ongoing problem that this check box doesn't work. I continually get messages from users who say that even though they tick the box on their mobile device, they have to log in again next time they visit.. Is there a fix?

          Comment


          • keiahnig
            keiahnig commented
            Editing a comment
            I am also having this problem on my PC now and I don't think it should be that we need to delete cookies every time we get this problem. Is there another solution?

        • #6
          If the cookie prefix in your /config.php and /core/includes/config.php file do not match, you will be logged out. If you delete your cookies, you will be logged out. If you use a cookie manager, you will be logged out. If you don't accept cookies, you will be logged out. If you have Javascript disabled, you will be logged out. If users are on mobile devices, the only browsers that are officially supported are the Android Browser and Safari for iOS. However can't replicate this problem using Google Chrome on iOS or Silk Browser on FireOS.

          The deletion of cookies is the cause of the problem. Unfortunately "Users getting logged out" isn't really enough information. What are their environments? What version are you using? Are they using ad blockers? Cookie Blockers? Javascript Blockers? Have they modified their mobile OS (i.e. Rooted or Jailbreak, neither of which are supported)?
          Translations provided by Google.

          Wayne Luke
          The Rabid Badger - a vBulletin Cloud demonstration site.
          vBulletin 5 API - Full / Mobile
          Vote for your favorite feature requests and the bugs you want to see fixed.

          Comment


          • #7
            Hi Wayne, thanks so much for getting back to me about this as it is getting annoying. I have a feeling it has something to do with the cookie prefix as all the other things you mentioned are not being done. It is also suspicious that this problem has only come up after the latest upgrade (5.1.8). I will get back to you on that. I had the same problem today when I went to the page on my latest version firefox browser on my desktop PC, I had to log in again although I had ticked the box yesterday. One of the users that complained is using Safari on her stock standard Iphone with the same results...

            Comment


            • #8
              Hi Wayne, I am still having problems with this and my users are getting annoyed.. The cookie prefixes match as 'bb' stock standard and the browsers and devices are all stock standard and of the latest mark. The computer I am using to write this and the browser are all standard with Chrome and my login was saved (kept me logged in) on this help forum but not on my own forum. Would you recommend changing the cookie prefix to something else and trying again? Thanks for your help..

              Comment


              • #9
                Upgrade to 5.1.9 PL1 in the first instance. Older versions will have bugs that may have been fixed subsequently. I know that work gets done on the login system in quite a few versions, including this specific issue.

                I do think on some server setups this is just going to be an issue at the moment. My demo site does log me out from time to time, I believe there's still an open bug surrounding this but it doesn't affect every site.
                MARK.B | vBULLETIN SUPPORT

                TalkNewsUK - My vBulletin 5.5.6 Demo
                AdminAmmo - My Cloud Demo

                Comment


                • #10
                  Thanks for the quick reply, I think I just screwed something up... In my frustration I changed the ADMINCP cookie settings to the directory of my forum... It fixed the problem of logging me out of my forum but now I can't log into the ADMINCP.. HELP! Ha.. Sorry about that I should have listened to the warning.. Strange though that it fixed the problem but now I can't get to the ADMINCP.. What do I need to do?
                  PS I upgraded to the latest patch before this
                  Last edited by keiahnig; Fri 6th Nov '15, 2:16am.

                  Comment


                  • #11
                    What setting exactly did you change?
                    MARK.B | vBULLETIN SUPPORT

                    TalkNewsUK - My vBulletin 5.5.6 Demo
                    AdminAmmo - My Cloud Demo

                    Comment


                    • #12
                      I changed the default cookie setting of / to /forum/ (my forum directory)..
                      Unfortunately I can't tell you the exact setting as I can't get in there but its the first one about where the cookies are saved.
                      Sorry about that, what a pain

                      Comment


                      • Wayne Luke
                        Wayne Luke commented
                        Editing a comment
                        Do not change this setting unless you are running multiple vBulletin installations on the same domain. Even then, just changing the cookie prefix variables is the easier way to handle this.

                    • #13
                      1) Upload the /core/install folder from your download package.

                      2) Upload tools.php from your "do_not_upload" folder. This should go into your core/admincp directory.

                      3) Load this in your browser by going to: yourforums/core/admincp/tools.php

                      4) Enter your customer ID.

                      5) Click on Reset Cookie Path and Reset Cookie Domain.

                      6) Delete tools.php from your server.

                      7) Delete the /core/install folder from the server.

                      8) See if you can login.
                      MARK.B | vBULLETIN SUPPORT

                      TalkNewsUK - My vBulletin 5.5.6 Demo
                      AdminAmmo - My Cloud Demo

                      Comment


                      • #14
                        Yessssssssss! You are a life saver, I can log in again. I owe you a drink. For info the setting I changed was 'path to save cookies' from the default '/' to '/forum/'. I was hoping that would fix the log in thing. Obviously not..Oh well I think I am better off just leaving it..

                        Comment


                        • #15
                          1. Make sure your cookie settings are the default.
                          2. Remove your existing cookies and log in again.

                          If you are using both www and non-www URLs, you should redirect one to the other using .htaccess or other webserver level redirect. Redirect to the one specified in your AdminCP under Settings -> Site Name / URL / Contact Details.
                          Translations provided by Google.

                          Wayne Luke
                          The Rabid Badger - a vBulletin Cloud demonstration site.
                          vBulletin 5 API - Full / Mobile
                          Vote for your favorite feature requests and the bugs you want to see fixed.

                          Comment

                          widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                          Working...
                          X