Announcement

Collapse
No announcement yet.

Facebook Connect, the Publish to Facebook option is not working

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Zachery
    replied
    Originally posted by Wayne Luke View Post


    This isn't necessary and will actually end up causing more problems than it is worth.
    I was under the impression it was required. Sorry

    Leave a comment:


  • Wayne Luke
    replied
    Originally posted by Zachery View Post
    Submit your app for approval.

    This isn't necessary and will actually end up causing more problems than it is worth.

    Leave a comment:


  • Zachery
    replied
    Submit your app for approval.

    Leave a comment:


  • Richy
    replied
    Thanks Wayne, the settings were shown in the original screen prints 3 and 4, which you will find above.

    Leave a comment:


  • Wayne Luke
    replied
    Can't see any problems with your settings on the Facebook Side. I don't know what your vBulletin settings are though and that is what we really support here.

    Use these instructions:
    www.vbulletin.com/go/fbconnect

    Leave a comment:


  • Richy
    replied
    Evidently I am not going to get any help on this from the Forum, so I will raise a support ticket.

    Leave a comment:


  • Richy
    replied
    Hi Wayne, Yes I went back through all the settings and found I had made one omission which I then rectified. I have double-checked everything I can yet nothing gets posted. We have a Globalsign security certificate on the forum and so the URL within the Facebook App is set to https - can this be an issue or ok? Please see screen prints which show it is live and Facebook logins working.
    Click image for larger version

Name:	FB2.jpg
Views:	36
Size:	140.9 KB
ID:	4322007 Click image for larger version

Name:	FB1.jpg
Views:	12
Size:	136.5 KB
ID:	4322008 Click image for larger version

Name:	FB3.jpg
Views:	11
Size:	133.1 KB
ID:	4322009
    Attached Files

    Leave a comment:


  • Wayne Luke
    replied
    The screenshots do not tell my why you cannot publish to Facebook. Did you follow the instructions I pointed to?

    Leave a comment:


  • Richy
    replied
    I found one omission in that I had not entered the App Domains section correctly. I have edited this. I now do not receive the Waiting for Facebook errors, however my post still does not get made to Facebook. Any ideas.

    Leave a comment:


  • Richy
    replied
    Hi Wayne, thanks for the reply.

    Please see the screenprints for all related details, but I copy the config below. We upgraded PHP in preparation prior to the FB implementation.
    Server Type Linux Users to Moderate 0 [View]
    Web Server Apache v2.4.7 Topics to Moderate 1 [View]
    PHP 5.5.9-1ubuntu4.9 Posts to Moderate 1 [View]
    PHP Max Post Size 8.00 MB MySQL Version 5.5.43-0ubuntu0.14.04.1
    PHP Maximum Upload Size 2.00 MB MySQL Packet Size 16.00 MB
    PHP Memory Limit 128.00 MB
    I followed the steps in the sticky note instructions and all appears ok, as I can act as a new visitor and Register/Login using FB. The only issue is that although the option is on screen to copy the post onto FB, this does not work (please see screenprints for what happens).

    Any help / advise very welcome.

    Cheers . . .R

    Leave a comment:


  • Wayne Luke
    replied
    What version of PHP are you using?

    Also make sure your app on Facebook's end is set up like the instructions here: http://www.vbulletin.com/go/fbconnect/

    Leave a comment:


  • Richy
    replied
    Hi again, just wondering if there is any update on this topic?
    Cheers . . . Richard
    Last edited by Richy; Wed 20 May '15, 7:07am.

    Leave a comment:


  • Richy
    replied
    Hi Zach, thanks I have uploaded the screenprints now including one from the MyApps on Facebook which shows that it has recognised the login via FB (1 X user login) So the interaction is working and a test user profile has been created using Login with FB. So all fine except for the sharing of a post onto FB. I've double-checked the options and all seems ok. I notice that within the post, where the option is to share on FB that what looks like a checkbox is blank and cannot be checked. Could this be the issue?

    Thanks again Rich

    Leave a comment:


  • Zachery
    replied
    You haven't attached anything, but did you app get published to facebook?

    Leave a comment:


  • Facebook Connect, the Publish to Facebook option is not working

    I have followed the setup instructions and have created a login by Facebook user which all worked fine. However even though the settings in Facebook Options are correct, the user cannot share their post onto Facebook. Please see the attached Word document containing 3 screenprints.

    Thanks in advance for any advice R
    Attached Files
    Last edited by Richy; Mon 18 May '15, 6:42am. Reason: With screenprints

Related Topics

Collapse

Working...
X