Announcement

Collapse
No announcement yet.

Private Messaging not working for registered users

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Private Messaging not working for registered users

    Using VB 5.1.6

    Anyone know how to enable private messaging for registered users? works just fine for super moderators and administrators. If i try and turn it on for other user groups those users will get into the message centrer but cannot compose a new message or reply to any messages they have received by a mod or admin of course. they just see a message saying they are not authorized?

    I have the following options enabled for my registered users group. i even setup another usergroup and set every permission to yes! and i still couldn't get registered users to compose a pm.
    Private Message Permissions
    Maximum Stored Messages:If you set this to 0 users from this usergroup will not be able to use private messaging. 25
    Can Ignore Quota
    no
    Maximum Recipients to Send PMs at a time do not set this too high for performance reasons (set to 0 to allow unlimited recipients) 1
    Any advise would be greatly received.
    Last edited by sichapman; Tue 28th Apr '15, 2:22pm. Reason: Just to say have updated to patch level 1 and still same problem?

  • #2
    I'm having this issue. Wasn't having it with 5.1.6, but it happened after I installed the patch level 1. Weird. All of my settings are fine. Only admin can send a PM. Registered users says that they aren't authorized, but when I check the permissions it shows that are authorized, and it was working before the patch installation.

    Comment


    • #3
      Just some ideas:
      • Did you change anything under 'AdminCP > Settings > Options > Private Messaging Options', for example did you turn off the whole PM system by accident?
      • Under 'AdminCP > Usergroups > [Edit usergroup] > Create Permissions', is 'Can create private message' set to yes?

      Comment


      • #4
        Originally posted by TLMD View Post
        Just some ideas:
        • Did you change anything under 'AdminCP > Settings > Options > Private Messaging Options', for example did you turn off the whole PM system by accident?
        • Under 'AdminCP > Usergroups > [Edit usergroup] > Create Permissions', is 'Can create private message' set to yes?
        I've checked, and double checked, all of the Private Messaging permissions and they're all ok. Private Messaging is active, and all users have permission to create and use the Private Messaging function.

        Comment


        • #5
          Are there any secondary groups involved that don't have permission to send private messages?

          What happens if you go to Usergroups -> Channel Permissions and scroll all the way down to Special then click the "Reset" link to the right of that channel name?
          Translations provided by Google.

          Wayne Luke
          The Rabid Badger - a vBulletin Cloud demonstration site.
          vBulletin 5 API - Full / Mobile
          Vote for your favorite feature requests and the bugs you want to see fixed.

          Comment


          • #6
            Wayne, it worked. I reset the "Special." What is the special? I "deny all" because I didn't know what it is. Should I just leave it as is? Not sure what it is.

            Also, what is the difference between Channel Permissions in the Channel Management section and the Channel Permissions in the Usergroups section?

            Comment


            • #7
              Just to confirm Waynes solution fixed our problem too.

              Comment


              • #8
                Originally posted by online68 View Post
                Wayne, it worked. I reset the "Special." What is the special? I "deny all" because I didn't know what it is. Should I just leave it as is? Not sure what it is.

                Also, what is the difference between Channel Permissions in the Channel Management section and the Channel Permissions in the Usergroups section?

                The Special channel holds infractions, private messages, visitor messages, albums from the user profile, etc... It is for things that don't have real channels. Technically there is a Private Messages channel hidden under Special. I'd prefer the entire Specials channel was hidden from the interface but they only hid private messages and albums for some weird reason.
                Translations provided by Google.

                Wayne Luke
                The Rabid Badger - a vBulletin Cloud demonstration site.
                vBulletin 5 API - Full / Mobile
                Vote for your favorite feature requests and the bugs you want to see fixed.

                Comment


                • #9
                  I have searched the forums but this is the only thread I've come across for the same problem I'm having. We recently upgraded from vB 3.8.6 (I know) to vB 5.3.1. Administrators can send PMs but Registered users cannot. There's no error message, but when they go to the Message Center they have no "Compose New" button and they cannot reply to PMs in their inboxes.

                  All "regular" members are in the Registered Usergroup as their Primary group. That Usergroup has:
                  - Can create private messages = Yes
                  - Maximum Stored Messages = 250
                  - Can Ignore Quota = No
                  - Can Use vB Messenger = No
                  - Maximum Recipients to Send PMs at a time = 5

                  In Settings > Options > Private Messaging and vB Messenger Options:
                  - Private Messaging Enabled = Yes.
                  - Instant Messaging Support = Yes
                  - Minimum Characters Per Message = 1
                  - Maximum Characters Per Message = 300
                  - Minimum Time Between Private Messages = 15
                  - Skip floodcheck for PM Replies = No

                  I have changed and reset these permissions (usually one at a time) to no effect.

                  I tried the solutions above with the Channel Permissions:
                  - Reset permissions for Special > Private Messages (it's exposed individually in vB 5.3.1)
                  - Reset permissions for Special (and presumably all of its children)

                  I also cleared the system cache (partly to solve another issue).

                  No effect for any of these. Registered users still cannot send PMs.

                  Anyone have any suggestions?

                  Thanks
                  Last edited by TexArkana; Fri 30th Jun '17, 6:41pm.

                  Comment


                  • #10
                    In the Private Message channel, what are the permissions? Especially the "Can Create" permissions at the bottom of the list?

                    Channel Management -> Channel Permissions. Scroll down to Special -> Private Messaging
                    Translations provided by Google.

                    Wayne Luke
                    The Rabid Badger - a vBulletin Cloud demonstration site.
                    vBulletin 5 API - Full / Mobile
                    Vote for your favorite feature requests and the bugs you want to see fixed.

                    Comment


                    • #11
                      Hi Wayne,

                      Thanks for the reply. That's one of the things that baffled me... In the Private Messages channel, I had also tried setting the permissions for the "Registered" Usergroup (our default primary group for members) so that "Can create private message" was set to Yes. It was still a no go.

                      I actually have it working now. Upon re-reading the help topic for the "Can create private message" permission, this caught my attention:
                      Members can create private messages in any channel where one of their usergroups has this permission. This only makes sense and should only be assigned in the private message channel.

                      The last sentence made me think, "Hmmm... well then, even though that permission exists in any given Usergroup, perhaps we're not supposed to set it to Yes in a Usergroup." So, here's what I did:

                      (1) Under Channel Permissions > Special > Private Messages, I set "Can create private message" to No.

                      (2) I then set "Can create private message" to No for all of our Usergroups. Everything is No for that permission now.

                      (3) I went back to Channel Permissions > Special > Private Messages, and set "Can create private message" to Yes for the Registered group.

                      For better or worse, right way or wrong, that worked. In the Registered Usergroup (under Usergroup Manager), the "Can create private message" permission is still set to No. But it's set to Yes for that group under the Private Messages channel. And it works.

                      Maybe that'll help someone else down the road.

                      Cheers!

                      Comment

                      Related Topics

                      Collapse

                      Working...
                      X