Announcement

Collapse
No announcement yet.

Problem with Facebook Connect

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Problem with Facebook Connect

    Hello,

    I have "successfully" setup Facebook Connect, to the point that the "Login with F" link appears on new user registrations and the "Connect to Facebook" option is available in the user account section for existing users.

    However, when one attempts to actually sign into Facebook, they get the error message: "Error: An unexpected error was returned: 'Facebook SDK failed to initialize'"

    I have searched Google and these boards to no effect. It appears that other vB Connect boards have this working, so I'm not sure where to troubleshoot the issue on my forum. Any help would be greatly appreciated!

  • #2
    Are you running PHP 5.3?

    Comment


    • #3
      Originally posted by Kevin Sours View Post
      Are you running PHP 5.3?
      Yep

      Comment


      • #4
        I should have provided the board info so others could see what I mean: http://forum.highonhockey.com/

        Comment


        • #5
          vB 5.1.6 and in particular the new Facebook SDK doesn't support php 5.3, you'll need to upgrade to at least php 5.4

          Comment


          • #6
            Originally posted by Kevin Sours View Post
            vB 5.1.6 and in particular the new Facebook SDK doesn't support php 5.3, you'll need to upgrade to at least php 5.4
            Ah, your question was a bit of a trick one then. I asked my host who claims that their servers are updated with the latest version of PHP. vB 5.1.6 had no issues installing and runs fine other than that Facebook issue and a few other bugs that I believe are already known issues with vB Connect.

            Are there any other troubleshooting steps I can take? Do you know of a way I can verify for myself which version of PHP is installed on the server my site is hosted on?

            Comment


            • #7
              The latest version of PHP is 5.6.7. PHP 5.3.X is no longer supported by the PHP Group. The requirement for PHP 5.4.X when using Facebook Libraries is a requirement from Facebook that we have to adhere to.

              To see your PHP version, you can go to Maintenance -> View PHP Info. It will be listed at the top of the resulting page. If you are using a web server with cPanel, you might be able to change your version to a higher version under Software -> Select PHP Version. If that is possible, I suggest using PHP 5.5 for bug fixes and performance improvements in PHP.
              Translations provided by Google.

              Wayne Luke
              The Rabid Badger - a vBulletin Cloud demonstration site.
              vBulletin 5 API - Full / Mobile
              Vote for your favorite feature requests and the bugs you want to see fixed.

              Comment


              • #8
                Originally posted by Wayne Luke View Post
                The latest version of PHP is 5.6.7. PHP 5.3.X is no longer supported by the PHP Group. The requirement for PHP 5.4.X when using Facebook Libraries is a requirement from Facebook that we have to adhere to.

                To see your PHP version, you can go to Maintenance -> View PHP Info. It will be listed at the top of the resulting page. If you are using a web server with cPanel, you might be able to change your version to a higher version under Software -> Select PHP Version. If that is possible, I suggest using PHP 5.5 for bug fixes and performance improvements in PHP.
                You and Kevin were 100% right. I was able to use the information in the adminCP to go back to my host and get them to upgrade to 5.5.9. Now Facebook Connect works perfectly.

                Thank you very much for your help

                Comment

                Related Topics

                Collapse

                Working...
                X