Announcement

Collapse
No announcement yet.

Automatic spacing cause problem in Thai language

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Automatic spacing cause problem in Thai language

    Hello, i setup a website with vBulletin 5 and got problem with Thai language from text auto spacing, with this feature it can cause miss understanding sentences in our language.

    there was no problem in English because it always have space in ever word.

    How could i disable it ?

    i test it in English for easy understanding, screenshots in image below, please take a look.


    I try to create the English text with out spacing in text editor before post.

    Click image for larger version

Name:	beforepost.png
Views:	8
Size:	6.2 KB
ID:	4316488

    The result of English text without spacing when click preview, red arrow point to the auto text spacing

    Click image for larger version

Name:	preview.png
Views:	0
Size:	4.8 KB
ID:	4316489




    The result of English text without spacing when when posted.

    Click image for larger version

Name:	afterpost.png
Views:	1
Size:	9.6 KB
ID:	4316490


    The result of Thai language in text editor before post, green arrows show text in very long sentence without problem.
    Click image for larger version

Name:	thai_beforepost.png
Views:	0
Size:	4.5 KB
ID:	4316491

    The result of Thai language after posted, the red arrows show posted text problem in very long sentence.
    It very hard to read and sometimes can cause miss understanding. text in Thai can't have a space in very words like English style.

    Click image for larger version

Name:	thai_preview.png
Views:	0
Size:	7.3 KB
ID:	4316492

  • #2
    Try this setting:

    AdminCP > Settings > Options > Topic Display Options > Number of Characters Before Wrapping Text
    Set that to 0.

    Should end up with this:
    http://www.talknewsuk.com/testvb/node/15536
    MARK.B | vBULLETIN SUPPORT

    TalkNewsUK - My vBulletin 5.5.6 Demo
    AdminAmmo - My Cloud Demo

    Comment


    • #3
      Originally posted by Mark.B View Post
      Try this setting:

      AdminCP > Settings > Options > Topic Display Options > Number of Characters Before Wrapping Text
      Set that to 0.

      Should end up with this:
      http://www.talknewsuk.com/testvb/node/15536
      Thank you Mark, it's work like charm

      Comment

      Related Topics

      Collapse

      Working...
      X