Announcement

Collapse
No announcement yet.

Hitting 'New Topics' on forum page brings up error message - how do we configure?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Hitting 'New Topics' on forum page brings up error message - how do we configure?

    We have just noticed that when on the forum page when we hit the words 'New Topics' immediately below the home tab and immediately to the right of 'Who's online' we get an error message which is "Your criteria is not restrictive enough and might return too many results. Please restrict your criteria and try again." The breadcrumb shows 'Home, Advanced Search, Search Results" when we get this error message.

    I'm guessing that this must be to do with a configuration setting within one of the modules on the page. Which setting and module is it?

    On that page I have

    - Announcement Module
    - Page Title Module
    - Sub-Channels Display Module
    - An ad widget (it won't be this one)
    - Channel Display Module

    So which of these modules is taking me to the Advanced Search function? Or is it something else? How do I stop this error message?
    Attached Files

  • #2
    Use more keywords to restrict your search.

    What is the string used for the search?
    Last edited by Wayne Luke; Fri 13 Mar '15, 10:27am.
    Translations provided by Google.

    Wayne Luke
    The Rabid Badger - a vBulletin Cloud demonstration site.
    vBulletin 5 API

    Comment


    • jdj
      jdj commented
      Editing a comment
      It's not a search; it's just when we hit the New Topics link that we get taken to the search function. I had assumed it was to do with one of the widgets.

  • #3
    New Topics does this on some sites since 5.1.5. At this stage I have no idea why. I've seen it enough times now to warrant raising it as a bug, which I will do shortly, but I have currently no idea what makes it do this.

    If you want to send a support ticket for my attention with your admincp login, I'll set a slightly different URL that will work properly.
    http://www.vbulletin.com/go/techsupport
    MARK.B | vBULLETIN SUPPORT

    TalkNewsUK - My vBulletin 5.6.4 Demo
    AdminAmmo - My Cloud Demo

    Comment


    • jdj
      jdj commented
      Editing a comment
      I have put in a support ticket marked for your attention.

  • #4
    Hi Mark,

    we are running into the same problem after upgrading from 4.2.2 to 5.1.7.
    Please provide the changes required to prevent the error message.

    Thanks in advance,
    Julian

    Comment


    • #5
      Never mind, i just copied the JSON from this forums "Latest Topic" link.

      For anyone else running into the same problem:
      {"date"%3A"lastVisit"%2C"view"%3A"topic"%2C"unread_only"%3A1%2C"sort"%3A{"lastcontent"%3A" desc"}%2C"exclude_type"%3A["vBForum_PrivateMessage"]}

      Comment


      • #6
        That's exactly the fix I use.
        MARK.B | vBULLETIN SUPPORT

        TalkNewsUK - My vBulletin 5.6.4 Demo
        AdminAmmo - My Cloud Demo

        Comment


        • #7
          Originally posted by Mark.B View Post
          That's exactly the fix I use.
          Any more detail on this for how you fix this problem?

          Comment


          • #8
            You need to edit the navbar using Site Builder and replace the relevant link with the code posted.

            If you are unsure, please raise a support ticket for my attention, include admincp credentials and I'll complete this for you.
            http://www.vbulletin.com/go/techsupport
            MARK.B | vBULLETIN SUPPORT

            TalkNewsUK - My vBulletin 5.6.4 Demo
            AdminAmmo - My Cloud Demo

            Comment

            Related Topics

            Collapse

            Working...
            X