I'm so confused I'm not even sure how to phrase my question. I just upgrade from 5.2.3 to 5.2.5. Upgrade seems to have gone fine, until I tested the site with my Test User that has less permissions...