Announcement

Collapse
No announcement yet.

Error when upgrading my test forum from 5.1.4 patch 3 to 5.1.5 but eventually worked?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Error when upgrading my test forum from 5.1.4 patch 3 to 5.1.5 but eventually worked?

    I followed the instructions to make a test forum. This worked.
    I then followed the instructions to do an upgrade.


    It starts running but I got this error saying unexpected text:

    <?xml version="1.0" encoding="UTF-8"?> Warning: Invalid argument supplied for foreach() in .../install/includes/class_upgrade_515a3.php on line 82 <upgrade> <message replace="0">Updating navbar link for New Topics.</message> <status>Status: Processing 5.1.5 Alpha 4, Step 1 of 3</status> <longversion>5.1.5 Alpha 3</longversion> <version>515a4</version> <nextstep>1</nextstep> <upgradenotice><![CDATA[<strong>Upgrading to 5.1.5 Alpha 3</strong>]]></upgradenotice> </upgrade>
    My only template mods have been via new templates and the css_additional.css. I've edited no core templates. So I don't understand why I would get an unexpected text error.

    details after the upgrade stopped show:
    • Upgrading to 5.1.5 Alpha 1
    • Step 1 - Altering privatemessage Table (1 of 1)
    • Upgrading to 5.1.5 Alpha 2
    • Step 1 - Altering channel Table (1 of 1)



    And now when I get back into the upgrade.php I see
    Upgrading to 5.1.5
    Press the button below to begin the upgrade
    from 5.1.5 Alpha 3 to 5.1.5



    So it upgraded me to an alpha version and stopped???

    So I just hit upgrade again and it finished.

    Can anyone shed some light on this. I'd like to upgrade my main forum but this made me a little nervous -- is there something I should do before I upgrade my live forum?
    The reputation bar is hard coded. This is bad design.
    http://tracker.vbulletin.com/browse/VBV-14349
    Facebook 2 step registration doesn't work
    http://tracker.vbulletin.com/browse/VBV-9490
    Vbulletin android app does not work with VB5 and has no roadmap -- don't buy it! Demand better.
    http://tracker.vbulletin.com/browse/...Aroadmap-panel

  • #2
    There was likely a extra character that got output which malformated the XML we passed to the upgrader. If you can refresh it and it continues its not a serious error.

    Comment

    Related Topics

    Collapse

    Working...
    X