Announcement

Collapse
No announcement yet.

Sitemap changed in upgrade

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • arshadeomran
    commented on 's reply
    Thanks a lot!
    It works fine for vbulletin 5.1.7

  • Graham Walters
    replied
    Seems to have worked fine for me version VB5.1.6 alpha

    Leave a comment:


  • Merenguista
    commented on 's reply
    Now it works fine .. Thank you Mark ..

  • Mark.B
    replied
    You need the full SERVER path.

    For example, mine is:

    /var/www/vhosts/mysite.com/httpdocs/forum/core/store_sitemap

    Attached is a zip file. Unzip it, and upload smpath.php to the forum root (must be this exact location). Then go to yourforums.com/smpath.php.
    The file will output the correct path to use, based on a default vB5 installation. Copy and paste it into the Sitemap settings.
    Remove the file from the server afterwards.
    Attached Files

    Leave a comment:


  • megabink
    commented on 's reply
    The path in Webmasters tool should be: /core/store_sitemap/vbulletin_sitemap_index.xml.gz

  • yv3013
    replied
    I don't get it, where do I use the full path?

    This is mine..

    /home/myforum/public_html/core

    I put that in the site map file path in the xml sitemap page in cpanel.

    ok, that's good. But what about webmaster tools, what do I submit to google?
    the same address?

    I have been putting in these three but neither work anymore..

    /core/xmlsitemap.php?fn=vbulletin_sitemap_node_0.xml.gz
    /core/xmlsitemap.php?fn=vbulletin_sitemap_starter_1.xml.gz
    /core/xmlsitemap.php?fn=vbulletin_sitemap_page_2.xml.gz

    Leave a comment:


  • DisasterDotCom
    replied
    It wants a FULL path. In Windows, for example, the full path to your document directory might be "c:\users\username\Documents" (this is just an example - not what you would type in).

    On my vBulletin server, the full path for the sitemap is something like:

    /servers/www.sitename.com/forums/core

    You need to find out the FULL PATH to where your core directory is and use that.

    Leave a comment:


  • megabink
    replied
    Well the information i provided worked for me but you need to add the correct path and don't use an url or domain name....i need to add i cmodded the vbulletin_sitemap.xml.gz files within the store_sitemap folder to 0666 instead of 0644...don't know this is save but that was the only way to get it to work!

    Once you got the right path and it's accepted in your admin control panel you need to add the same path in your webmasters tool to add the sitemap!

    Leave a comment:


  • Merenguista
    replied
    Same issue here guys .. I have excactly the same issue as you too ..

    My folder "store_sitemap" (and the files in it) are chmod 777.

    I tried theses paths :

    ./core/store_sitemap
    /core/store_sitemap
    ./store_sitemap
    /store_sitemap

    But i still get this error message in the page..

    Error: You did not enter a valid value for this setting.
    Sitemap File Path

    Leave a comment:


  • yv3013
    commented on 's reply
    Yeah not sure anyone is looking at this thread, I don't know what to do with it either.
    i've fixed everything per instructions but google can't read the site map.

  • Lexus!
    replied
    I've the same problem, right after upgrading to 5.1.5.

    First it works fine with "./store_sitemap". After upgrading from 5.1.4 (latest patch), i get the message "You did not enter a valid value for this setting". No sitemaps are made anymore. Not automatically, not manual.

    I Already tried:
    ./core/store_sitemap
    /core/store_sitemap
    ./store_sitemap
    /store_sitemap
    /domains/mydomainname.nl/public_html/core/store_sitemap (it's copied from DirectAdmin filebrowser and Filezilla root path)

    The folder "store_sitemap" (and the files in it) are chmod 777.

    How can I fix my broken sitemaps? My site (vBulletin) isn't found well by Google, but without sitemaps it's only get worse. Please help!

    Leave a comment:


  • yv3013
    commented on 's reply
    No everything worked fine before the upgrade from 5.1.4 to 5.1.5.

    Isn't this the path to my sitemap?

    /core/xmlsitemap.php?fn=vbulletin_sitemap_node_0.xml.gz
    /core/xmlsitemap.php?fn=vbulletin_sitemap_starter_1.xml.gz
    /core/xmlsitemap.php?fn=vbulletin_sitemap_page_2.xml.gz

    That's what i've always had on webmaster tools and it worked fine, now all of a sudden there these errors.

    ok so I put in the path to my sitemap and same thing, those errors.

    oh man, this is hopeless.

    and what's going on with that text I pasted? is it just me or can everyone see it's gone outside the page?

  • megabink
    commented on 's reply
    No Google needs only the path to your sitemap....the Google bots will only read what's inside the xml.gz files.
    Do you allow guests/visitors on your site?....if not then Google bots can not see your site or your sitemap...or do you block Google via your htaccess maybe?

  • yv3013
    replied
    geez, what have I done?

    Leave a comment:


  • yv3013
    replied
    ok got that, thanks.

    That side of it seems to work now but I still get the errors in webmaster tools after submitting the sitemaps.

    am I doing it right? should all 3 site maps be submitted?
    We encountered an error while trying to access your Sitemap.
    Please ensure your Sitemap follows our
    guidelines and can be accessed at the location you provided and then resubmit.
    General HTTP error: HTTP 403 error (Forbidden) HTTP Error: 403

    Leave a comment:

Related Topics

Collapse

Working...
X