Announcement

Collapse
No announcement yet.

I need to disable the VIDEO script

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • I need to disable the VIDEO script

    Hi,

    In the new VB5 there is a VIDEO tag that embed any youtube video and show an image. When you click the image the video start to play. That's good if you want a fast load speed, but it's very bad if your community is part of a Youtube channel.
    It's very important to me to show the thumbnail and the real size of the video embed directly, without click that image. How can disable this plugin? is there any way to embed youtube videos without this option?

    Regards.

  • #2
    Why exactly is it bad to display a thumbnail of the video before letting the video load? Currently there is no way to disable this. Its for performance on the end users computer. I don't understand how this is a bad thing.

    Comment


    • #3
      It has 2 basic problems.

      1.- It shows a smaller size of the video, not real and it looks very bad.

      2.- It doesn't show the thumbnail of the video.

      My community is based on my Youtube channel, so the thumbnail videos are a real important part of my web. Here you have an example:

      How it looks in my actual community (vBulletin 4.2.2)
      http://justunboxing.com/showthread.p...-en-tu-Android


      How it looks in the test community (vBulletin 5.1.5)
      http://justunboxing.com/upload/forum...-en-tu-android
      Last edited by rubenban; Tue 27 Jan '15, 8:39am.

      Comment


      • #4
        It should be showing the thumbnail, that is a bug.

        Comment


        • #5
          I see... I will try to remove the script directly in the code until it is fixed. I can't use the community like this.

          SOLUTION
          -----------------
          Well, I found a solution for this issue. It wasn't difficult at all so I put it here because maybe can help someone. I don't know why vBulletin support didn't give me a help with this.

          You just have to go to AdminCP > Styles & Templates > Edit template (in your default)

          Edit the "video_frame" template and just put this code replacing the original. I highly recommend you to save the original template in a txt file in your PC in case you need to go back to the original script.

          HTML Code:
          <div class="videocontainer">
          <iframe width="560" height="315" src="//www.youtube.com/embed/{vb:raw code}" frameborder="0" allowfullscreen></iframe>
          </div>
          Add this to the css_additional.css template if you want the video resized to the with of the site. This will show the youtube video correctly in smartphones and tablets:

          HTML Code:
          .videocontainer {position: relative;padding-bottom: 56.25%; /* 16:9 */padding-top: 25px;height: 0;}
          .videocontainer iframe {position: absolute;top: 0;left: 0;width: 100%;height: 100%;}
          And now your youtube videos will be shown correctly, but of course, you can't embed other videos like vimeo, daily motion, etc. (I don't know how many video servers work with the VIDEO tag as I never used other than Youtube)
          Last edited by rubenban; Mon 23 Feb '15, 6:05am.

          Comment


          • #6
            Tengo que borrar todo lo que pone e incluir este código en vez del que hay?. Muchas gracias rubenban

            Comment


            • #7
              Thank you for the help rubenban

              Comment

              Related Topics

              Collapse

              Working...
              X