Announcement

Collapse
No announcement yet.

Last Post Not updating with new replies

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • kavih
    replied
    Okay.

    Leave a comment:


  • Wayne Luke
    replied
    Changing the code isn't something we support. I don't know where you would make those changes. However it appears you're using an older version of the software. Numerous changes have been made and caching has been enhanced in the last 8 releases.

    Leave a comment:


  • kavih
    replied
    Originally posted by Wayne Luke View Post
    By Last Posts, I am guessing you mean the "Last Post" column in the forum and/or topic list. There is no value to change how this is cached that is exposed outside the system. It should update automatically every few minutes though.
    Wayne, we are having the same problem where it is taking much longer than "every few minutes." You mention that this is a cached set of data. So, would you please tell me where I can edit this caching system (in the source code)? Thanks. The goal is to shorten the cache lifetime.

    Leave a comment:


  • wbtd
    replied
    Well, New Posts is now New Topics (which is a completely different Search then what we used to have)

    With New Posts we would get an automatic return when someone made a post in a thread.

    With New Topics we get ??
    And it doesn't automatically update every few minutes. That's the problem. It's hanging for hours and people think the discussion has died.

    Again, the only thing I have found to "fix" it is to clear the system cache. I don;t want to have to keep manually doing that but it sounds like you are telling me this lag is built into the software because vbulletin decided it would improve our performance.

    Leave a comment:


  • Wayne Luke
    replied
    I was replying to post #6 which is a completely different thing than Last Posts.
    Originally posted by wbtd View Post
    Can I get a response to this?

    I would like to see "New Posts" updated in real time.

    This feature is killing our discussions as people think there are no new posts when there is.

    By Last Posts, I am guessing you mean the "Last Post" column in the forum and/or topic list. There is no value to change how this is cached that is exposed outside the system. It should update automatically every few minutes though.

    Leave a comment:


  • wbtd
    replied
    Originally posted by Wayne Luke View Post
    Update your new topics link to this code:
    Code:
    search?searchJSON=%7B%22view%22%3A%22topic%22%2C%22unread_only%22%3A1%2C%22sort%22%3A%7B%22lastcontent%22%3A%22desc%22%7D%2C%22exclude_type%22%3A%5B%22vBForum_PrivateMessage%22%5D%7D
    1. To do this, turn on Site Builder by clicking the Edit Site button.
    2. Click on Navigation Bar
    3. Click on the edit icon (pencil) for New Topics in the Sub Navigation Bar.
    4. Past the above code into the Target URL field.
    5. Click OK
    6. Click Save Changes for the Navigation Bar.
    7. Turn off Site Builder if you wish.
    We are already using this code/link and it does not address the Last Posts not being reflected.

    Right now the only thing that seems to be working is to Clear the System Cache ( Maintenance in the Admin CP)

    Is there a way to adjust the cache time?

    Leave a comment:


  • Wayne Luke
    replied
    Synonymous in vBulletin 5. It is New Topics on this site because people complained since the results are in a topic view. On my test site, it uses the same string and it is New Posts with the default language.

    Leave a comment:


  • danijels2006
    replied
    Originally posted by wbtd View Post
    Can I get a response to this?

    I would like to see "New Posts" updated in real time.

    This feature is killing our discussions as people think there are no new posts when there is.
    I have the same problem, and only after refreshing the browser I get maybe the correct and updated posts
    Originally posted by Wayne Luke View Post
    Update your new topics link to this code:
    Code:
    search?searchJSON=%7B%22view%22%3A%22topic%22%2C%22unread_only%22%3A1%2C%22sort%22%3A%7B%22lastcontent%22%3A%22desc%22%7D%2C%22exclude_type%22%3A%5B%22vBForum_PrivateMessage%22%5D%7D
    1. To do this, turn on Site Builder by clicking the Edit Site button.
    2. Click on Navigation Bar
    3. Click on the edit icon (pencil) for New Topics in the Sub Navigation Bar.
    4. Past the above code into the Target URL field.
    5. Click OK
    6. Click Save Changes for the Navigation Bar.
    7. Turn off Site Builder if you wish.
    are you sure Wayne? that's the target URL for New Topics and not for New Posts...

    Leave a comment:


  • Wayne Luke
    replied
    Update your new topics link to this code:
    Code:
    search?searchJSON=%7B%22view%22%3A%22topic%22%2C%22unread_only%22%3A1%2C%22sort%22%3A%7B%22lastcontent%22%3A%22desc%22%7D%2C%22exclude_type%22%3A%5B%22vBForum_PrivateMessage%22%5D%7D
    1. To do this, turn on Site Builder by clicking the Edit Site button.
    2. Click on Navigation Bar
    3. Click on the edit icon (pencil) for New Topics in the Sub Navigation Bar.
    4. Past the above code into the Target URL field.
    5. Click OK
    6. Click Save Changes for the Navigation Bar.
    7. Turn off Site Builder if you wish.

    Leave a comment:


  • wbtd
    replied
    Can I get a response to this?

    I would like to see "New Posts" updated in real time.

    This feature is killing our discussions as people think there are no new posts when there is.

    Leave a comment:


  • mangoz
    replied
    Is there a way to adjust this cache time? What is the default time?

    Leave a comment:


  • Zachery
    replied
    vBulletin 5 is a fairly different beast, we do short caches in some areas where it makes sense, in order to improve performance.

    Leave a comment:


  • tsauvageau
    replied
    Zachery , Thank you! That makes sense, just wasn't positive. I thought I remembered it updating immediately on previous versions.

    Leave a comment:


  • Zachery
    replied
    There is a cache on that sort of stuff, its intentional.

    Leave a comment:


  • tsauvageau
    started a topic Last Post Not updating with new replies

    Last Post Not updating with new replies

    Our members are complaining that the "Last Post" on the forum home page does not update when a new reply has been made. It takes about 10-15 minutes before the last post is updated. Any ideas?

    vBulletin Version - 5.1.4 Patch Level 2
    PHP Version - 5.4.16
    MySQL Version - 5.6.20
    Any Addons installed - No
    Does the issue occur in a default style? - Yes
    Does the issue occur using the English language provided? - Yes
    Error message on the screen' - None
    Browser and Browser version used. - IE, Firefox, Chrome (newest versions)

    http://forums.iboats.com/

Related Topics

Collapse

Working...
X