Announcement

Collapse
No announcement yet.

Error activating SiteBuilder. (Error code 0) - A lot of my forum not working.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Error activating SiteBuilder. (Error code 0) - A lot of my forum not working.

    Hello,

    I've had a lot of trouble getting my forum to work (turns out cpanel didn't like me uploading so I had to switch to filezilla).

    Now I'm trying to open my sitebuilder, and I've being shown 'Error activating SiteBuilder. (Error code 0)'. I've been into my permissions in my ACP and allowed admin accounts to do basically everything. Still not working though.

    This is my forum. It's an installation in a subfolder of a much larger blog:
    http://expertphotography.com/forum

    Also, when I click on blogs/groups/etc. it takes me back to my main website, with a 'page not found'.

    The installation process seemed to go through fine so I don't know what's wrong. I see other people have had this problem, but I can't find a solution.

    Can you help?

    Thank you very much.
    Josh

  • #2
    Make sure the value specified in your baseurl variable in your config.php file matches the value in your browser's address bar. This includes whether or not you have www. in the URL.

    Second edit the .htaccess provided with vBulletin 5 and add the following line under RewriteEngine On:
    RewriteBase /subfolder/

    Where subfolder is the folder's name.
    Translations provided by Google.

    Wayne Luke
    The Rabid Badger - a vBulletin Cloud demonstration site.
    vBulletin 5 API - Full / Mobile
    Vote for your favorite feature requests and the bugs you want to see fixed.

    Comment


    • #3
      There was no 'RewriteEngine On'

      This is what I found under js/ckeditor/.htaccess

      What should I do?

      #
      # Copyright (c) 2003-2012, CKSource - Frederico Knabben. All rights reserved.
      # For licensing, see LICENSE.html or http://ckeditor.com/license
      #


      #
      # On some specific Linux installations you could face problems with Firefox.
      # It could give you errors when loading the editor saying that some illegal
      # characters were found (three strange chars in the beginning of the file).
      # This could happen if you map the .js or .css files to PHP, for example.
      #
      # Those characters are the Byte Order Mask (BOM) of the Unicode encoded files.
      # All FCKeditor files are Unicode encoded.
      #


      AddType application/x-javascript .js
      AddType text/css .css


      #
      # If PHP is mapped to handle XML files, you could have some issues. The
      # following will disable it.
      #


      AddType text/xml .xml

      Comment


      • #4
        That isn't our .htaccess. You need to upload the .htaccess that is included with vBulletin into vBulletin's directory.

        You'll find it in the upload directory.
        Translations provided by Google.

        Wayne Luke
        The Rabid Badger - a vBulletin Cloud demonstration site.
        vBulletin 5 API - Full / Mobile
        Vote for your favorite feature requests and the bugs you want to see fixed.

        Comment


        • #5
          SOLVED

          Thanks for your help. I guess .htaccess is a hidden file because when I dragged and uploaded the file to filezilla, it didn't upload. I uploaded the whole zip and extracted it in cpanel and then moved the .htaccess to the /forum/ folder and now everything works. Thank you!

          Comment


          • #6
            Yes... Anything with a dot or period as the first character in the filename is considered a hidden file in Unix based OSes like Linux and Mac OSX.
            Translations provided by Google.

            Wayne Luke
            The Rabid Badger - a vBulletin Cloud demonstration site.
            vBulletin 5 API - Full / Mobile
            Vote for your favorite feature requests and the bugs you want to see fixed.

            Comment


            • #7
              this topic help me to
              thanks
              blog-technologie.com

              Comment


              • #8
                Originally posted by Wayne Luke View Post
                Make sure the value specified in your baseurl variable in your config.php file matches the value in your browser's address bar. This includes whether or not you have www. in the URL.

                Second edit the .htaccess provided with vBulletin 5 and add the following line under RewriteEngine On:
                RewriteBase /subfolder/

                Where subfolder is the folder's name.
                Which folder's name should we add in? Thank you

                Im also getting an error 0 message.

                Comment


                • #9
                  Originally posted by culltail View Post
                  Which folder's name should we add in? Thank you

                  Im also getting an error 0 message.
                  What ever folder you have vBulletin installed in. I could throw out some names but only you know where you installed the software.
                  Translations provided by Google.

                  Wayne Luke
                  The Rabid Badger - a vBulletin Cloud demonstration site.
                  vBulletin 5 API - Full / Mobile
                  Vote for your favorite feature requests and the bugs you want to see fixed.

                  Comment

                  Related Topics

                  Collapse

                  Working...
                  X