Announcement

Collapse
No announcement yet.

Timestamp Error?

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Timestamp Error?

    I have 2 weird problem...

    I have setup the timezone in AdminCP and my user profile correctly, however the wrong time is being returned.

    Example I have setup GMT -5, and now the time is 8:25 am, however all post show as 9:25 am, one hour ahead.

    I had our server admin verify the server and they assure me the the time on the server and bios is correct?

    Also, the international time variable are not being converted.

    This is what my footer displays :

    In French

    Fuseau horaire GMT -5. Il est actuellement H:i.

    You see the H:i is not being converted?

    Thank-you.

  • #2
    Originally posted by M@dness View Post
    Example I have setup GMT -5, and now the time is 8:25 am, however all post show as 9:25 am, one hour ahead.
    Users can adjust date and time options, so if you are logged in, make sure everything is set up correctly under "User Settings > Account > Date & Time Options".

    Originally posted by M@dness View Post
    Fuseau horaire GMT -5. Il est actuellement H:i.

    You see the H:i is not being converted?
    This is a bug (VBV-13555). You can "fix" this temporarily, if you go to "AdminCP > Languages & Phrases > Language Manager > Edit Settings" and make sure that there are no entries under "Date/Time Formatting".
    Last edited by TLMD; Sun 4th Jan '15, 8:32am.

    Comment


    • #3
      Originally posted by TLMD View Post
      Users can adjust date and time options, so if you are logged in, make sure everything is set up correctly under "User Settings > Account > Date & Time Options".


      This is a bug (VBV-13555). You can "fix" this temporarily, if you go to "AdminCP > Languages & Phrases > Language Manager > Edit Settings" and make sure that there are no entries under "Date/Time Formatting".
      Fixed the first problem, was caused by the daylight saving time.

      For the fix you mention, would I remove the settings in the English or French file?

      And we ar talking about these settings, correct :
      %d %B %Y

      %Hh%M

      %B %Y

      %d %B %Y

      %d %B

      %Y-%m-%d %X

      ,

      _

      Comment


      • #4
        You would remove those settings from the language you are using for your frontend (in your case French). If you remove the time formats from your language file, the details from the general vBulletin options are being used and the footer shows the correct information again. (As you can see in the JIRA I linked above, there is an issue with time formats that can be entered in 2 places: the general options and the language file.)

        Comment


        • #5
          I tired removing those entries from the default Language French, however when I try to save, I get this message :

          You have defined a locale for this language but did not define all of the date/time override fields. You must define each of these fields using the formatting style that is listed. Note that this style differs from the formatting you would use in the vboptions for the normal date/time fields.

          ​It won't let me save it with a blank value?

          Comment


          • #6
            It seems as if you have still entered a locale. With every field being empty (under "Date / Time Formatting"), I have no problem when I try to save those settings.

            Click image for larger version

Name:	date-time.jpg
Views:	1
Size:	134.9 KB
ID:	4247048

            Comment


            • #7
              That was it! Clear the fields properly, emptied cache and all is working now, thank-you for the help! Much appreciated.

              Comment


              • #8
                Hi All,
                It works but now, the numbers are wrong because there is no more decimal separator...
                Please find an issue!
                Bernard

                Comment

                widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                Working...
                X