Announcement

Collapse
No announcement yet.

French forum - 30.000 members - migration 3.8.2 -> vb5

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • French forum - 30.000 members - migration 3.8.2 -> vb5

    Hi,


    This is an offline migration on a spare server willing to go from 3.8.2 in French to 5.0.0b21 in English.


    For now, I installed VB5 sucessfully, tested post creation, language translation, style applied.. all ok.
    Willing to have the old DB, I just updloaded the DB to a new one and changed the DB config.php files.


    As a result, it launched then the upgrade.php script which was intended.


    Then, at one step, upgrade 4.0.0 alpha xx it now stops and shows :


    Code:
    Action Required
    Unexpected Text:
    <?xml version="1.0" encoding="windows-1252"?>
    <?xml version="1.0" encoding="windows-1252"?>
    <error>Impossible de créer le répertoire de système de fichiers pour recevoir votre fichier attaché.</error>
    What I noted for any roll back (there is no prod downtime right now as this is just a test)
    - Checked onfig.php: not seeing many problems there.
    - Apply a 755 mask on the whole structure below the www root.. : on going may end in minutes..

    I also noted for the future migration that I should switch to English before any import task to make error messages a bit more correct..

    Would you have any idea ?



    Thanks
    Pierrick

    - - - Updated - - -

    sorry in advance for my weird title that should show the error message

  • #2
    You can't install vB5, overwrite a vB3 database, and then run the upgrader again.

    You just need to upgrade: http://www.vbulletin.com/docs/html/upgrade

    Comment


    • #3
      Thanks Zachery..

      Well, it sounds that it began to work at this step.. html source shows
      Code:
      Version Mismatch
      Your upgrade log shows that your last upgrade was to version 4.0.0 Alpha 1 but you are currently on version 3.8.7.
      And also
      Code:
      Upgrading to 5.0.0 Beta 21
      Status: Processing 4.0.0 Alpha 1, Step 89 of 109
      The 755 mask didn't changed anything ..
      What I did so far.. to be clear
      - Uploaded the content of vb5 'upload' folder to the root of my new server (the old vb3 one was in /forum).
      - Played with vb5 then decided to go over with my old DB:
      - Dump the MySQL DB from the already working vb3 server to flat files &
      - Uploaded + imported these flat files to the new DB MySQL server.

      Due to the old server file and vb3 folder structure I would like to avoid porting this mess in the new vb5.. maybe :
      - Restart from scratch..
      - Delete anything on the new server, upload the content of vb5 'upload' folder
      - Drop the new DB and Upload + import the vb3 version again
      ?

      Would you have an idea on how to resolve this error ?

      Thanks

      Comment


      • #4
        If you installed vBulletin 5 and customized it, then restored a vBulletin 3 database over it, then tried to upgrade, you're not going to get good results.

        You need to upgrade, without the clean install. Please also be aware localization support is not available right now, and won't be until after gold.

        Comment


        • #5
          vBulletin 5 is currently only in BETA, which isn't meant for live forums.

          I suggest upgrading to either 4.1.12 to 4.2.0.
          Former vBulletin user

          Comment


          • #6
            Hi guys,

            @Zachery : I don't see why this is not pssible. All is in the error message, that doesn't help but the DB formated in vb3.8 should be upgradable in vb5 or I misunderstood the whole concept

            @Amaury, thanks but there is another whole context and I guess that Beta will help me in anyway.. :
            - I have good perf but no communication with my hosting company.. I need to go away while I still can
            Build anew forum is exhausting, I would rather ebuild it fresh and clean !
            - I need to move on with a new site and forum due to a new motorbike release (which is the whole idea of my forum)
            I don't want to develop a new skin/style to burn it in 6 months
            Finally, I am one of these early Beta believers..

            Anyway.. the VB5 installer didn't helped neither.. In this case, I had to troubleshoot alone..

            Here, I would like to address a point to the whole vBulletin developpers.

            -> Please, when there is an error with a path, would it be possible to show this path ? Really.. ?
            At least there is something here that could help instead of a strange error message mixed between 2 languages..

            Well, I went to this attachement topic and either if my path was chmodded 755, my folder created, it was still not working - same error message.
            As my Control Panel is nowbroken (migration not finished) couldn;t leave it like that and I had to drill down to "where this guy gets his information" I searched the database, vb_setting which by the way can be updated as :

            UPDATE `mysqldb`.`vb_setting` SET `value` = '/your/full/path/forum/attached/' WHERE `vb_setting`.`varname` = 'attachpath';
            Replaced this manually with the right value but still, same error message. Took me more time to figure out that the trick is all in the table vb_datastore !

            For further needs.. : be careful, don't edit this vb_datastore table. Dump it to a SQL file and then DELETE * FROM it and push the INSERT (updated) commands !

            Maybe other tricks.. in case you didnt changed the paths and disabled products and plugins:
            UPDATE `mysqldb`.`vb_product` SET `active` = '0' WHERE `active` = '1'
            UPDATE `mysqldb`.`vb_plugin` SET `active` = '0' WHERE `active` = '1'
            That's all for now.. the update is going on..
            Last edited by best98; Wed 19th Dec '12, 10:15am.

            Comment


            • #7
              Its not possible because we don't support it, and you overwrite and change schemas due to the database restoration.

              Please be aware, that you may not be able to receive full support for issues you have in the future.

              Comment


              • #8
                Hi Zachery,
                Doing this runs the install/upgrade script. Isn't it there the full story of upgrading ?
                Specially when I read such comments from vBulletin Support - Spanish Team member
                Thanks

                Comment


                • #9
                  Try this:

                  - close your forum via AdminCP
                  - update the Forum URL value in AdminCP > vBulletin Options > Site Name / URL / Contact Details to a new directory on your server
                  - upload all the vB5 files to that new directory
                  - copy any custom avatar/attachment/profile pic folders to the new directory
                  - run upgrade script
                  - backup the previous forum directory
                  - empty the previous forum directory
                  - update the Forum URL value in AdminCP > vBulletin Options > Site Name / URL / Contact Details to a previous forum directory on your server
                  - move all files back to the previous forum directory

                  Does your site work then?
                  Vote for:

                  - *Admin Settable Paid Subscription Reminder Timeframe*
                  -
                  *PM - Add ability to reply to originator only*
                  - Add Admin ability to auto-subscribe users to specific channel(s)
                  - Highlight the correct navigation tab when you are on a custom page
                  - "Quick Route" Interface...
                  - Allow to use custom icons for individual forums

                  Comment


                  • #10
                    The original error is because the folder you're trying to store attachments in doesn't exist or isn't writable by the webserver. The folder specified under Attachments -> Attachment Storage type needs to be chmod 777. If you used a relative link for the folder, then you need to place the folder within the /core directory as far as I am aware. Absolute paths are easier to handle.
                    Translations provided by Google.

                    Wayne Luke
                    The Rabid Badger - a vBulletin Cloud demonstration site.
                    vBulletin 5 API - Full / Mobile
                    Vote for your favorite feature requests and the bugs you want to see fixed.

                    Comment


                    • #11
                      HI,

                      @Trevor & Wayne: I definitely appreciate your support and help but when you re upgrading the forum, no AdminCP is possible at any point, unless you hang it and rename the 'install' folder but there may be some corruptions going on there.. I won't suggest it. Not sure if you should suggest the attachement->Attachement storage shortcut in such a case

                      Anyway, this issue is resolved, as explained, this was linked to the attachement path. Maybe I did it wrong but moving from server to another, the paths were different and as explained here not only creating nor chmod the folder and updating the dtabase table vb_setting helped me, this path information needed to be updated on the vb_datastore as well (that can't be edited in phpMyAdmin) !

                      Well, now I m struggling with another error, more memory related with a number of locks exceeded on the table vb_node but this is a whole other topic and I already contacter my server hosting company to see if they could expand the 8Mb memory size to a wider value, I will share more feedback when my test migration will be over.. I ll maybe repeat it as well.

                      Should you need more details, please let me know.

                      Thanks for reading,
                      Pierrick

                      Comment


                      • #12
                        When we refer to the AdminCP, we are referring to your 3.8.2 AdminCP which should be fully functional before you perform the upgrade itself.
                        Translations provided by Google.

                        Wayne Luke
                        The Rabid Badger - a vBulletin Cloud demonstration site.
                        vBulletin 5 API - Full / Mobile
                        Vote for your favorite feature requests and the bugs you want to see fixed.

                        Comment

                        Related Topics

                        Collapse

                        Working...
                        X