Announcement

Collapse
No announcement yet.

Insert attachment into post shows broken link/image icon

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Insert attachment into post shows broken link/image icon

    In my forum (http://forum.pfadfinder-biedermannsdorf.at), adding an attachment into the post works fine. Clicking on "Insert" shows something like

    ['ATTACH]temp_4679_1421245519959_472[/'ATTACH] (without ')

    in the editor. After posting the topic/reply, all such inserted attachments show up as "broken links/images" in the post:

    Click image for larger version

Name:	image_64927.jpg
Views:	44
Size:	74.5 KB
ID:	4231080

    A right-click, "view image" (firefox) opens the download-dialoge to the attached file.

    I tried several different file types, all with the same result (except for image-files).

    System Information:
    The forum has been upgraded (from 3x to 5.1.4) & moved to another server recently.
    PHP 5.5.17, MySQL 5.5.39-36.0-log, occurs in english/german, default and other styles, firefox 34.0, chrome Version 40.0.2214.38 beta (64-bit) [both on ubuntu trusty]
    Several Addons/mods are installed, but the problem existed before adding them (and persists).
    Last edited by Wayne Luke; Sat 14th Feb '15, 3:10pm.

  • #2
    Still got the problem. Here's a live preview: http://forum.pfadfinder-biedermannsd...bulletin-tests

    Edit: alright, as far as I understand now, that's a vBulletin bug, since the same error occurs here:



    This is very disappointing. vBulletin 5 connect apparently has a lot of unfixed bugs (such as the "maximum users online" or the green indicator on the bottom left of postbit) of basic (!) functions that I absolutely expect to be working in a 250 $ CMS…
    Attached Files
    Last edited by wurfgang; Wed 14th Jan '15, 6:36am.

    Comment


    • #3
      The issue is caused be a regression in 5.1.4 and is fixed in the upcoming 5.1.5 release.
      Translations provided by Google.

      Wayne Luke
      The Rabid Badger - a vBulletin Cloud demonstration site.
      vBulletin 5 API - Full / Mobile
      Vote for your favorite feature requests and the bugs you want to see fixed.

      Comment


      • #4
        It seems to me that the problem persists after upgrading to 5.1.5

        Comment


        • #5
          Originally posted by wurfgang View Post
          It seems to me that the problem persists after upgrading to 5.1.5
          On existing posts or new ones? If existing posts, edit the posts and save them again. You may need to upload the attachments again.
          Translations provided by Google.

          Wayne Luke
          The Rabid Badger - a vBulletin Cloud demonstration site.
          vBulletin 5 API - Full / Mobile
          Vote for your favorite feature requests and the bugs you want to see fixed.

          Comment


          • #6
            Originally posted by Wayne Luke View Post

            On existing posts or new ones?
            both
            Originally posted by Wayne Luke View Post
            If existing posts, edit the posts and save them again. You may need to upload the attachments again.
            I tried that without success.

            A test here:
            Attached Files

            Comment


            • #7
              PDF files are not images.

              Inserted via Insert Image on Menu:
              Click image for larger version

Name:	496px-Junior-Jaguar-Belize-Zoo.jpg
Views:	26
Size:	146.3 KB
ID:	4302561


              Translations provided by Google.

              Wayne Luke
              The Rabid Badger - a vBulletin Cloud demonstration site.
              vBulletin 5 API - Full / Mobile
              Vote for your favorite feature requests and the bugs you want to see fixed.

              Comment


              • #8
                Inserted via Attachment Object:
                Click image for larger version

Name:	600px-Manoel.jpg
Views:	23
Size:	92.6 KB
ID:	4302563
                Translations provided by Google.

                Wayne Luke
                The Rabid Badger - a vBulletin Cloud demonstration site.
                vBulletin 5 API - Full / Mobile
                Vote for your favorite feature requests and the bugs you want to see fixed.

                Comment


                • #9
                  Originally posted by Wayne Luke View Post
                  PDF files are not images.
                  surprise...

                  What I mean (as explained in the first post here): I click on the "Upload Attachments" icon on the top right of the editor, then "Upload Attachments" on lower left. After selecting a non-image file I click on "Insert", which inserts the "attach" tags:
                  At that point, I would expect a Link to that file (as vb 3.x did, as far as I remember) - similar to the "attached files" box at the bottom of a post with attachments (which, btw, does not appear with the "latest activity" view).
                  Attached Files

                  Comment


                  • #10
                    Don't insert non-images into a post. I'll write a JIRA to remove those controls.
                    Translations provided by Google.

                    Wayne Luke
                    The Rabid Badger - a vBulletin Cloud demonstration site.
                    vBulletin 5 API - Full / Mobile
                    Vote for your favorite feature requests and the bugs you want to see fixed.

                    Comment


                    • #11
                      I think a link to the file can be useful in the post. Especially for users using the "latest activity" view as standard, since they don't get the "attached files" list at the end of the post (in other words, they can't even know there are files attached to a post if not mentioned in the post)

                      Edit: I know I can manually insert a link, but a control button would be of much more comfort.

                      Comment


                      • #12
                        The controls in question don't allow the insertion of a link. They allow insertion of various image sizes. They should not be shown on non-image uploads. A separate JIRA will need to be created to have an "Insert Link" control on non-image attachments.
                        Translations provided by Google.

                        Wayne Luke
                        The Rabid Badger - a vBulletin Cloud demonstration site.
                        vBulletin 5 API - Full / Mobile
                        Vote for your favorite feature requests and the bugs you want to see fixed.

                        Comment


                        • #13
                          I have the same problem. I can't insert any pdf files. Apparently this problem exists even in the 5.1.6 Beta 1

                          Comment


                          • #14
                            There's a JIRA for this issue: http://tracker.vbulletin.com/browse/VBV-14318

                            Comment


                            • wurfgang
                              wurfgang commented
                              Editing a comment
                              I suggest implementing the insertion of a text link not only for PDF files but all types of non-image files that can be attached.

                          Related Topics

                          Collapse

                          Working...
                          X