Announcement

Collapse
No announcement yet.

What do you do when a vB5 page is broken and "Edit Site" does not work?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • What do you do when a vB5 page is broken and "Edit Site" does not work?

    I'm playing around with google calendar trying to add it to a widget on vB5 to try and get the size to work; I've got the calendar displayed in full on one page. But I've tried adding agenda view to another html widget on another page and now on that page whilst a widget has appeared, although not displayed correctly, Site Builder is greyed out and nothing works. So basically I'm logged in, I've got site builder switched on, I can go to the other pages and edit them; but with the broken page Site Builder says it's on but it's greyed out and I can't edit the page. So not only can I not edit it, I can't delete it because every time I hit the "Edit Page" tab it takes me off that page and on to the forum page.

    How do you fix this?

    PS: Just noticed if you hit any of the tabs... Edit Page, Navigation Bar, Channel Manager etc. it takes you to Mysite.com/forum. So I guess the page must be broken. How do you fix this?
    Last edited by jdj; Fri 5th Dec '14, 10:39am.

  • #2
    There is an issue with javascript and editing the page. If you're using a Static HTML Module, then go to Settings -> Options -> General Settings and set Disable PHP and Static HTML modules. That should let you edit the page. If not, there is a patched file here: http://www.vbulletin.com/forum/node/4211807

    The JIRA is here: http://tracker.vbulletin.com/browse/VBV-13932
    Translations provided by Google.

    Wayne Luke
    The Rabid Badger - a vBulletin Cloud demonstration site.
    vBulletin 5 API - Full / Mobile
    Vote for your favorite feature requests and the bugs you want to see fixed.

    Comment


    • #3
      Originally posted by Wayne Luke View Post
      There is an issue with javascript and editing the page. If you're using a Static HTML Module, then go to Settings -> Options -> General Settings and set Disable PHP and Static HTML modules. That should let you edit the page. If not, there is a patched file here: http://www.vbulletin.com/forum/node/4211807

      The JIRA is here: http://tracker.vbulletin.com/browse/VBV-13932
      I tried settings, options, general, settings and set disable PHP and static HTML modules to 'no'. That made no difference, site builder remains greyed-out. What do I do with the patched file?

      Comment


      • #4
        Replace the existing file with the one linked to. Clear your browser's cache to enforce getting the proper javascript.
        Translations provided by Google.

        Wayne Luke
        The Rabid Badger - a vBulletin Cloud demonstration site.
        vBulletin 5 API - Full / Mobile
        Vote for your favorite feature requests and the bugs you want to see fixed.

        Comment


        • #5
          I've just encountered a similar problem with 5.1.5. I have a page visible only to the admins on my live site which I've installed the 'what's going on' module to take a look at it. Now if I'm logged in to the other pages and have site builder turned on I can edit all the other pages. However, if I hit the tab for this new page it tells me I'm not logged in and it won't let me log in. If I navigate back to the other tabs/pages I am still logged in and can edit the pages.

          So it's a problem with this one page and it won't let me edit or delete it. It's not a static HTML module; is it the same fix?

          Comment


          • #6
            Doesn't seem to be the same issue. However it never really hurts to reupload files. They can get corrupted in any way.

            As pages have no permissions and can only be hidden by lack of disclosing the URL, what happens if you view the page as a non-admin? What URL did you give it?
            Translations provided by Google.

            Wayne Luke
            The Rabid Badger - a vBulletin Cloud demonstration site.
            vBulletin 5 API - Full / Mobile
            Vote for your favorite feature requests and the bugs you want to see fixed.

            Comment


            • #7
              How come we can't get a response of any kind for well over 48 hours to multiple phone calls with messages left dealing with a ticket you had already promised to address yesterday? But you have time to post help for free here ? Don't we even deserve a response? Why are we paying you for support? I aborted our migration and turned our forum back on since you are AWOL.

              Chris
              http://www.ironmind-forum.com/

              Comment


              • jdj
                jdj commented
                Editing a comment
                He may be posting help here but it's not for free as I'm a licensed user. The advantage of posting here is that other people can see what's posted and also have a chance to respond.

            • #8
              Originally posted by Wayne Luke View Post
              Doesn't seem to be the same issue. However it never really hurts to reupload files. They can get corrupted in any way.

              As pages have no permissions and can only be hidden by lack of disclosing the URL, what happens if you view the page as a non-admin? What URL did you give it?
              I made the navtab visible only to admins, but the page name is mysite.com/Administrators. If I navigate directly to that page as a non-admin user I can view it. If I try to log in at that page it appears to accept my login but gives me this in the browser bar http://www.mysite.com/Administrators?_=1424373936582 but shows me as not logged in. However, if I then hit one of the other tabs (any of them) they all show me as logged in.

              So I'm guessing it must be a broken page.

              Comment


              • #9
                Originally posted by Wayne Luke View Post
                There is an issue with javascript and editing the page. If you're using a Static HTML Module, then go to Settings -> Options -> General Settings and set Disable PHP and Static HTML modules. That should let you edit the page. If not, there is a patched file here: http://www.vbulletin.com/forum/node/4211807

                The JIRA is here: http://tracker.vbulletin.com/browse/VBV-13932
                So given that the problem I'm having at the moment is not with a static HTML module, will this fix work? Or do I need to do something else?

                Comment


                • #10
                  I can't say it will or will not. Like you, I think there is a problem with the page itself. We'll need a support ticket with database access to look at the specific page records as Site Builder doesn't have a lot of troubleshooting tools built into it.
                  Last edited by Wayne Luke; Thu 19th Feb '15, 12:20pm.
                  Translations provided by Google.

                  Wayne Luke
                  The Rabid Badger - a vBulletin Cloud demonstration site.
                  vBulletin 5 API - Full / Mobile
                  Vote for your favorite feature requests and the bugs you want to see fixed.

                  Comment


                  • jdj
                    jdj commented
                    Editing a comment
                    I'm still having a problem with this page. Originally when I tried to edit it it showed me as not logged in. Now when I turn site builder on it shows me as logged in but I can edit any page except that one. If I try to edit the page I get a warning just showing as "Error."

                    I've put in a support ticket.

                Related Topics

                Collapse

                • NumNum
                  Unable to go into "Edit page"
                  by NumNum
                  I'm unable to edit a recently created page. I had access to edit the page, but recently the "edit page is greyed out to edit, and doesnt respond when selecting it. In fact, when clicling on edit...
                  Mon 13th Feb '17, 5:08am
                • globe
                  Edit a new created Page
                  by globe
                  Hey folks

                  so I created a new Page with a html widget in it. Inside is a iframe which shows a map on google. Works pretty good the porblem is I didn't set the width and height correct so I...
                  Mon 1st Oct '12, 1:14pm
                • JimMM
                  Site Builder editor not working
                  by JimMM
                  I am trying to edit the page at mysite.com/ since it is a blank page at the moment
                  The editor won't let me edit that page so I created a new page at mysite.com/index and when I saved it the second...
                  Mon 7th May '18, 6:15am
                • coolv1994
                  Page Management
                  by coolv1994
                  As of now it would appear that there is no centralized management for the new vb5 pages.
                  Once you create a page you can only access via the url you set when editing the page.
                  You can't just...
                  Thu 20th Feb '14, 8:07am
                • WhiskeyOSS
                  Specific page coding
                  by WhiskeyOSS
                  Is there a way to add some code to a specifc page and it not effect the other pages in vb5

                  - - - Updated - - -

                  I just answerd my own question it can be done by adding a html...
                  Sat 29th Dec '12, 4:50pm
                Working...
                X