Announcement

Collapse
No announcement yet.

Problems changing language code

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Problems changing language code

    Hello, I'm finding myself with problems changing the language code.
    The first update I made ​​in ISO-8859-1 and I had to change the Spanish language to find no problems with special characters. Now I run into the problem that when I insert links appear with strange characters, however if I put the code in UTF-8 language appear to me well. The problem arises when switching to UTF-8 I have to adapt the Spanish language, I do this too well and I see special characters well. Now I have a new problem and I can not see the last activity or replies already posted, or use the Page Manager.
    Solution that I can apply to move to UTF-8 and not have problems?

    Thanks, greetings.

  • #2
    Really shouldn't switch encoding after content is added. You'll get issues like this.

    Some people encounter problems with garbled characters when using vBulletin with non-English languages. Here are some things you can check based on my experience troubleshooting these problems:


    1. Make sure your HTML charset is appropriate to your forum language:
    Admin CP -> Languages & Phrases -> Language Manager -> [Edit Settings] -> HTML Character Set

    2. Also try emptying the blank character stripper:
    Admin CP -> vBulletin Options -> Censorship Options -> Blank Character Stripper

    3. Also, the line wrapper can sometimes cause problems with multi-byte languages:
    Admin CP -> vBulletin Options -> Thread Display Options (showthread) -> Number of Characters Before Wrapping Text

    4. Also, the "prevent shouting" feature can cause problems for some non-English languages. Try disabling it:
    Admin CP -> vBulletin Options -> Message Posting and Editing Options -> Prevent 'SHOUTING'

    5. You might also need to set the MySQL charset in your includes/config.php file by uncommenting this line. This setting was added starting with 3.5.x:
    // $config['Mysqli']['charset'] = 'utf8';


    6. Also make sure your database collations are appropriate and consistent throughout the entire database. You need to use program like phpmyadmin to view your collations:
    http://www.phpmyadmin.net/home_page/index.php

    When you click your database name in phpmyadmin it will list all tables, their collations, as well as the collation of the database itself at the bottom. And when you click the name of a table on the left it will list the collations of individual fields within that table.
    1) To edit the collation of the database itself you need to click the database name on the left and then click "Operations" on the top.
    2) To edit the collation of an individual table you need to click its name on the left and then click "Operations" on the top.
    3) To edit the collation of an individual field within a table you need to click the table name on the left and then click the edit image (a little pencil icon) for that field.

    7. If there was a database move involved then you might need to specify the character set when making the dump. This guide shows how:
    http://wiki.refbase.net/index.php/Troubleshooting

    Note their example:
    mysqldump refbase -u root -p --opt --default-character-set=utf8 > refbase.sql
    Translations provided by Google.

    Wayne Luke
    The Rabid Badger - a vBulletin Cloud demonstration site.
    vBulletin 5 API - Full / Mobile
    Vote for your favorite feature requests and the bugs you want to see fixed.

    Comment


    • #3
      Thank you very much. I try and I comoento did it go.

      - - - Updated - - -

      WOW it worked just changing what the config.php and then putting the HTML in UTF-8 charset. In addition, I have solved the problem of saving changes in the Page Manager.

      THANKS. Now I just need to be resolved as the sitemap and you would have a truly operational version.

      Oh and the problem of excess spacing in the last activity.

      Comment

      Related Topics

      Collapse

      Working...
      X