Announcement

Collapse
No announcement yet.

Link Posting does not work

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Link Posting does not work

    i understand that it works fine on the demo edition that vB has made available. but it has not worked on my test install on my server.

    i just installed the latest beta 15. this is what happens. if i do not include a text in the message box it shows this error: http://i.imgur.com/IBdzU.png

    if i add some text and then try to post, it just hangs. a working message comes at the top in a yellow box. but nothing works. even if i wait for minutes.

    what can be the reason? i have tried a fresh install. has been same since the first public beta release. should i file this as a bug?

  • #2
    Can you show us a phpinfo page? Its possible a function we rely on to get the external site might be broken.

    Comment


    • #3
      https://thimble.webmaker.org/p/f3ag (i hope this is safe to post online! otherwise delete this post once you have gone through it!)

      Comment


      • #4
        Do you use cloudflare?

        Comment


        • #5
          i do. with a previous beta i had issues loading the admin control panel. and you had pointed out the same issue. so i paused it in the cloudflare backend. even that has not helped.

          vbulletin is able to load the details related to the external link. it hangs during the posting process. http://i.imgur.com/DFFfe.png

          i am going to test it with nameservers changed back to the original values completely bypassing cloudflare and would update if it solves the problem.

          just curious... do you plan to fix support for cloudflare optimizations? they have become very popular online and their platform really improves the site's performance. i currently have it enabled on my vb4.2 forum. have to disable some options (rocket loader primarily) but other than that it works great!

          ---

          update:

          ok. i got it to work once in a thread. second attempt fails. creation of a new thread with a link fails. here is a screenshot: http://i.imgur.com/at1wQ.png

          also realized that post editor works much smoother in firefox compared to chrome! i hope future updates would improve chrome support. post editor does not show the link field after a link is posted. need a hard refresh...
          Last edited by Sushubh; Thu 25th Oct '12, 12:35am.

          Comment


          • #6
            Can you switch to mod_php instead of mod_fcgid?
            Translations provided by Google.

            Wayne Luke
            The Rabid Badger - a vBulletin Cloud customization and demonstration site.
            vBulletin 5 Documentation - Updated every Friday. Report issues here.
            vBulletin 5 API - Full / Mobile
            I am not currently available for vB Messenger Chats.

            Comment


            • #7
              i would check with my server guy. he usually avoids anything that cpanel/whm does not recommend. would update once i get a word from him!

              Comment


              • #8
                a bit late... here is what the server guy told me:

                We can disable mod_suphp which disables running the php as cgi/fcgi if you want. Be aware that mod_suphp offers security enhancments that would not be available running php as standard php. If the box suffers performance or a hack, we are not responsible Let us know if you want to proceed.

                Comment


                • #9
                  Originally posted by Sushubh View Post
                  a bit late... here is what the server guy told me:
                  They could also loosen restrictions a bit. If it is a dedicated server or VPN, you should be able to install a domain which uses mod_php without hurting other existing installations.
                  Translations provided by Google.

                  Wayne Luke
                  The Rabid Badger - a vBulletin Cloud customization and demonstration site.
                  vBulletin 5 Documentation - Updated every Friday. Report issues here.
                  vBulletin 5 API - Full / Mobile
                  I am not currently available for vB Messenger Chats.

                  Comment


                  • #10
                    it's a dedicated server. i would check if he can enable mod_php on the forum domain. though i hope i have the option to disable this functionality(?) because i do not like it at all. thanks!

                    Comment


                    • #11
                      Well right now you're troubleshooting an issue on a beta installation of software. This may require server changes. I can't recreate the issue using my Linux server which uses mod_php or on my IIS Server which uses Fast/CGI.
                      Translations provided by Google.

                      Wayne Luke
                      The Rabid Badger - a vBulletin Cloud customization and demonstration site.
                      vBulletin 5 Documentation - Updated every Friday. Report issues here.
                      vBulletin 5 API - Full / Mobile
                      I am not currently available for vB Messenger Chats.

                      Comment


                      • #12
                        right. i would keep an eye on the new beta updates. the feature is not working on the latest one as well. thanks.

                        Comment


                        • #13
                          I take it this is with *every* link? I have had similar errors with individual links which is to do with the link redirecting.
                          MARK.B | vBULLETIN SUPPORT

                          TalkNewsUK - My vBulletin 5.5.4 Demo
                          AdminAmmo - My Cloud Demo

                          Comment


                          • #14
                            yes. i just tried linking google.com. it renders the preview correctly but posting does not work as it halts with Working... message at the top. http://imgur.com/puS3v

                            Comment

                            Related Topics

                            Collapse

                            Working...
                            X