Announcement

Collapse
No announcement yet.

Question about ini_set

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Question about ini_set

    Hello, I have an issue, the ini_set should be enabled?. At the present I'm using vb4 with ini_set disabled without problems.

    Regards.

    Sergio.
    Last edited by slossetti; Tue 16th Oct '12, 6:27pm. Reason: change title

  • #2
    The ability to use this function is a server setting in the PHP ini file. It isn't something you set in vBulletin usually.

    Sent from my iPhone using Forum Runner
    Translations provided by Google.

    Wayne Luke
    The Rabid Badger - a vBulletin Cloud customization and demonstration site.
    vBulletin 5 Documentation - Updated every Friday. Report issues here.
    vBulletin 5 API - Full / Mobile
    I am not currently available for vB Messenger Chats.

    Comment


    • #3
      The issue is that I have my forum running on a VPS and my provider doesn't enable the ini_set, because it modifies the memory limit.

      Comment


      • #4
        Shouldn't be an issue at all... what is the exact problem it is causing?
        Translations provided by Google.

        Wayne Luke
        The Rabid Badger - a vBulletin Cloud customization and demonstration site.
        vBulletin 5 Documentation - Updated every Friday. Report issues here.
        vBulletin 5 API - Full / Mobile
        I am not currently available for vB Messenger Chats.

        Comment


        • #5
          I'm getting these errors:

          [10-Oct-2012 01:58:55 UTC] PHP Fatal error: Class 'vB_Array' not found in /home/patria/public_html/vbtest/core/vb/vb.php on line 526
          line 526 --> self::$config = vB_Array::arrayReplaceRecursive($default, $config);


          [10-Oct-2012 06:25:57 UTC] PHP Fatal error: Call to a member function get() on a non-object in /home/patria/public_html/vbtest/core/vb/api/user.php on line 611
          line 611 --> $currentUserId = vB::getCurrentSession()->get('userid');


          [10-Oct-2012 13:16:47 UTC] PHP Fatal error: Call to undefined method vB_Mail::vbmail() in /home/patria/public_html/vbtest/core/includes/cron/birthday.php on line 50
          line 50 --> vB_Mail::vbmail($userinfo['email'], $maildata['subject'], $maildata['message']);

          Comment


          • #6
            Please re-upload all files in the /core directory.
            Translations provided by Google.

            Wayne Luke
            The Rabid Badger - a vBulletin Cloud customization and demonstration site.
            vBulletin 5 Documentation - Updated every Friday. Report issues here.
            vBulletin 5 API - Full / Mobile
            I am not currently available for vB Messenger Chats.

            Comment


            • #7
              I reloaded all the /core directory files and I'm getting this error:

              PHP Fatal error: Class 'vB_Array' not found in /home/patria/public_html/vbtest/core/vb/vb.php on line 526
              line 526 --> self::$config = vB_Array::arrayReplaceRecursive($default, $config);


              the error disappears when I put an @ at the beginning of the following line:

              // Set unserializer to use spl registered autoloader
              @ini_set('unserialize_callback_func', 'spl_autoload_call');


              after that, the forum works. I don't understand why.

              Comment


              • #8
                What version of PHP and MySQL are you running?

                Please don't PM or VM me for support - I only help out in the threads.
                vBulletin Manual & vBulletin 4.0 Code Documentation (API)
                Want help modifying your vbulletin forum? Head on over to vbulletin.org
                If I post CSS and you don't know where it goes, throw it into the additional.css template.

                W3Schools <- awesome site for html/css help

                Comment


                • #9
                  PHP: 5.3.16
                  MySQL: 5.5.25-cll

                  Comment


                  • #10
                    Same issues un beta 14

                    PHP Fatal error: Call to undefined method vB_dB_MYSQL_QueryDefs::fetchLanguage() in core/vb/db/query/method.php on line 157
                    line --> $this->data_loaded = $this->querydefs->$method($params, $this->db, true, $this->dbSlave);


                    PHP Fatal error: Class 'vB_Array' not found in core/vb/vb.php on line 526
                    --> self::$config = vB_Array::arrayReplaceRecursive($default, $config);

                    I still think that the errors are because I have the ini_set disabled.

                    Comment


                    • #11
                      ini_set is used to turn PHP options on or off. I don't see how it is related to the errors you're receiving.

                      In your /core/includes/config.php file what do you have for database class? Make sure mysql is in all lower case.
                      Translations provided by Google.

                      Wayne Luke
                      The Rabid Badger - a vBulletin Cloud customization and demonstration site.
                      vBulletin 5 Documentation - Updated every Friday. Report issues here.
                      vBulletin 5 API - Full / Mobile
                      I am not currently available for vB Messenger Chats.

                      Comment


                      • #12
                        mysql is right into the config fle.

                        I do not understand what's going on, but, the forums works when I comment:

                        // Set unserializer to use spl registered autoloader
                        //ini_set('unserialize_callback_func', 'spl_autoload_call');

                        I don't know why.

                        The VB4 is running well.

                        Comment


                        • #13
                          Originally posted by slossetti View Post
                          mysql is right into the config fle.

                          I do not understand what's going on, but, the forums works when I comment:

                          // Set unserializer to use spl registered autoloader
                          //ini_set('unserialize_callback_func', 'spl_autoload_call');

                          I don't know why.

                          The VB4 is running well.
                          Well when you comment that out, you're restoring default functionality. Not sure why you're pointing the unserialize() function elsewhere. I suggest not doing that for vBulletin. We have our own error handling built into the system.
                          Translations provided by Google.

                          Wayne Luke
                          The Rabid Badger - a vBulletin Cloud customization and demonstration site.
                          vBulletin 5 Documentation - Updated every Friday. Report issues here.
                          vBulletin 5 API - Full / Mobile
                          I am not currently available for vB Messenger Chats.

                          Comment


                          • #14
                            What can I do to use the forum? a fresh install for testing purpose?.

                            Everytime I try to enter into the forum, I get the errors specified above

                            Comment

                            widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                            Working...
                            X