Announcement

Collapse
No announcement yet.

Does the Maximum Number of Images setting affects all users the same regardless of usergroup settings?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Wayne Luke
    replied
    There is no way to limit users to 7 images across the entire site.

    Leave a comment:


  • Claire SR
    replied
    Hello,
    I know this has been long but did you find a way to set up the maximum number of images globally(let's say 7) used over the whole forum, keeping the maximum image per post = 5?
    I would like to limit users to use only 7 images for all forums.

    Would you anyone please advise me? Thank you in advance

    Leave a comment:


  • Replicant
    replied

    I'm still battling this. I am no longer using secondary user groups. Just to make sure it wasn't permissions related, I installed a default unmodified version of 5.1.3 patch level 1 on my test server. I created 2 registered users.

    Mark, here are the steps.

    Set the AdminCP > General Settings > Options > Message Posting and Editing Options: Maximum Images/Videos Per Post = 0

    I left the registered user group settings default which is 5.

    Then as registered user, I posted 6 images, then 12 without any restriction.

    I then changed AdminCP > General Settings > Options > Message Posting and Editing Options: Maximum Images/Videos Per Post = 10
    and left the registered user setting at 5.

    I was limited to 10 pics as per the global setting. 5 pics using the attachment option.

    So basically, when AdminCP > General Settings > Options > Message Posting and Editing Options: Maximum Images/Videos Per Post = 0
    picture posting limits are OFF globally. Users are restricted to the number of pictures attached or IMG tagged to whatever number is set here over 0. The setting in the usergroups only affected the "attached images. When the global in settings was turned off (0), IMG tags were unaffected by whatever settings are in the usergroup settings.

    Leave a comment:


  • Replicant
    replied
    I am using secondary usergroups. I'l look further into that. But this group should be unaffected by that since both registered and registered-pro have identical permissions with exception of user title.

    UPDATE:I removed the secondary usergroup and there was no change. What I did notice is, I can only post the number of "attached images" as per the limit, but with [IMG] tags is where it is umlimited. I never use picture attachments, I always use [IMG] tags as well as most of my users. The global setting worked on [IMG] tags as well as attached images. So is this normal?
    Last edited by Replicant; Fri 31 Oct '14, 12:00pm.

    Leave a comment:


  • TLMD
    replied
    Well, if you set Maximum Images/Videos Per Post = 0 (AdminCP > General Settings > Options > Message Posting and Editing Options) and Maximum Attachments per Post = 5 (AdminCP > Usergroups > Usergroup Manager), then any user of that particular group can post exactly 5 attachments (images). If you create another group and set Maximum Attachments per Post = 10, then any user of that group can post exactly 10 attachments (images).

    Are you using secondary usergroups, so a single user belongs to more than one group? What you are describing sounds like other settings are messing up the permissions.

    Leave a comment:


  • Replicant
    replied
    TMLD, Mark, thanks for the response. I tried setting max num attachments to 0 this morning on my test server and now any user can post unlimited pictures.
    this is a screenshot of the registered-pro permission that is also a member of the user group registered (the same settings)

    Leave a comment:


  • Mark.B
    replied
    What TLMD says is correct.
    If you're experiencing any other behaviour, make sure you are on the latest version of your vBulletin branch. then post back with exact steps to replicate the issue.
    We may also need a support ticket so we can look at your set up. It sounds like the permissions aren't actually set up like you think they are.

    Leave a comment:


  • TLMD
    replied
    I have tried what you want to achieve here (restrict the ammount of image attachments per post based on usergroups), but I did not run into any difficulties. Here is what I did:

    1.)
    AdminCP > General Settings > Options > Message Posting and Editing Options:
    Maximum Images/Videos Per Post = 0
    This seems to be a global setting and if you don't disable it here (by inserting 0), it messes around with other group-specific options.

    2.)
    AdminCP > Usergroups > Usergroup Manager:
    Maximum Attachments per Post: 5 (10, 15, whatever value you want)
    If you want to restrict the ammount of image attachments per post based on usergroups, create different usergroups with different Maximum Attachments per Post values.

    The above did work perfectly fine on my test installation. User 1, who is in usergroup 1 with Maximum Attachments per Post = 1 can only post one attachment (image) per post. User 2, who is in usergroup 2 with Maximum Attachments per Post = 3 can only post three attachments (images) per post.

    Leave a comment:


  • Replicant
    replied
    This must have been a really dumb question to get no response at all.

    Leave a comment:


  • Replicant
    replied
    Bump

    Leave a comment:


  • Replicant
    replied
    Bump. It's a simple question.

    Leave a comment:


  • Does the Maximum Number of Images setting affects all users the same regardless of usergroup settings?

    I have Maximum Images/Videos Per Post currently set to 4. I wanted to do a multi tier "the more you pay, the more play" with the images. 5,10,15 limit for proud, supporting,elite members respectively. When I set the Maximum Images/Videos Per Post to 15 and adjust the user groups "Maximum number of attachements per post" to 5, 10 or 15, it makes no difference and any user can post 15. Is there another setting I'm missing?

Related Topics

Collapse

Working...
X