Announcement

Collapse
No announcement yet.

Subdomain instalision problem

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Subdomain instalision problem

    Probably the problem source is .htaccess file.

    So when we want to install it on our subdomain which codes do we need to use on .htaccess file?

  • #2
    The .htaccess should take sub-domain into account. What is exactly your problem?
    Translations provided by Google.

    Wayne Luke
    The Rabid Badger - a vBulletin Cloud demonstration site.
    vBulletin 5 API - Full / Mobile
    Vote for your favorite feature requests and the bugs you want to see fixed.

    Comment


    • #3
      i wanna install it on http://deneme.timgrubu.com

      I ve been installed it but there are some problems like when you click blog it gives "internal Server Error"

      And when i try to enter admin panel: http://deneme.timgrubu.com/admincp/ there is a empty and white page...

      What i gonna write in to .htaccess file?

      Comment


      • #4
        Your paths are incorrect in your /config.php file.

        What do you have for the base_url, core_url and core_path values. My guess is core_path is incorrect.
        Translations provided by Google.

        Wayne Luke
        The Rabid Badger - a vBulletin Cloud demonstration site.
        vBulletin 5 API - Full / Mobile
        Vote for your favorite feature requests and the bugs you want to see fixed.

        Comment


        • #5
          $config['baseurl'] = 'http://deneme.timgrubu.com';


          $config['baseurl_core'] = 'http://deneme.timgrubu.com/core';


          $config['baseurl_login'] = $config['baseurl'];


          //$config['baseurl_login'] = 'https://www.yourdomain.com/folder';


          $config['core_path'] = '/home/content/81/6899581/html/deneme/core';

          Comment


          • #6
            Looks correct. Can you verify that the path is correct though? We've provided a script here: https://www.vbulletin.com/forum/show...=1#post2343889

            Should also make sure that mod_rewrite is working correctly for that directory and sub-domain.

            Finally make sure the site URL entered is http://deneme.timgrubu.com/core. This is under settings -> options -> site name / url / contact details.

            Since you can't access the AdminCP directly, you can temporarily access it via
            http://deneme.timgrubu.com/core/admincp. Not all functionality will work but you can verify the setting.
            Translations provided by Google.

            Wayne Luke
            The Rabid Badger - a vBulletin Cloud demonstration site.
            vBulletin 5 API - Full / Mobile
            Vote for your favorite feature requests and the bugs you want to see fixed.

            Comment


            • #7
              I could enter by using this http://deneme.timgrubu.com/core/admincp to admin panel

              Its true. As you say. what i gonna change on panel?

              I cant understand it why is it gives error? When i click on blog or ext?

              Comment


              • #8
                Originally posted by Wayne Luke View Post
                Finally make sure the site URL entered is http://deneme.timgrubu.com/core. This is under settings -> options -> site name / url / contact details.
                ...
                Translations provided by Google.

                Wayne Luke
                The Rabid Badger - a vBulletin Cloud demonstration site.
                vBulletin 5 API - Full / Mobile
                Vote for your favorite feature requests and the bugs you want to see fixed.

                Comment


                • #9
                  settings -> options -> site name / url / contact details

                  Make sure the site URL entered is http://deneme.timgrubu.com/core

                  Edit: ninja'd!

                  vBulletin QA - vBulletin Support French - Lead Project Tools developer

                  Next release? Soon(tm)

                  Comment


                  • #10
                    Originally posted by Wayne Luke View Post
                    ...
                    As i told you its true. It is http://deneme.timgrubu.com/core

                    But still problem is going on..

                    Comment


                    • #11
                      mod_rewrite isn't configured correctly on your server.
                      Translations provided by Google.

                      Wayne Luke
                      The Rabid Badger - a vBulletin Cloud demonstration site.
                      vBulletin 5 API - Full / Mobile
                      Vote for your favorite feature requests and the bugs you want to see fixed.

                      Comment


                      • #12
                        So i was saying that. How can i configure it correctly?
                        What is the correct?

                        Its:

                        <IfModule mod_rewrite.c>
                        RewriteEngine On
                        RewriteCond %{REQUEST_FILENAME} !-f
                        RewriteCond %{REQUEST_FILENAME} !-d
                        RewriteRule ^(.*)$ index.php?routestring=$1 [L,QSA]


                        #needed because admincp is an actual directory.
                        RewriteRule ^(deneme/admincp/)$ index.php?routestring=$1 [L,QSA]
                        </IfModule>

                        Comment


                        • #13
                          That is correct. It isn't configured properly at the server level.

                          vBulletin is presenting the URLs correctly: http://deneme.timgrubu.com/blogs

                          Your server isn't passing them through correctly according to the rewrite rules. This is why you're getting 500 server errors and blank pages.
                          Our .htaccess doesn't even care about the domain name or whether you're using a sub-domain or not.
                          Translations provided by Google.

                          Wayne Luke
                          The Rabid Badger - a vBulletin Cloud demonstration site.
                          vBulletin 5 API - Full / Mobile
                          Vote for your favorite feature requests and the bugs you want to see fixed.

                          Comment


                          • #14
                            What i gonna do now then?

                            Comment


                            • #15
                              Talk to your hosting provider? They should be able to help make sure things are configured correctly. At the very least, they can tell you what is causing the 500 server error as it should be logged.
                              Translations provided by Google.

                              Wayne Luke
                              The Rabid Badger - a vBulletin Cloud demonstration site.
                              vBulletin 5 API - Full / Mobile
                              Vote for your favorite feature requests and the bugs you want to see fixed.

                              Comment

                              Related Topics

                              Collapse

                              Working...
                              X