Announcement

Collapse
No announcement yet.

Unable to unban a user

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Joe D.
    replied
    The best way to report a bug is directly in the bug tracker- a direct link for VB5 bugs is here: http://tracker.vbulletin.com/secure/...91&issuetype=1

    All you need to worry about is the summary and description, you don't need to touch any other settings you're not sure of.

    In the description please give instructions on how to replicate the problem, that is the easiest way for someone to confirm the bug.

    Leave a comment:


  • manixless
    replied
    Well, no problem Joe. We can take this thead as solved. However, there are a few vbulletin bugs that I'd want to report. Tahnk you guys for support.

    Leave a comment:


  • Joe D.
    replied
    Originally posted by manixless View Post
    Apologies for my bad.

    When I installed the forum I create a custom usergroup name "Ninja" in order to learn how to edit it and how to play with promotions based in post count. For some reason, in the creation phase probably I setted "This Usergroup is not a Banned' Group" to NO. So, rolled-back it fix the problem.

    PS: I think that using "This Usergroup is not a Banned Group" as a negative expression is so confuse, do you?
    It is confusing, but the reason it is so is because users can have multiple usergroups- and a Yes in one usergroup always overrides a No in other usergroups. So for an example a user only has to have one "Yes" say in a VIP group to have a signature... even if they are in 3 other groups that say no signatures, having 1 that says yes, allows them to have a signature.

    Therefore the option was phrased do a yes would override a no like with all other usergroup options.

    Leave a comment:


  • manixless
    replied
    Originally posted by Joe D. View Post
    What I need to know is what usergroup did you change it in that fixed the problem?
    Apologies for my bad.

    When I installed the forum I create a custom usergroup name "Ninja" in order to learn how to edit it and how to play with promotions based in post count. For some reason, in the creation phase probably I setted "This Usergroup is not a Banned' Group" to NO. So, rolled-back it fix the problem.

    PS: I think that using "This Usergroup is not a Banned Group" as a negative expression is so confuse, do you?

    Leave a comment:


  • Joe D.
    replied
    Hello-- the forumhome link is a known bug, so lets table that for now.

    A few posts up you posted "Update 2 - Changing this value in other usergroups fixed the problem of banned user. Thank you much. "

    What I need to know is what usergroup did you change it in that fixed the problem?

    Leave a comment:


  • manixless
    replied
    Joe,
    I am managing the banner users with the native vBulletin's ban usergroup (ID = 8). No special settings, nothing. Before open this thread, I installed a fresh vbulletin 5.1.2 instance from scratch, because of this, I can not provide you a specific way to reproduce this broken link. Also, after review the moderator control panel I found anotther broken link. Please, take a look to the image.
    Just to let you know again, there are not problems with usersgorups, but broken links.

    Thank you much for your pacience


    Leave a comment:


  • Joe D.
    replied
    Originally posted by manixless View Post
    Last thing is, why does "view banner user" link is broken? The url of this item in my admin panel is http://www.my-site.com//banning.php?do=banuser&, should be http://www.mys-site.com/admincp/banning.php?do=banuser&, right? The rest of admincp's items works fine.
    It's possible the banned user list is only showing users from the official banned usergroup rather than custom usergroups. This would still be a bug but not as big a bug if the system wasn't working at all.

    Can you tell me the usergroupid of the usergroup you had marked to "No" (the number) and if there were any special settings I can try to reproduce the issue with?

    Leave a comment:


  • manixless
    replied
    Last thing is, why does "view banner user" link is broken? The url of this item in my admin panel is http://www.my-site.com//banning.php?do=banuser&, should be http://www.mys-site.com/admincp/banning.php?do=banuser&, right? The rest of admincp's items works fine.

    Leave a comment:


  • manixless
    replied
    Originally posted by Joe D. View Post
    Go to Usergroup Manager. edit the Registered Users group- Make sure This Usergroup is not a 'Banned' Group is set to YES. If it;s No, change it to Yes.
    Hello Joe, the option "This Usergroup is not a 'Banned' Group'" is already setted as YES.

    - Update: I have another ones usergroups who have this option setted as NO. I will change this value to YES and then I will notify you the result about this.

    - Update 2: Changing this value in other usergroups fixed the problem of banned user. Thank you much.
    Last edited by manixless; Mon 11 Aug '14, 11:26am.

    Leave a comment:


  • Joe D.
    replied
    Go to Usergroup Manager. edit the Registered Users group- Make sure This Usergroup is not a 'Banned' Group is set to YES. If it;s No, change it to Yes.

    Leave a comment:


  • manixless
    replied
    Hello Mark,

    After follow your advice I found a strange error. When I try to list all banned user as your method the result is equals to the image. It says: "Showing Users 1 to 25 of 1193". But the table below where the users should be listed is empty.

    Leave a comment:


  • Mark.B
    replied
    Go to the usergroup manager, select the banned usergroup, and "View primary users" - if the user is listed there, you can simply change his usergroup back to a normal one.

    Leave a comment:


  • manixless
    started a topic Unable to unban a user

    Unable to unban a user

    Today a user email me saying that everytime he log in into the my forum a message appears let him know that he is banned permanently. So, my first action is to list all banner users from admincp with the option "View banned users". Please see the image.

    However, if I click this option a error message apperars stating that the url is invalid. I can confirm it. In effect, the URL is invalid because if I hover the cursor over the item "View banned users" the web browser show me the url where I will be redirected, I mean, http://my-site.com//banning.php?do=modify&. (Please see the imagen again, at left-botton side).

    Well, after search for another solution to unban the user, I went to the database in order to check for banned users doing:
    select * from userban;

    The query returns zero results. So, now from here I do not know what anything else do. Thank you.


Related Topics

Collapse

Working...
X