Announcement

Collapse
No announcement yet.

Newly created styles do not show up in the Admin CP

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Newly created styles do not show up in the Admin CP

    First let me start out with my relevant info as you advise:
    • vBulletin Version: 5.1.2
    • PHP Version: 5.3.28
    • MySQL Version: 5.6.17
    • Any Addons installed: no
    • Does the issue occur in a default style? Not sure the right way to answer this...
    • Does the issue occur using the English language provided? Yes
    • Error message on the screen: No error messages
    • Browser and Browser version used: Google Chrome: 35.0.1916.153 m
    • A list of steps that can be used to recreate the issue: Not sure how to recreate...
    To give some more background, this is a new setup. I initially installed the latest 4.x release so that I could import forum users from phpBB. Note that during the import (with Impex), I imported everything that could be imported in case that is relevant. I then upgraded from the latest 4.x release to 5.1.2.

    The current issue I see is that any styles I try to either import or add do not show up in the admin CP, even though they definitely exist in the database.

    These are the only styles that show up now, and they are the ones that have always been there since I started to work with the styles in 5.1.2: http://i.imgur.com/pkRZDvk.png

    As you can see though, when I run "Rebuild Style Information", the styles I have tried adding (through the style manager) or importing (through Upload Styles) show up: http://i.imgur.com/E26ROrF.png

    The other thing that is curious is that in the Style manager screen in the first picture, only the style "Default VB5 Style" gives me the full list of options for styles as seen here: http://i.imgur.com/BKsOv5V.png

    All the others give me a smaller menu like this: http://i.imgur.com/UdYddPN.png

    Another important thing to note if it helps is that there also used to be a style along the lines of "VB4 style" which said (Incompatible) or something like that in the name, which I deleted.

    I am wondering if somehow the other styles aren't typically there and are somehow from VB4 or phpBB and are causing trouble. The reason I need to create a style is that we have been making stylevar changes to "Default VB5 Style", but I would like to move all those changes out to a new style where we can even start adding a few minor template changes and be sure that updates will not mess up the forum. Also as can often be the case maybe this is a sign of some deeper issue that may cause trouble in the future.

    Any help would be greatly appreciated, Thanks!!

  • #2
    When you create the new styles, are you creating them so that they have no parent?

    Styles that are part of the built in new "Themes" facility, will have the cutr down menus in 5.1.2.
    MARK.B | vBULLETIN SUPPORT

    TalkNewsUK - My vBulletin 5.5.6 Demo
    AdminAmmo - My Cloud Demo

    Comment


    • #3
      Originally posted by Mark.B View Post
      When you create the new styles, are you creating them so that they have no parent?

      Styles that are part of the built in new "Themes" facility, will have the cutr down menus in 5.1.2.

      I have tried creating both with and without a parent, in this pic: http://i.imgur.com/E26ROrF.png you can see that "Test Style" and "Another Test" both have parents, while all the ones at the bottom do not have a parent.

      Maybe my problem is related to this new "Themes" functionality? From what I gather in your post what I really want is a "Style" and not a "Theme" (as I want to be able to customize both the templates and the stylevars).

      Comment


      • #4
        Hey, any other ideas on this? It is still a major issue for me.

        Comment


        • #5
          I'd suggest adding this to the other ticket I asked you to create and we can figure out what is going on.

          Comment

          widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
          Working...
          X