Announcement

Collapse
No announcement yet.

Noumerous problems after upgrading to vBulletin 5.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Guido64
    replied
    He is the best. Without his help my brain would've exploded

    Leave a comment:


  • Mark.B
    replied
    Zachery "fixes all the things" you see...

    Leave a comment:


  • Guido64
    replied
    Together with posting here i sended a ticket to the support team of vb. Zachery helped me yet again. The problem was the database type was set to mysql in my vb config.php after i changed it to mysqli everything worked. I have now vb5.1.3 running on php5.6.0 great ..!

    Leave a comment:


  • Guido64
    replied
    Well i checked the apache error file, i checked the syslog.log, i checked php log files there is nothing related to this problem in those files weird enough.
    Wen i lower the php version from php 5.4 to php 5.3 it still works. Only wen i go up to php5.5 and php5.6 is gives this critical error page.

    I use a clean new server i setup for the purpose of upgrading and testing VB with php5.6 since our hosting provider is going to upgrade their servers soon and the current forum (phpbb2) isn't working anymore. Its weird i can't find nothing related to this in the logs. The server is setup and configured using the howtoforge.org Debian Wheezy Perfect Server tutorial with ispconfig3 and also did the additional php versions tutorial. All this is running in a OpenVZ virtual system. Maybe this is important to know.

    Leave a comment:


  • Mark.B
    replied
    We'd need to see the actual error from the server's error logs.

    Leave a comment:


  • Guido64
    replied
    I too have a local test server were I can switch between different php versions (5.3.29, 5.4.33, 5.5.17, 5.6.0). I installed vb4.2.2 with PHP set to version 5.4.33. Then I imported my phpbb forum into this VB4.2.2. My plan was to upgrade VB after that to VB5.1.3 and the next step would be to switch to PHP5.6.0. After I upgraded VB to 5.1.3 I switched the PHP version to 5.6.0 and also tested with php 5.5.17.

    I too receive this critical error page when i switch to a higher php version.

    Critical Error
    We are currently experiencing technical difficulties. Please check back in 24 hours.

    What could be the problem?
    Last edited by Guido64; Fri 17 Oct '14, 5:37pm.

    Leave a comment:


  • Mark.B
    replied
    Originally posted by Probeus View Post
    Users are still always online in the user-profile :/
    This might be a bug, I can replicate it on here.

    I'll do some testing and log it later on.

    Leave a comment:


  • Probeus
    replied
    Users are still always online in the user-profile :/

    Leave a comment:


  • Probeus
    replied
    Ok, so now its updated, but all issues are still present :/
    Edit: Seems cookies are working again.
    Last edited by Probeus; Wed 16 Jul '14, 3:54am.

    Leave a comment:


  • Probeus
    replied
    Originally posted by Mark.B View Post
    Changing php versions should not alter any MySQL passwords. You should speak to your host about this.
    Google " mysqlnd cannot connect to MySQL 4.1+ using old authentication." and you will see my problem. It's not that its alters the password, but it is unable to read the password since it is stored in a old way.

    Leave a comment:


  • Mark.B
    replied
    Changing php versions should not alter any MySQL passwords. You should speak to your host about this.

    Leave a comment:


  • Probeus
    replied
    I can switch the PHP version myself, and when i switch it to 5.4 i get "Critical error. Please visit back in 24 hours"

    Updates:
    - It seems to fix itself somehow. Will check if issues are fixed.
    - Or not... Seems that i need to update my MySQL passwords for 5.4 to work. Will get back as soon as it works again
    Last edited by Probeus; Wed 16 Jul '14, 12:48am.

    Leave a comment:


  • Mark.B
    replied
    Your php version is too low. Ask your hosts to upgrade to either 5.3.28, or the latest version 5.4.

    Leave a comment:


  • Probeus
    started a topic Noumerous problems after upgrading to vBulletin 5.

    Noumerous problems after upgrading to vBulletin 5.

    Code:
    vBulletin 5.1.2
    PHP Version 5.3.0
    MySQL Version 5.5.34-log
    No 3. party products installed.
    All issues occur all of the time
    The only language installed is the default English
    No error-messages visible
    Issues occur in multiple browsers, OS and versions.
    Issue #1: Cookies does not seem to work
    The Remember me function does not seem to work. I am beeing logged out after AFKing over 15 mins.
    [Updated to PHP 5.4 solved this]

    Issue #2: All users are always online
    The Whos online list on the frontpage seems to work. But if you go into a thread, all users in the thread are marked as online. The same at all user profiles.

    Issue #3: Users in the Forumuser group have trouble posting.
    The default forummember group can post in a thread, but when they are posting a new thread they are either unapproved or get an error message telling them that the captcha was not filled out. No Captcha image was shown to them.
    [Disabling spamchecker solved this. However i feel this is not a good solution]

    Issue #4: Lots of broken links in the ACP
    On the dashboard there are stats and links to Topics to Moderate, Posts to moderate. When clicking theese i get an error message telling me site is not found:
    Invalid Page URL. If this is an error and the page should exist, please contact the system administrator and tell them how you got this message.
    Links:
    Code:
    http://www.domain.no/forums/modcp/moderate.php?do=posts
    http://www.domain.no/forums/modcp/moderate.php?do=posts#postlist
    Last edited by Probeus; Wed 16 Jul '14, 5:21am.

Related Topics

Collapse

Working...
X