Announcement

Collapse
No announcement yet.

DB error mails error 1367

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • DB error mails error 1367

    Hi,

    I am getting mails with the following form my vbulletin forums. Can you please let me know why this is coming and what can be done to resolve the issue. The forum is opening fine till now.

    Database error in vBulletin 5.0.5:

    Invalid SQL:
    SELECT * FROM session
    WHERE `sessionhash` = 723649729538e2723926177489193895 AND `lastactivity` > 1405196249 AND `idhash` = '45a9b6447f6881cc327f4f87263635bb';

    MySQL Error : Illegal double '723649729538e2723926177489193895' value found during parsing
    Error Number : 1367

    Thanks for your support!
    Sowmya


  • #2
    Run this query:

    truncate table session;

    Do you continue to get the errors? If so you should upgrade to 5.1.2 so you have all the latest fixes and features. There is no real benefit to be running an older version.
    Translations provided by Google.

    Wayne Luke
    The Rabid Badger - a vBulletin Cloud demonstration site.
    vBulletin 5 API

    Comment


    • #3
      The issue was fixed in 5.1.0: http://tracker.vbulletin.com/browse/VBV-11771

      Comment


      • #4
        Hi Wayne and Zachery,

        Thanks for your replies!

        I will try running the query and see how it goes.

        http://tracker.vbulletin.com/browse/VBV-11771 is not opening for me. It shows webpage is not available.

        Regarding vbulletin upgrade, I have not done any comlplete upgrade till now. Hope http://www.vbulletin.com/docs/html/upgrade is the URL for complete reference for upgrading to latest version. Please guide me if I am wrong. As you would have seen from my question the version which is currently running is 5.0.5.

        Thanks!
        Sowmya

        Comment


        • #5
          You should upgrade to 5.1.2, which should fix the issue.
          MARK.B | vBULLETIN SUPPORT

          TalkNewsUK - My vBulletin 5.6.4 Demo
          AdminAmmo - My Cloud Demo

          Comment


          • #6
            Hi Mark,

            Thanks for your reply. But as you would have seen from my comment

            ---- Regarding vbulletin upgrade, I have not done any complete upgrade till now. Hope http://www.vbulletin.com/docs/html/upgrade is the URL for complete reference for upgrading to latest version. Please guide me if I am wrong. As you would have seen from my question the version which is currently running is 5.0.5.

            -----Also we got one more similar DB related error which I am not sure whether will be resolved with the upgrade or any hotfix is available for it.

            > Invalid SQL:
            > INSERT INTO closure (parent, child, depth, publishdate)
            > SELECT parent.parent, node.nodeid, parent.depth + 1, node.publishdate
            > FROM node AS node
            > INNER JOIN closure AS parent ON parent.child = node.parentid
            > WHERE node.nodeid = 167
            > /**addClosure**/;
            >
            > MySQL Error : Duplicate entry '2-167' for key 'closure_uniq'
            > Error Number : 1062

            Thanks!
            Sowmya



            Comment


            • #7
              Hi,

              Please help me with my above comment #6.

              Thanks!
              Sowmya

              Comment


              • #8
                Hello

                In the first instance, please upgrade to 5.1.2 and see if any issues persist. The instructions you linked to are correct, make sure you have version 5.1.2 selected at the top.
                MARK.B | vBULLETIN SUPPORT

                TalkNewsUK - My vBulletin 5.6.4 Demo
                AdminAmmo - My Cloud Demo

                Comment

                Related Topics

                Collapse

                Working...
                X