Announcement

Collapse
No announcement yet.

What Channel Permissions are Required for the Search Module?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • What Channel Permissions are Required for the Search Module?

    Hi,

    I am running 5.1.1.

    I have inserted a Search Module using the Site Builder and enabled search for several forums.
    However some posts for some forums are not showing up for a user group.

    Q1. May I know what Channel Permissions are needed for new posts to surface out in the Search Module?

    I then enabled the "Join Channel" permission for the user group. I found that a new post in the Channel
    is reflected in the Search Module. But older posts that are not showing even though they are still within
    the search criteria.

    Q2. Is caching or search indexing at work here causing the issue?

    Thanks!

    regards,
    sl



  • #2
    1. They need to be able to search, and they need to be able to view titles/content.
    2. There is a small cache on most modules

    Comment


    • #3
      Hi,

      Thanks for the reply. I just checked and yes, the User Group has permissions to Search. The Channel Permissions also allow the user group to view the topics and content. I also logged in as a user of that group and was able to view the post that is missing from the Search Module results.

      May I know is it possible to clear the cache in the module?
      I have already done AdminCP->Maintenance->Clear System Cache but the search results are the same.

      Thanks!

      regards,
      sl


      Comment


      • #4
        Hi,

        I just tried to use the Advanced Search with the same search criteria and the post did surface out in the advanced search.

        Does the Search Module that can be inserted by Site Builder use the same code as the Advanced Search page?

        The new post in question belonged to a topic that was created quite a while back (Topic was created in 2009 and post was several hours ago).
        Could it be that the Search Module has some limits on when the topic was created?

        regards,
        sl

        Comment


        • sauloon
          sauloon commented
          Editing a comment
          Please ignore this observation. I see other new posts in the forum that are not surfacing. These posts belong to topics that are newly created.

      • #5
        The code between searches is the same. However your parameters may not be. You're not providing enough information for us to provide an answer satisfactorily. You'll need to open a support ticket so someone can look at your settings.
        Translations provided by Google.

        Wayne Luke
        The Rabid Badger - a vBulletin Cloud demonstration site.
        vBulletin 5 API - Full / Mobile
        Vote for your favorite feature requests and the bugs you want to see fixed.

        Comment


        • #6
          Can we get a screen shot of your settings in the search module.

          Please don't PM or VM me for support - I only help out in the threads.
          vBulletin Manual & vBulletin 4.0 Code Documentation (API)
          Want help modifying your vbulletin forum? Head on over to vbulletin.org
          If I post CSS and you don't know where it goes, throw it into the additional.css template.

          W3Schools <- awesome site for html/css help

          Comment

          widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
          Working...
          X