Announcement

Collapse
No announcement yet.

Search result issues

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Search result issues

    Hi there,

    I'm having a big issue with the search result using the latest vBulletin version 5.1.1.

    Case #1:

    I followed the steps in http://www.vbulletin.com/forum/blogs...etin-5-connect to create my latest topics module. But the result of this search module doesn't show the result topics in the proper sort order.

    I want my module to search only the forum (which is channel ID 2) and sort the display topics by "Date - last update" in "descending" order.

    This is my search JSON:
    Code:
    searchJSON={"channel":["2"],"sort":{"lastcontent":"desc"},"view":"topic","exclude_type":["vBForum_PrivateMessage"]}
    But the result topics don't display in the proper sorting order, here is a screenshot of the end result of my forum (the ones that don't sort properly are outlined in red):




    I looked at the vbulletin.com/forum, even this forum's "Today's Posts" link located in the sub-navigation bar is not showing the result in correct sorting order:



    To me, it seems like the sorting of descending order by "Date - last update" is broken. I've already rebuilt my site search index couple times and this issue still exists. Is there a way to fix this?

    Case #2:

    In the search JSON, the attribute "unread_only" doesn't seem to work correctly.

    In vbulletin.com/forum, there's a "New Topics" link in the sub-navigation bar that shows any unread topics since the last visit and the result should be sorted by "Date - last update" in descending order.

    This is the search JSON in the link:
    Code:
    searchJSON={"date":"lastVisit","view":"topic","unread_only":1,"sort":{"lastcontent":"desc"},"exclude_type":["vBForum_PrivateMessage"]}
    But the end result always shows the topics that are already been read (highlighted in red):



    My site has the same issue like the current vbulletin.com/forum as well. I only want to show unread topics in the "New Topics" link. Is there a way to fix this issue?

    This is information about my site...
    vBulletin Version: 5.1.1
    PHP Version: 5.3.28
    MySQL Version: 5.5.32-31.0-log
    Any Addons installed: No
    Does the issue occur in a default style? Yes
    Does the issue occur using the English language provided? Yes
    Error message on the screen: No error message, but screenshots of the issues are attached to this post.
    Browser and Browser version used: Chrome v35.0.1916.153, FireFox v30.0, IE 11.0.9600.17041


    These search result issues are quite critical and my site users are complaining. I'd greatly appreciate if anyone can help or give me some insights on how to fix these issues.
    Thanks!
    Attached Files
    Last edited by antoniom; Tue 17 Jun '14, 11:39am. Reason: fixed images

  • #2
    Looks like images are not displaying in the post, fixed them using image tags.

    Anyone know a fix for these issues?

    Comment


    • #3
      Both are issues that are being worked on.

      Sorting: http://tracker.vbulletin.com/browse/VBV-12581

      Images: http://tracker.vbulletin.com/browse/VBV-12944
      Translations provided by Google.

      Wayne Luke
      The Rabid Badger - a vBulletin Cloud demonstration site.
      vBulletin 5 API

      Comment


      • #4
        Thank you for the info.

        Comment


        • #5
          The same issue is actual for 5.1.10
          I'm an Ukrainian developer, so I'm sorry for my bad English

          Comment


          • #6
            The bug report is still open:
            http://tracker.vbulletin.com/browse/VBV-12581
            MARK.B | vBULLETIN SUPPORT

            TalkNewsUK - My vBulletin 5.6.4 Demo
            AdminAmmo - My Cloud Demo

            Comment

            Related Topics

            Collapse

            Working...
            X