Announcement

Collapse
No announcement yet.

Sitemap generation not working

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • zeman
    replied
    I had the same problem. When I checked the URL target, it had my old domain name. I changed it to my new one, changed Sitemap folder permission to 777 and it worked.

    Leave a comment:

  • Graham Walters
    Senior Member

  • Graham Walters
    replied
    Originally posted by Lynne View Post
    The file path should only be to a directory, not a file. So, what exactly do you have for AdminCP > Settings > Options > XML Sitemap? And, as Wayne stated, if you have something like "./store_sitemap" (the default), then this is a directory located in the /core directory, not in your root.
    It's that "." before the / that gets me every time

    Leave a comment:

  • Lynne
    Former vBulletin Support

  • Lynne
    replied
    The file path should only be to a directory, not a file. So, what exactly do you have for AdminCP > Settings > Options > XML Sitemap? And, as Wayne stated, if you have something like "./store_sitemap" (the default), then this is a directory located in the /core directory, not in your root.

    Leave a comment:

  • Graham Walters
    Senior Member

  • Graham Walters
    replied
    Originally posted by Lynne View Post
    I am not getting this error on my 5.1.1 test site. If you go to AdminCP > Settings > Options > XML Sitemap, what do you have for the Sitemap File Path? And can you save that options page without error?
    I've done that, the file path is store_sitemap/sitemap.xml if I try anything else it gives me an error on the page

    Leave a comment:

  • Wayne Luke
    vBulletin Technical Support Lead

  • Wayne Luke
    replied
    Originally posted by Graham Walters View Post

    I'm still getting the same error messages, not sure what you mean by "owned by the Webserver User and Group"

    If you do a directory listing from the command line it will tell you who owns a folder and file. You would have to use chown and chgroup to get the directory into the webserver user's possession. This is increasingly required on shared hosting systems for security. If you don't know how to make these changes or you do not have access to the command line of the machine, you will need to ask your hosting providers to make the changes for you.

    Leave a comment:

  • fishingforum
    Member

  • fishingforum
    replied
    dito

    Leave a comment:

  • Graham Walters
    Senior Member

  • Graham Walters
    replied
    Originally posted by Wayne Luke View Post
    The default path specified in the AdminCP is relative to the /core directory. So without changing that value to an absolute path you need to make sure that /core/store_sitemap is chmod 0777 and is owned by the Webserver User and Group.
    I'm still getting the same error messages, not sure what you mean by "owned by the Webserver User and Group"

    Leave a comment:

  • Wayne Luke
    vBulletin Technical Support Lead

  • Wayne Luke
    replied
    The default path specified in the AdminCP is relative to the /core directory. So without changing that value to an absolute path you need to make sure that /core/store_sitemap is chmod 0777 and is owned by the Webserver User and Group.

    Leave a comment:

  • Lynne
    Former vBulletin Support

  • Lynne
    replied
    I am not getting this error on my 5.1.1 test site. If you go to AdminCP > Settings > Options > XML Sitemap, what do you have for the Sitemap File Path? And can you save that options page without error?

    Leave a comment:

  • fishingforum
    Member

  • fishingforum
    replied
    same issue here please assist thanks

    Leave a comment:

  • Graham Walters
    Senior Member

  • Graham Walters
    started a topic Sitemap generation not working

    Sitemap generation not working

    I'm running 5.1.1 and I am getting error messages regarding the automatic sitemap generation :

    "The directory the sitemap files are to be written into is not writeable. Please change the permissions on the path to be writeable by the web server or enter a different path in the sitemap options."

    "Creation of one of the sitemap files failed. Please check the permissions on the sitemap directory.

    Once you have done this, remove the sitemap session and try again.
    "

    File permissions are set to 777

Related Topics

Collapse

Working...
X