Announcement

Collapse
No announcement yet.

RSS Not Working After Upgrade

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    With what has been said, it really is impossible to tell what the issue is. We'd need to actually be able to take a look at your files and admincp. In order to get that information, I'd suggest you put in a ticket with a link to this thread along with admincp login information and ftp information.

    Please don't PM or VM me for support - I only help out in the threads.
    vBulletin Manual & vBulletin 4.0 Code Documentation (API)
    Want help modifying your vbulletin forum? Head on over to vbulletin.org
    If I post CSS and you don't know where it goes, throw it into the additional.css template.

    W3Schools <- awesome site for html/css help

    Comment


    • #17
      Ok it seems I have the same issue. And for what I see, it that you are also on a IIS server.

      I suspect there is something wrong with the rewrite of the URL. My issues are about the same.

      I've done a trace and IIS rewrites it to:

      myforum.com/index.php/external?type=rss2&nodeid=25

      That doesn't seem to work.

      While this one does work:

      myforum.com/index.php/search

      When I try, for example and testing, this on this vbulletin forum, these work:

      vbulletin.com/forum//index.php/search
      vbulletin.com/forum//index.php/articles



      But also here on this Vbulletin forum vbulletin.com/forum/index.php/external does not work:

      http://www.vbulletin.com/forum/index...rss2&nodeid=28

      It gives the exact same error message I'm having on my IIS server.

      So it seems that /external on IIS rewrites to index.php/external and that is incorrect.

      Under water this url does not seem to fire up index.php:

      http://www.vbulletin.com/forum/exter...rss2&nodeid=28

      The question is what do we need to change in the web.config file to fix the url rewrite bug on IIS?


      Last edited by User0223423; Thu 7th Aug '14, 8:22am.

      Comment


      • #18
        Did some more testing, while looking at the htaccess file and this should be the correct rewrite:

        http://www.glassbuzz.com/index.php?routestring=external

        And that does work for your site

        Also this works:

        http://www.vbulletin.com/forum/index...tring=external

        I think this needs to be changed:

        Code:
        <?xml version="1.0" encoding="UTF-8"?>
        <!-- This file is to support redirection in IIS.
        This file is harmless if you are running under Apache -->
        <configuration>
            <system.webServer>
                <rewrite>
                    <rules>
                        <rule name="Css" stopProcessing="true">
                            <match url="^css.php$" ignoreCase="false" />
                            <action type="Rewrite" url="core/css.php" />
                        </rule>
                        <rule name="Installer" stopProcessing="true">
                            <match url="^install/" ignoreCase="true" />
                            <action type="Rewrite" url="core/install/" />
                        </rule>
                        <rule name="Main Redirect" stopProcessing="true">
                            <match url="^(.*)$" ignoreCase="false" />
                            <conditions logicalGrouping="MatchAll">
                                <add input="{REQUEST_FILENAME}" matchType="IsFile" ignoreCase="false" negate="true" />
                                <add input="{REQUEST_FILENAME}" matchType="IsDirectory" ignoreCase="false" negate="true" />
                            </conditions>
                            <action type="Rewrite" url="index.php/{R:1}" />
                        </rule>
                        <rule name="Admincp" stopProcessing="true">
                            <match url="^(admincp/)$" ignoreCase="false" />
                            <action type="Rewrite" url="index.php/{R:1}" />
                        </rule>
                    </rules>
                </rewrite>
            </system.webServer>
        </configuration>
        To:

        Code:
        <?xml version="1.0" encoding="UTF-8"?>
        <!-- This file is to support redirection in IIS.
        This file is harmless if you are running under Apache -->
        <configuration>
        <system.webServer>
        <rewrite>
        <rules>
        <rule name="Css" stopProcessing="true">
        <match url="^css.php$" ignoreCase="false" />
        <action type="Rewrite" url="core/css.php" />
        </rule>
        <rule name="Installer" stopProcessing="true">
        <match url="^install/" ignoreCase="true" />
        <action type="Rewrite" url="core/install/" />
        </rule>
        <rule name="Main Redirect" stopProcessing="true">
        <match url="^(.*)$" ignoreCase="false" />
        <conditions logicalGrouping="MatchAll">
        <add input="{REQUEST_FILENAME}" matchType="IsFile" ignoreCase="false" negate="true" />
        <add input="{REQUEST_FILENAME}" matchType="IsDirectory" ignoreCase="false" negate="true" />
        </conditions>
        <action type="Rewrite" url="index.php?routestring={R:1}" />
        </rule>
        <rule name="Admincp" stopProcessing="true">
        <match url="^(admincp/)$" ignoreCase="false" />
        <action type="Rewrite" url="index.php/{R:1}" />
        </rule>
        </rules>
        </rewrite>
        </system.webServer>
        </configuration>
        I've tested this and this seems to solve the issue.

        No thanks VBulletin.

        Comment


        • #19
          The index.php will not be in the URL on a properly configured server. What are you using to process rewrites? We currently only support the URL Rewrite Module (version 2) from Microsoft. Plus you must be using IIS 7.5 or higher.
          Translations provided by Google.

          Wayne Luke
          The Rabid Badger - a vBulletin Cloud demonstration site.
          vBulletin 5 API - Full / Mobile
          Vote for your favorite feature requests and the bugs you want to see fixed.

          Comment


          • #20
            I know it is not in the URL, as it has been rewritten, but under water it refers to index.php.

            I'm using the URL rewrite from Microsoft. And the above problem was just because of a mistake in the rewrite rule.

            I only used index.php/search of index.php?routestring=search manually typed to troubleshoot and to discover where the error came from.

            My URL rewrite diagnostics told me that /external was under water rewritten to index.php/external and that didn't work. The rewrite must be index.php?routestring=external and that did work.

            So I changed the rewrite rule from:

            Code:
             <rule name="Main Redirect" stopProcessing="true">
                                <match url="^(.*)$" ignoreCase="false" />
                                <conditions logicalGrouping="MatchAll">
                                    <add input="{REQUEST_FILENAME}" matchType="IsFile" ignoreCase="false" negate="true" />
                                    <add input="{REQUEST_FILENAME}" matchType="IsDirectory" ignoreCase="false" negate="true" />
                                </conditions>
                                <action type="Rewrite" url="index.php/{R:1}" />
                            </rule>
            To :

            Code:
            <rule name="Main Redirect" stopProcessing="true">
            <match url="^(.*)$" ignoreCase="false" />
            <conditions logicalGrouping="MatchAll">
            <add input="{REQUEST_FILENAME}" matchType="IsFile" ignoreCase="false" negate="true" />
            <add input="{REQUEST_FILENAME}" matchType="IsDirectory" ignoreCase="false" negate="true" />
            </conditions>
            <action type="Rewrite" url="index.php?routestring={R:1}" />
            </rule>
            And that solves the problem.

            The supplied web.config is incorrect for the 'Main Redirect' rule.

            Comment

            widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
            Working...
            X