Announcement

Collapse
No announcement yet.

Landing Page Error

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Landing Page Error

    Just installed 5.1.0. I use a page from the CMS articles as my website's home/landing page. And cannot get it to work now.

    Here's what I've tried so far:

    1. Using the existing article
    2. Read about creating a landing page in the new vBulletin software, so I then....
    3. HTML META Redirect
    • <META http-equiv="refresh" content="1;URL=http://www.everythingaquatic.net/forum/CMSLanding">
    • Get the same Error Message
      Couldn't find controller file for vB5_Frontend_Controller_

    Website: http://www.everythingaquatic.net
    PHP Version: 5.3.27
    MySQL Version: 5.5.29

    I have tried 2 types of 301 Redirects as well.....

    The one that was working with vBulletin 4.2.2 was the simple page redirect: Redirect 301 /index.htm http://www.everythingaquatic.net/forum/CMSLanding

    And the rule redirect

    RewriteEngine On
    RewriteCond %{HTTP_HOST} ^everythingaquatic\.net$
    RewriteRule (.*) http://www.everythingaquatic.net/$1 [R=301,L]
    RewriteRule ^$ forum/CMSLanding [L]

    What I noticed was that in all cases the URL has the parameter string "?routestring=content.php" tacked onto the end. The software is adding it which is causing the Error message. If I manually remove it from the browser's address bar the page will display. Is there something I can do to correct this? Or, is it another bug?

  • #2
    The vBulletin rewrites are doing their thing, and your custom rewrites are causing problems.

    Comment


    • #3
      Excuse me. I am doing what I have always done. The ONLY thing that has changed is that I upgraded from 4.2 to 5.1...guess that was my mistake. I should have never trusted that the upgraded code base was usable. It is unacceptable to add a parameter string to a valid URL and throw the controller error; and then to blame the 301 redirect. If the vBulletin code worked correctly the URL would be unchanged and the page would display.

      Comment


      • #4
        Your custom rewrites, are conflicting with the vBulletin 5 rewrites that make the software work. I don't know how else to explain this to you.

        Comment


        • #5
          This works:
          Redirect 301 /articles/index.htm http://www.everythingaquatic.net/forum/articles

          And this fails, browser sent to http://www.everythingaquatic.net/forum/articles?routestring=content.php:
          Redirect 301 /index.htm http://www.everythingaquatic.net/forum/articles

          Both redirects are pointed to the same URL. There is no reason for the parameter string to be tacked onto the end when redirecting from the site index vs redirecting from a different html index on the website.

          Check your code for the routestring parameter. The vBulletin rewrites are not working correctly 100% of the time.

          Comment


          • #6
            What if you remove your custom rewrites?

            Comment


            • #7
              Then the original HTML file is displayed. And vBulletin is out of the picture until a link is clicked that points to it.

              Comment


              • #8
                The .htaccess file in your /forum/ directory - did you add the line RewriteBase /forum/ below the line that enables the Rewrite engine? That may help limit the VB5 redirects to the /forum/ directory.

                Comment


                • #9
                  Why not just make your Articles page the Landing page for your site within the software?

                  Edit the Forums page in Site Builder. Save the page and change its route to /forums/.

                  Then edit your Articles page or whatever landing page you want. Save the page and change its route to /.

                  Should get the effect you want without custom .htaccess that will break everything else. In fact, you can edit any page and change its route when you save it to fit your needs.

                  Our default .htaccess is necessary to receive support on the software..
                  Translations provided by Google.

                  Wayne Luke
                  The Rabid Badger - a vBulletin Cloud demonstration site.
                  vBulletin 5 API - Full / Mobile
                  Vote for your favorite feature requests and the bugs you want to see fixed.

                  Comment


                  • #10
                    I will give that a try. But, the htaccess file is in my website's root directory, not the one packaged in vBulletin, and is used to redirect a few hundred pages. I simply used the same process for the site's landing page, but kept running into issues with every attempt. It shouldn't matter if a link was clicked, if a 301 redirect is triggered or any other means of moving about a site. When called outside of vBulletin, none of those methods would be aware of the parameter string to tack it onto the URL that is being called. That is coming from within the software.

                    Comment


                    • #11
                      Sorry to bring this up again; however, I am getting multiple errors from search engine attempts to scan my website with the known/indexed vb4.2.2 SEO Friendly link path.

                      For example, the search engines have the following URL indexed and are attempting to scan the page again: http://www.everythingaquatic.net/for...icPlantLibrary. When you attempt to navigate to that link, the same controller error appears.

                      This same page does exist in vb5.1.0. In fact, it has not been edited since the forum was upgraded. However, in 5.1 the SEO friendly URL is now http://www.everythingaquatic.net/for...-plant-library.

                      Is there an easy way to help redirect the now outdated SEO URLs generated in vb4 to work in vb5? Otherwise, I have thousands of pages in CMS; and if I now have to create 301s that will take weeks.

                      Any suggestions?

                      Comment


                      • #12
                        The problem is the link you provided isn't a link to a specific article. Specific articles such as-
                        Code:
                        http://www.everythingaquatic.net/forum/articles/aquatic-plant-library/149980-micro-sword-care-sheet
                        WILL forward correctly from the old URL to the new URL.

                        The old URL you provided was-
                        Code:
                        http://www.everythingaquatic.net/forum/content.php/45-AquaticPlantLibrary
                        Which I believe was a section- sections no longer exist in VB5 so there is no forward available.

                        Comment


                        • #13
                          Some of the links are pointed at sections/categories. Guess I will need to figure out the 301s for those. A shame too because they are clearly displayed in the Category listings; and now I have lost all PageRank my site had built up with vBulletin pages.

                          I did chop off the end of the old style link above, it should have read http://www.everythingaquatic.net/for...Library?page=4, or any of the other pages within this section/category of my CMS files. The new link style is /page4 in vb5.1. Makes no sense why this change cannot be processed to display the page. This unfortunately is not a parameter I can tell the search engines to ignore as I loose several indexed pages and would only have the first page remain indexed.

                          There are very specific links that the search engines are not able to find. For example,

                          http://www.everythingaquatic.net/for...e?postid=50385
                          http://www.everythingaquatic.net/for...h?postid=24922

                          With each one, if I drop the parameter string portion of the link then the page displays. For example

                          http://www.everythingaquatic.net/for...!?postid=90115
                          Drop the parameter string: http://www.everythingaquatic.net/for...ything-Aquatic!
                          Displays as: http://www.everythingaquatic.net/for...ything-aquatic

                          As a test I have added the postid parameter to the list to ignore. I am hoping that will help Google to call the correct URL so that vBulletin 5 can display it instead of the controller error. If you have any other ideas please let me know.

                          Comment


                          • #14
                            If you feel the system should be improved please use this link to make an Improvement Request in the software- http://tracker.vbulletin.com/secure/...91&issuetype=4

                            You can copy over what you are looking to have changed/added.

                            It would not hurt to link to this thread as well.

                            You can ignore fields you don't understand, the only important ones are Summary and Description.

                            Comment


                            • #15
                              Will do.

                              Comment

                              Related Topics

                              Collapse

                              Working...
                              X