Announcement

Collapse
No announcement yet.

CSS edits don't render

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Wayne Luke
    replied
    Are you using a CDN like Cloudflare? You need to flush the cache of said CDN every time you save the CSS. This will force the service to update faster.

    Leave a comment:


  • Lynne
    replied
    If you have any wrong CSS in the css_additional.css template, then anything you add after that will not be parsed. Have you tried going directly to the file at yoursite.com/css.php?styleid=xx&td=ltr&sheet=css_additional.css (change xx to the styleid you are using) and seeing what is there ? Or viewing it in firebug?

    Leave a comment:


  • maipoman
    replied
    Originally posted by Lynne View Post
    After you make the changes to the stylevars, click Maintenance > Clear System Cache. You also need to do a Force Refresh of your browser to force it to get the new CSS files.
    I've done that. It's not a cache issue.

    Leave a comment:


  • Lynne
    replied
    After you make the changes to the stylevars, click Maintenance > Clear System Cache. You also need to do a Force Refresh of your browser to force it to get the new CSS files.

    Leave a comment:


  • maipoman
    replied
    I'm afraid it doesn't. If by "put CSS back in the database" you mean set "Store CSS Stylesheets as Files?" to No. The CSS files in the new folder still don't update with the edits I make in Admin CP.

    If I keep "Store CSS as files" to No, not even the changes I made to stylevars apply - everything renders with the default template.

    I'm on a dedicated server, so there should be no other accounts on there.

    Leave a comment:


  • Joe D.
    replied
    It is possible the files are "owned" by the wrong account on your server.

    I suggest the following-

    1) First put CSS back in the database in Style & Language settings in the Admin CP

    2) rename the vbulletin_css folder on your server to vbulletin_css_old

    3) create a new vbulletin_css folder (it will be empty) chomod the folder to 777

    4) In Admin CP put CSS back into the file system

    See if it updates now...

    Leave a comment:


  • maipoman
    started a topic CSS edits don't render

    CSS edits don't render

    I've been trying for days to edit some of the css-templates, and adding to css_additional, but the changes just don't apply.

    Now I've discovered that it's the css-files in clientscript/vbulletin_css/ that don't update. If I go in and manually overwrite a css-file there, the changes does apply - but not when I edit the files in Admin CP. And if I run "Maintenance >> Rebuild Styles" all the changes I've made are lost. I've set properties on core/clientscript/vbulletin_css/ to 777 - so it should be writable!

    Any ideas?

Related Topics

Collapse

Working...
X