Announcement

Collapse
No announcement yet.

CAN'T START THE INSTALL PROCESS OF VB5

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • CAN'T START THE INSTALL PROCESS OF VB5

    Hello everybody,
    I'm trying to install vb5 from zero, after I couldn't upgrade from 4.2.2 to 5.
    i'm getting this error right after I start the process:
    i tried to install vb5 but I got this error:
    Action Required
    Unexpected Text: Action Required
    Unexpected Text:
    <br /> <b>Deprecated</b>: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in <b>/forum/RTvb5/core/includes/functions.php</b> on line <b>4369</b><br /> <?xml version="1.0" encoding="windows-1252"?> <upgrade> <message replace="0">Connection successful</message> <status>Status: Installing, Step 2 of 6</status> <longversion>install</longversion> <version>install</version> <nextstep>2</nextstep> <upgradenotice><![CDATA[<strong>Installing</strong>]]></upgradenotice> </upgrade>

    NOTE:server with NGINX, Mysql5.5.3, and php5.5.9, character UTF8

    I've followed all the instruction in vb manual, and i'm not sure what the problem is.
    any ideas?

  • #2
    Yes vB5 isn't compatible with PHP 5.5 yet. You have to use PHP 5.4.

    Comment


  • #3
    I know, but believe me it is not supported yet. That's why you get the deprecated messages. They are working on it with version 5.1 but still it doesn't work with it in my test environment.

    Comment


    • samerss
      samerss commented
      Editing a comment
      ok thanks. I'll take your advise and put php5.4
      I really got tired of this. it's been a week of trying to run my forum without any result.
      thanks again for your reply.

  • #4
    now php ver is 5.4.23
    still I have the same error !
    vb team help please.

    Comment


    • #5
      Hello samerss, could you try to disable php error reporting in your php.ini or in the vbulletin config files? I was able to get mine working even in php 5.5 when I disabled error reporting. (although php5.5 isn't really recommended for vb5)

      Comment


      • #6
        Hi trelis, I finally installed vb5. but i'm facing another problem now.
        after the install was finished, I cleared the install folder content and then pressed on the "go to admincp" button. but I see white page with "File not found".
        i'm not sure what to do next.
        I re-copied the install folder and ran the upgrade script, but nothing have changed.
        I appreciate any advise.
        thanks

        Comment


        • #7
          You are using nginx web server? This might have something to do with vb5 url-rewriting. Apparently, vb5 rewrites url to search-engine friendly ones, so your webserver should be able to support it. This is the .htaccess file you find in root folder.

          This should work out of the box if you are using Apache with mod_rewrite enabled. However, I am not sure for other web servers.

          Comment


          • samerss
            samerss commented
            Editing a comment
            thanks a lot trelis. you helped me indeed.

        Related Topics

        Collapse

        Working...
        X